Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027237
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-07-30 16:002014-09-29 06:01
ReporterjecharriView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revision80067e160ad9
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027237: Alerts notification are not executing always the same query

DescriptionAlerts notification are not executing always the same query

Notifications:
-Alert icon in the top of the window is doing:
select distinct(e.alertRule) from ADAlertRecipient e where e.alertRule.active = true and (e.userContact.id=? or (e.userContact.id = null and e.role.id = ?)))
and
select count(*) from AD_ALERT where COALESCE(to_char(STATUS), 'NEW')='NEW' AND AD_CLIENT_ID in ('A65074D0843147BEB4F13FF007B52F0A', '0') AND AD_ORG_ID in ('BE0AC4CFA26F4F408FD407033E4BFCF9', '9DB2E1269F0149EDBD0D00C53C7DAC73', '4525CC3279774C89AC745FE7627C701C', '504FD243C72E40ABBA834C73B5667EF7', '7C4A8703014F416CB5222163B9DB1BFE', '05830B2BCB9D477B9A3F22082634DFFF', '6C32D1DF2D504ADCA4FC5ABCFCDA18FF', 'BF22A3C7C9CD4F70814D871A2E4EE7A2', '6049CE77D04845969D328CA3731F033F', '2AA41098B0AA47C791B92AE5B1D40A99', 'DDD786B5320F4B19B19661A9CDBF74EA', '18164FB16A334FC8BF449DE217284031', 'E0522AE6B2EA446D85FD69B5CC416826', 'C11EF9BFAC03464C9B9E6925C0EE7F8C', 'C11077EB595D403AA87AFEBCC45CD83D', '387E977F25204A4DB5B6BED50554B168', '02BC27FC439147F6BB1DF655D03623C0', 'FB6777E278FD4ED08F9384450FEA3845', '5F0478879DED4E2CBF387B35A779569E', '0', 'B1269F493B1342BE8B4B75D11B995E0E', '83A0BB79EEDA4ECCB4BCFDF1A9A09466', 'C069750FD29C46BF98A0F1126496C711') AND AD_ALERTRULE_ID = '64DE8FF5E60143CABDF625890684D8BD' )
file
modules/org.openbravo.client.application/src/org/openbravo/client/application/AlertActionHandler.java

-Alert management window
as ar
where exists (select 1 from ar.aDAlertRecipientList as arr
    where arr.userContact.id = :user
      or (arr.userContact is null
          and arr.role.id = :role))
And the query is filtering by organization and client as default DAL query
File
modules/org.openbravo.client.application/src/org/openbravo/client/application/AlertManagementActionHandler.java

Due to that problem, the icon can show that there are some alerts in the system but the window alert management does not show any alert.
Steps To Reproduce-Create a role with access to "España Sur"
-Create an Alert for F&B but set organization "España Norte"
-In the alert recipient include created role
-Execute background alert process and create some alert with created alert rule

Login to ERP with created role, verify that you can see the alert in the icon of the top of the screen but if you go to Alert management window you are not able to see any alert
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0070266)
hgbot (developer)
2014-09-23 09:14

Repository: erp/devel/pi
Changeset: 80067e160ad94fd59acd851750ace39eab0d310c
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Sep 23 09:13:17 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/80067e160ad94fd59acd851750ace39eab0d310c [^]

fixed bug 27237: inconsistent alert count and list visualization

  When visualizing alerts in Alert Management window, only those rules visible
  (client/org) from current role were shown. But when counting active alerts to
  display in the nav bar icon, all rules were taken into account.

  Now rules taken into account are consistently filtering out non visible ones.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/AlertActionHandler.java
---
(0070349)
hudsonbot (developer)
2014-09-25 11:30

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/63604e8e17b7 [^]
Maturity status: Test
(0070481)
shankarb (developer)
2014-09-29 06:01

Code reviewed and verified in pi changeset 6514115544c4.

- Issue History
Date Modified Username Field Change
2014-07-30 16:00 jecharri New Issue
2014-07-30 16:00 jecharri Assigned To => dmiguelez
2014-07-30 16:00 jecharri Web browser => Google Chrome
2014-07-30 16:00 jecharri Modules => Core
2014-07-30 16:00 jecharri Triggers an Emergency Pack => No
2014-08-04 14:11 jonalegriaesarte Web browser Google Chrome => Google Chrome
2014-09-22 13:23 vmromanos Web browser Google Chrome => Google Chrome
2014-09-22 13:23 vmromanos Assigned To dmiguelez => AugustoMauch
2014-09-22 13:23 vmromanos Category 01. General setup => A. Platform
2014-09-23 09:10 alostale Review Assigned To => shankarb
2014-09-23 09:10 alostale Web browser Google Chrome => Google Chrome
2014-09-23 09:10 alostale Assigned To AugustoMauch => alostale
2014-09-23 09:14 hgbot Checkin
2014-09-23 09:14 hgbot Note Added: 0070266
2014-09-23 09:14 hgbot Status new => resolved
2014-09-23 09:14 hgbot Resolution open => fixed
2014-09-23 09:14 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/80067e160ad94fd59acd851750ace39eab0d310c [^]
2014-09-25 11:30 hudsonbot Checkin
2014-09-25 11:30 hudsonbot Note Added: 0070349
2014-09-29 06:01 shankarb Note Added: 0070481
2014-09-29 06:01 shankarb Status resolved => closed
2014-09-29 06:01 shankarb Fixed in Version => 3.0PR14Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker