Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027110
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2014-07-17 13:262014-12-30 23:23
ReportermaiteView Statuspublic 
Assigned Toreinaldoguerra 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision7a398be57eab
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027110: It is not possible to delete Sales Invoice header due to linked items

DescriptionIt is not possible to delete Sales Invoice header due to linked items
Steps To Reproduce1. Register Sales Order for any org and bp and Invoice Terms=Immediate. Add any line and process
2. Register Sales Invoice header and add line using "Create Lines from" process and previous order
3. Register Goods Shipment header and add line using "Create Lines from" process and previous invoice
4. Come back to Sales Invoice document and Reactivate it.
5. Delete invoice line
6. Try to delete invoice header and following message will be obtained "This record cannot be deleted because it is associated with other existing elements. Please see Linked Items"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0071233)
reinaldoguerra (developer)
2014-10-28 16:26

Test plan used:
1- Login into Openbravo ERP
2- Register Sales Order for any organization and business partner. Select Invoice Terms=Immediate.
3- Create a new line, add any product.
4- Press Book botton and select "Process" option
5- Register a new Sales Invoice header and add line using "Create Lines from" process selecting previous order.
6- Register a new Goods Shipment header and add line using "Create Lines from" process selecting previous invoice.
7- Come back to Sales Invoice document and Reactivate it.
8- Delete invoice line.
9- Now it is possible to delete invoice header.
(0071251)
hgbot (developer)
2014-10-29 17:29

Repository: erp/devel/pi
Changeset: 7a398be57eab5f92ce9f7f24d1b389728caf4790
Author: Reinaldo Guerra <reinaldo.guerra <at> peoplewalking.com>
Date: Tue Oct 28 00:38:28 2014 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/7a398be57eab5f92ce9f7f24d1b389728caf4790 [^]

Fixed bug 27110: It is not possible to delete Invoice header due to linked items

On delete action rule was changed in table m_inout for foreing key named: m_inout_c_invoice, to set null c_invoice record when deleting sales invoices related in goods shipment window.
Now is possible to delete a sales invoice although appears related in goods shipment window.

---
M src-db/database/model/tables/M_INOUT.xml
---
(0071252)
Sandrahuguet (developer)
2014-10-29 17:31

Code review + testing OK
(0072999)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-07-17 13:26 maite New Issue
2014-07-17 13:26 maite Assigned To => dmiguelez
2014-07-17 13:26 maite Modules => Core
2014-07-17 13:26 maite Triggers an Emergency Pack => No
2014-07-17 13:27 maite Issue Monitored: networkb
2014-09-29 16:12 jonalegriaesarte Target Version 3.0PR14Q4 => 3.0PR15Q1
2014-10-24 10:14 eduardo_Argal Status new => scheduled
2014-10-24 10:14 eduardo_Argal Assigned To dmiguelez => eduardo_Argal
2014-10-24 10:14 eduardo_Argal fix_in_branch => pi
2014-10-28 04:09 reinaldoguerra Assigned To eduardo_Argal => reinaldoguerra
2014-10-28 04:09 reinaldoguerra fix_in_branch pi =>
2014-10-28 16:26 reinaldoguerra Note Added: 0071233
2014-10-29 17:29 hgbot Checkin
2014-10-29 17:29 hgbot Note Added: 0071251
2014-10-29 17:29 hgbot Status scheduled => resolved
2014-10-29 17:29 hgbot Resolution open => fixed
2014-10-29 17:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7a398be57eab5f92ce9f7f24d1b389728caf4790 [^]
2014-10-29 17:31 Sandrahuguet Review Assigned To => Sandrahuguet
2014-10-29 17:31 Sandrahuguet Note Added: 0071252
2014-10-29 17:31 Sandrahuguet Status resolved => closed
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072999


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker