Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027066
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacetrivialalways2014-07-14 17:552014-09-01 06:38
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revision3a731d082a0d
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027066: When autocompleting date fields the format defined in Openbravo.properties is not used

DescriptionWhen autocompleting date fields the format defined in Openbravo.properties is not used
Steps To ReproduceDefine the date formats to be separated by / instead of - in the Openbravo.properties file
   As group admin role:
      Open the Payment report window
      Enter 010114 in the Due date From field and push the Tab key
      Check the date is updated: 01/01/2014
      Launch the report
      You will get the following error:
"org.hibernate.exception.SQLGrammarException: could not execute query"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0069718)
AugustoMauch (developer)
2014-08-25 18:09

The bug is located in the getDateTime function of DateTextBox.js. getDateTime calls to purgeDateFormat, which among other things it does the following:

  str_format = str_format.replace("/","-").replace("/","-").replace("/","-");

This modifies the date format, changing the date separator from '/' to '-'.
(0069835)
hgbot (developer)
2014-08-28 14:54

Repository: erp/devel/pi
Changeset: 3a731d082a0d6365d104ffe93893a043d7048e33
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Aug 28 14:52:46 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3a731d082a0d6365d104ffe93893a043d7048e33 [^]

Fixes issue 27066: Dojo autocompleting changes the date separator

In the autocompleting process, dojo needs to use the '-' date separator. The problem was that after doing the autocompletion it was not respecting the original date separator, so if it used '/', this date 01/02/03 would to autocompleted to 01-02-2003.

To fix this the date separator is saved before purging the date format.

---
M web/js/dojo/dojo.js
---
(0069859)
hudsonbot (developer)
2014-08-29 15:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/af520c9729b9 [^]
Maturity status: Test
(0069874)
shankarb (developer)
2014-09-01 06:38

Code reviewed and verified in pi changeset 611572b5205f

- Issue History
Date Modified Username Field Change
2014-07-14 17:55 ngarcia New Issue
2014-07-14 17:55 ngarcia Assigned To => dbaz
2014-07-14 17:55 ngarcia Modules => Core
2014-07-14 17:55 ngarcia Triggers an Emergency Pack => No
2014-07-14 17:55 ngarcia Assigned To dbaz => jonalegriaesarte
2014-07-14 17:55 ngarcia Issue Monitored: networkb
2014-07-14 18:56 heccam Issue Monitored: heccam
2014-07-24 13:48 jonalegriaesarte Assigned To jonalegriaesarte => AugustoMauch
2014-08-05 13:35 AugustoMauch Target Version => 3.0PR14Q4
2014-08-25 18:09 AugustoMauch Note Added: 0069718
2014-08-28 14:53 AugustoMauch Issue Monitored: shankarb
2014-08-28 14:53 AugustoMauch Review Assigned To => shankarb
2014-08-28 14:54 hgbot Checkin
2014-08-28 14:54 hgbot Note Added: 0069835
2014-08-28 14:54 hgbot Status new => resolved
2014-08-28 14:54 hgbot Resolution open => fixed
2014-08-28 14:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3a731d082a0d6365d104ffe93893a043d7048e33 [^]
2014-08-29 15:53 hudsonbot Checkin
2014-08-29 15:53 hudsonbot Note Added: 0069859
2014-09-01 06:38 shankarb Note Added: 0069874
2014-09-01 06:38 shankarb Status resolved => closed
2014-09-01 06:38 shankarb Fixed in Version => 3.0PR14Q4
2014-09-01 17:16 ngarcia Relationship added related to 0027518
2014-09-01 17:16 ngarcia Relationship deleted related to 0027518


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker