Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027028
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-07-07 18:082014-07-08 16:30
ReporterjecharriView Statuspublic 
Assigned Todbaz 
PriorityurgentResolutionopenFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027028: Different behavior between grid and form showing "Absolute Time" reference

DescriptionDifferent behavior between grid and form showing "Absolute Time" reference
Steps To Reproduce-Define a Openbravo.properties with the following settings
dateFormat.js=%m-%d-%Y
dateFormat.sql=MM-DD-YYYY
dateFormat.java=MM/dd/yyyy
dateTimeFormat.java=MM/dd/yyyy hh:mm a
dateTimeFormat.sql=MM-DD-YYYY HH24:MI:SS

-After that compile to apply the changes
-Login as "system" and go to "Tables and columns"
-Choose table "AD_Process_Request" and column "start_time"
-Change the reference to "absolute time"
-Compile and restart tomcat

-Login to ERP and go to window "process request"

Verify that in grid you see in 24H format and in grip you see 12H format

TagsNo tags attached.
Attached Filespng file icon form.png [^] (54,598 bytes) 2014-07-07 18:08


png file icon grid.png [^] (56,756 bytes) 2014-07-07 18:08

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 00259363.0PR14Q3 closeddbaz DateTime reference format support hh:mm:ss a 

-  Notes
(0068559)
dbaz (developer)
2014-07-08 16:30

The issue was solved in Q3 during this project:

https://issues.openbravo.com/view.php?id=25936 [^]
(0068560)
jecharri (developer)
2014-07-08 16:30

Fixed in issue https://issues.openbravo.com/view.php?id=25936 [^]

- Issue History
Date Modified Username Field Change
2014-07-07 18:08 jecharri New Issue
2014-07-07 18:08 jecharri Assigned To => AugustoMauch
2014-07-07 18:08 jecharri File Added: form.png
2014-07-07 18:08 jecharri Modules => Core
2014-07-07 18:08 jecharri Triggers an Emergency Pack => No
2014-07-07 18:08 jecharri File Added: grid.png
2014-07-08 09:40 alostale Assigned To AugustoMauch => dbaz
2014-07-08 16:29 dbaz Relationship added related to 0025936
2014-07-08 16:30 dbaz Review Assigned To => dbaz
2014-07-08 16:30 dbaz Note Added: 0068559
2014-07-08 16:30 dbaz Status new => closed
2014-07-08 16:30 dbaz Resolution open => unable to reproduce
2014-07-08 16:30 jecharri Review Assigned To dbaz =>
2014-07-08 16:30 jecharri Note Added: 0068560
2014-07-08 16:30 jecharri Resolution unable to reproduce => open


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker