Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026980
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-06-30 20:032014-08-08 18:52
ReporterjecharriView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revision3948973fcaaf
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toshankarb
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026980: When you export to excel window organization the order is not the same

DescriptionWhen you export to excel window organization the order is not the same
Steps To Reproduce-go to window "organization"
-order by organization type

If you export to excel the order is not the same.

Another problem:
-select and organization and change to tree view
-if you export, the order is not the same in the excel file
TagsNo tags attached.
Attached Files? file icon fix-26980.export [^] (1,762 bytes) 2014-07-02 11:34

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00269963.0PR14Q4 closedinigosanchez Disable export to CSV in tree view 

-  Notes
(0068500)
alostale (developer)
2014-07-02 11:06

This issue happens when toggling sorting in a non primitive (FK) property.

So if grid is opened and filtered by another field (i.e. Name), then ascending by Org Type and exported it works fine. If afterwards Org Type is ordered descendingly it fails.
(0068503)
alostale (developer)
2014-07-02 11:34

This issue has been split in two:
-Current one for csv ordering
-0026996 for exporting in tree view
(0068504)
alostale (developer)
2014-07-02 11:34

attached fix as currently pi is frozen during release process
(0068524)
hgbot (developer)
2014-07-03 08:30

Repository: erp/devel/pi
Changeset: 3948973fcaaf5c000bd347921c5d353486ac8eb4
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Jul 02 11:33:10 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3948973fcaaf5c000bd347921c5d353486ac8eb4 [^]

fixed bug 26980: order is not kept when exporting to csv

  When toggling sorting (asc-desc) in a FK property and grid is exported to csv,
  sorting is not preserved.

  The problem is caused by SC's ListGrid.getSortField which is returning null in
  this situation. This fix prevents using this function using getSort which works
  correctly.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0068610)
shankarb (developer)
2014-07-14 11:01

Code reviewed and verified in pi changeset 022f33b5b771.
(0069130)
hudsonbot (developer)
2014-08-08 18:52

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4450016dee64 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-06-30 20:03 jecharri New Issue
2014-06-30 20:03 jecharri Assigned To => AugustoMauch
2014-06-30 20:03 jecharri Web browser => Google Chrome
2014-06-30 20:03 jecharri Modules => Core
2014-06-30 20:03 jecharri Triggers an Emergency Pack => No
2014-07-02 11:06 alostale Note Added: 0068500
2014-07-02 11:19 alostale Relationship added related to 0026996
2014-07-02 11:34 alostale Note Added: 0068503
2014-07-02 11:34 alostale File Added: fix-26980.export
2014-07-02 11:34 alostale Note Added: 0068504
2014-07-02 11:35 alostale Assigned To AugustoMauch => alostale
2014-07-03 08:28 alostale Review Assigned To => shankarb
2014-07-03 08:28 alostale Web browser Google Chrome => Google Chrome
2014-07-03 08:30 hgbot Checkin
2014-07-03 08:30 hgbot Note Added: 0068524
2014-07-03 08:30 hgbot Status new => resolved
2014-07-03 08:30 hgbot Resolution open => fixed
2014-07-03 08:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3948973fcaaf5c000bd347921c5d353486ac8eb4 [^]
2014-07-14 11:01 shankarb Note Added: 0068610
2014-07-14 11:01 shankarb Status resolved => closed
2014-07-14 11:01 shankarb Fixed in Version => PR14Q4
2014-08-08 18:52 hudsonbot Checkin
2014-08-08 18:52 hudsonbot Note Added: 0069130


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker