Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026968
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformtrivialhave not tried2014-06-30 12:402014-08-08 18:52
ReporteralostaleView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revisiond90e33674f60
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026968: jUnit test cases falling in latest jdk6 and jdk7

DescriptionjUnit test cases are failing when they are executed latest version of JDK6 and in any JDK7.

Problem is some of these test cases rely the order each test is executed (based on method name) which is not valid anymore.
Steps To ReproduceSee failing test cases
https://ci.openbravo.com/view/try/job/try-checks-pgsql/397/#showFailuresLink [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0027107 closedinigosanchez Some more junit testcase ordering problems (with latest java6 updates +java7) 

-  Notes
(0068526)
hgbot (developer)
2014-07-03 09:36

Repository: erp/devel/pi
Changeset: d90e33674f60e3b18455d15c22db9958fad1e682
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Jul 02 13:09:12 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d90e33674f60e3b18455d15c22db9958fad1e682 [^]

fixed bug 26968: jUnit test cases are failing because execution order in JDK7
Problem is some of these test cases rely the order each test is executed (based on method name) which
is not valid anymore. Solved the problem by forcing the required execution order.

---
M src-test/org/openbravo/test/security/EntityAccessTest.java
M src-test/org/openbravo/test/webservice/WSUpdateTest.java
M src-test/org/openbravo/test/xml/EntityXMLImportTestBusinessObject.java
---
(0068527)
alostale (developer)
2014-07-03 09:37

Code reviewed
Tested by passing try
(0069131)
hudsonbot (developer)
2014-08-08 18:52

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4450016dee64 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-06-30 12:40 alostale New Issue
2014-06-30 12:40 alostale Assigned To => AugustoMauch
2014-06-30 12:40 alostale Modules => Core
2014-06-30 12:40 alostale Triggers an Emergency Pack => No
2014-06-30 12:40 alostale Target Version => PR14Q4
2014-06-30 12:46 alostale Assigned To AugustoMauch => inigosanchez
2014-06-30 14:25 shuehner Issue Monitored: shuehner
2014-07-03 09:35 alostale Review Assigned To => alostale
2014-07-03 09:36 hgbot Checkin
2014-07-03 09:36 hgbot Note Added: 0068526
2014-07-03 09:36 hgbot Status new => resolved
2014-07-03 09:36 hgbot Resolution open => fixed
2014-07-03 09:36 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d90e33674f60e3b18455d15c22db9958fad1e682 [^]
2014-07-03 09:36 alostale Status resolved => closed
2014-07-03 09:36 alostale Fixed in Version => PR14Q4
2014-07-03 09:37 alostale Note Added: 0068527
2014-07-17 10:36 shuehner Relationship added related to 0027107
2014-08-08 18:52 hudsonbot Checkin
2014-08-08 18:52 hudsonbot Note Added: 0069131


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker