Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026806
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Cash upcriticalhave not tried2014-06-05 18:072014-10-04 21:38
ReporteradrianromeroView Statuspublic 
Assigned Toszapata 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision3525b545fb44
ProjectionnoneETAnoneTarget VersionRR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toszapata
Regression levelCoding ( Testing )
Regression date2014-05-17
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.cds/file/tip/web/org.openbravo.retail.posterminal/js/closecash/view/tabcashpayments.js [^]
Triggers an Emergency PackNo
Summary

0026806: The total expected in the Count cash step in Cash up is always zero

DescriptionIn the count cash step of the cashup process the expected amount always says zero. You can check it is wrong if you go to the next step where all payments are sumarized.
Steps To ReproduceIn description
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0067788)
adrianromero (manager)
2014-06-05 18:25

The line that sets the value to 0 is
https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e7c8bb410309#l1.27 [^]
(0068193)
hgbot (developer)
2014-06-19 23:13

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 3145e5d7233686ca525c033014790108ac712b68
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Thu Jun 19 23:13:38 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3145e5d7233686ca525c033014790108ac712b68 [^]

Fixed issue 26806: now the total is fixed and the cashup total deposit info

---
M web/org.openbravo.retail.posterminal/js/closecash/model/cashup-model.js
---
(0068196)
Orekaria (administrator)
2014-06-19 23:36

The i26806_CashupTotalNotShownInStep2 test has been added to pi-mobile to verify that the issue is fixed
(0068755)
marvintm (developer)
2014-07-21 11:57

The issue was not completely fixed. The previous changeset is correct, but an additional change is needed.
(0068756)
hgbot (developer)
2014-07-21 12:00

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 3525b545fb44c0a7197e3c72d22b0c42e41bc2f5
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Jul 21 11:59:43 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3525b545fb44c0a7197e3c72d22b0c42e41bc2f5 [^]

Fixed issue 26806. Now the total expected will always be correct.

---
M web/org.openbravo.retail.posterminal/js/closecash/view/closecash.js
---
(0068761)
Orekaria (administrator)
2014-07-21 12:47

Checked in rev. 3713
(0070135)
sureshbabu (reporter)
2014-09-16 09:36

able to reproduce the issue in live builds (postgres context)
(0070713)
szapata (developer)
2014-10-04 21:38

Not happening anymore.

- Issue History
Date Modified Username Field Change
2014-06-05 18:07 adrianromero New Issue
2014-06-05 18:07 adrianromero Assigned To => malsasua
2014-06-05 18:07 adrianromero Triggers an Emergency Pack => No
2014-06-05 18:23 adrianromero Regression level => Coding ( Testing )
2014-06-05 18:23 adrianromero Regression date => 2014-05-17
2014-06-05 18:23 adrianromero Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e7c8bb410309 [^]
2014-06-05 18:23 adrianromero Assigned To malsasua => Orekaria
2014-06-05 18:25 adrianromero Note Added: 0067788
2014-06-06 08:59 Orekaria Regression introduced by commit https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e7c8bb410309 [^] => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.cds/file/tip/web/org.openbravo.retail.posterminal/js/closecash/view/tabcashpayments.js [^]
2014-06-19 23:13 hgbot Checkin
2014-06-19 23:13 hgbot Note Added: 0068193
2014-06-19 23:13 hgbot Status new => resolved
2014-06-19 23:13 hgbot Resolution open => fixed
2014-06-19 23:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3145e5d7233686ca525c033014790108ac712b68 [^]
2014-06-19 23:36 Orekaria Note Added: 0068196
2014-06-27 14:09 marvintm Review Assigned To => marvintm
2014-06-27 14:09 marvintm Status resolved => closed
2014-06-27 14:09 marvintm Fixed in Version => RR14Q3
2014-07-21 11:57 marvintm Note Added: 0068755
2014-07-21 11:57 marvintm Status closed => new
2014-07-21 11:57 marvintm Resolution fixed => open
2014-07-21 11:57 marvintm Fixed in Version RR14Q3 =>
2014-07-21 12:00 hgbot Checkin
2014-07-21 12:00 hgbot Note Added: 0068756
2014-07-21 12:00 hgbot Status new => resolved
2014-07-21 12:00 hgbot Resolution open => fixed
2014-07-21 12:00 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3145e5d7233686ca525c033014790108ac712b68 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3525b545fb44c0a7197e3c72d22b0c42e41bc2f5 [^]
2014-07-21 12:47 Orekaria Review Assigned To marvintm => Orekaria
2014-07-21 12:47 Orekaria Note Added: 0068761
2014-07-21 12:47 Orekaria Status resolved => closed
2014-07-21 12:47 Orekaria Fixed in Version => RR14Q4
2014-09-16 09:36 sureshbabu Assigned To Orekaria => szapata
2014-09-16 09:36 sureshbabu Note Added: 0070135
2014-09-16 09:36 sureshbabu Status closed => new
2014-09-16 09:36 sureshbabu Resolution fixed => open
2014-09-16 09:36 sureshbabu Fixed in Version RR14Q4 =>
2014-10-04 21:38 szapata Review Assigned To Orekaria => szapata
2014-10-04 21:38 szapata Note Added: 0070713
2014-10-04 21:38 szapata Status new => closed
2014-10-04 21:38 szapata Resolution open => fixed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker