Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026767
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-06-03 08:502014-10-01 16:47
ReporteralostaleView Statuspublic 
Assigned Toguillermogil 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revision7f57d14061b9
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-12-16
Regression introduced in release3.0MP31
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/08e8dd69188fc9a592ce4cc0efb5f5ec425cee34 [^]
Triggers an Emergency PackNo
Summary

0026767: filters not working in Process Definition > Parameter

DescriptionFiltering Parameter Tab in Process Definition window is not working.
Steps To Reproduce-Log in as System Admin
-Go to Process Definition window and select APRM_PaymentProposalPickEdit record
-Go to Parameter window
-In DB Column Name filter type g
  * No record is shown -> ERROR
-Click refresh button
  * No record is shown -> ERROR
  * The criteria sent to backed is:
    criteria: [{"fieldName":"dBColumnName","operator":"iContains","value":"g"},
               {"fieldName":"obuiappProcess$_identifier","operator":"iEquals","value":"8D0D32CC819E449D9A08E0459B482963"}, <- Note this shouldn't appear
               {"fieldName":"obuiappProcess","operator":"equals","value":"8D0D32CC819E449D9A08E0459B482963"}]
-Remove filter typed g in Column Name
  * No record is shown -> ERROR
-Type g again and click on remove filter icon
  * Records are shown -> OK
Proposed SolutionWhen fixing this issue, check which other windows might be affected by this problem to determine its severity.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0026481 closedguillermogil Filtering not working when parent column is displayed in grid 
related to feature request 0026775 neweduardo_Argal Remove parent fields on grid view 

-  Notes
(0067700)
alostale (developer)
2014-06-03 08:54

Regression present since 3.0MP31
(0067722)
hgbot (developer)
2014-06-03 17:27

Repository: erp/devel/pi
Changeset: 7f57d14061b9785fcead3cd3b345d70a185cdda5
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Tue Jun 03 12:26:30 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7f57d14061b9785fcead3cd3b345d70a185cdda5 [^]

Fixed issue 26767:filters not working in Process Definition

Removed wrong criterias

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0067734)
alostale (developer)
2014-06-04 09:32

Code reviewed: pending comment in code to explain the case
Tested: executed test cases explained in the steps to reproduce
(0067738)
hgbot (developer)
2014-06-04 09:38

Repository: erp/devel/pi
Changeset: fd3b5f95efb6dbc30902dcaa11cf543e818b92c0
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Wed Jun 04 09:37:57 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fd3b5f95efb6dbc30902dcaa11cf543e818b92c0 [^]

Related to issue 26767:filters not working in Process Definition

Added comments to explain the case

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0067874)
hudsonbot (developer)
2014-06-10 22:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/763f16c2ad2e [^]
Maturity status: Test
(0067878)
hudsonbot (developer)
2014-06-10 22:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/763f16c2ad2e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-06-03 08:50 alostale New Issue
2014-06-03 08:50 alostale Assigned To => AugustoMauch
2014-06-03 08:50 alostale Modules => Core
2014-06-03 08:50 alostale Triggers an Emergency Pack => No
2014-06-03 08:54 alostale Regression level => Production - Confirmed Stable
2014-06-03 08:54 alostale Note Added: 0067700
2014-06-03 08:54 alostale Steps to Reproduce Updated View Revisions
2014-06-03 08:54 alostale Proposed Solution updated
2014-06-03 08:55 alostale Target Version => PR14Q3
2014-06-03 09:00 guillermogil Assigned To AugustoMauch => guillermogil
2014-06-03 11:30 guillermogil Regression date => 2013-12-16
2014-06-03 11:30 guillermogil Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/08e8dd69188fc9a592ce4cc0efb5f5ec425cee34 [^]
2014-06-03 12:03 guillermogil Issue Monitored: alostale
2014-06-03 12:03 guillermogil Review Assigned To => alostale
2014-06-03 17:23 guillermogil Relationship added has duplicate 0026481
2014-06-03 17:27 hgbot Checkin
2014-06-03 17:27 hgbot Note Added: 0067722
2014-06-03 17:27 hgbot Status new => resolved
2014-06-03 17:27 hgbot Resolution open => fixed
2014-06-03 17:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7f57d14061b9785fcead3cd3b345d70a185cdda5 [^]
2014-06-04 09:32 alostale Note Added: 0067734
2014-06-04 09:32 alostale Status resolved => closed
2014-06-04 09:32 alostale Fixed in Version => PR14Q3
2014-06-04 09:38 hgbot Checkin
2014-06-04 09:38 hgbot Note Added: 0067738
2014-06-04 09:44 guillermogil Relationship added related to 0026775
2014-06-10 22:23 hudsonbot Checkin
2014-06-10 22:23 hudsonbot Note Added: 0067874
2014-06-10 22:23 hudsonbot Checkin
2014-06-10 22:23 hudsonbot Note Added: 0067878
2014-10-01 16:47 plujan Regression introduced in release => 3.0MP31


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker