Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026544
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-05-14 09:402014-10-01 16:38
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisione44119bb1d49
ProjectionnoneETAnoneTarget Versionpi
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-10-07
Regression introduced in release3.0MP29
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/94d0fb15191969d20c2f89b919bec8a95ad33110 [^]
Triggers an Emergency PackNo
Summary

0026544: Auxiliary inputs are not properly calculated in grid view in some cases

DescriptionAuxiliary inputs are not being properly calculated in the grid view when a new record is selected if these conditions are met:
- The auxiliary input is based in a column of the same table where the auxiliary input is defined
- That column is not shown in the grid view
Steps To ReproduceAs F&B Admin:
- Open Sales Invoice. The header tab has an auxiliary input called DOCBASETYPE.
- Open the Developer Tools and click on a record in the header tab.
- Check that the FIC returns {} for the DOCBASETYPE auxiliary input. This is wrong.
- Double click on the record to open it in form view.
- Check that t he FIC now returns {value:'ARI', classicValue:'ARI'} for the DOCBASETYPE auxiliary input. This is right, this is the value that should have also been returned when the record was selected in the grid.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0067130)
hgbot (developer)
2014-05-14 13:29

Repository: erp/devel/pi
Changeset: e44119bb1d49e8881da4c8a10a1b350ce755ca56
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed May 14 13:26:15 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e44119bb1d49e8881da4c8a10a1b350ce755ca56 [^]

Fixes issue 26544: Auxiliary inputs are not properly calculated in grid view

The problem was that:
- The FIC needed all the columns used in the auxiliary inputs sent in the FIC request
- If those columns where not shown in the grid they were not being sent in the FIC request, so the FIC was not able to compute the auxiliary inputs properly

To fix this, all the columns used in the auxiliary inputs of a tab are included as required grid properties.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
---
(0067147)
shankarb (developer)
2014-05-15 13:17

code reviewed and verified in pi changeset cb4a3042e3a5
(0067168)
hudsonbot (developer)
2014-05-15 17:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8d6658b982c0 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-05-14 09:40 AugustoMauch New Issue
2014-05-14 09:40 AugustoMauch Assigned To => AugustoMauch
2014-05-14 09:40 AugustoMauch Modules => Core
2014-05-14 09:40 AugustoMauch Triggers an Emergency Pack => No
2014-05-14 09:41 AugustoMauch Regression level => Production - Confirmed Stable
2014-05-14 09:41 AugustoMauch Regression date => 2013-10-07
2014-05-14 09:41 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/94d0fb15191969d20c2f89b919bec8a95ad33110 [^]
2014-05-14 13:27 AugustoMauch Issue Monitored: shankarb
2014-05-14 13:27 AugustoMauch Review Assigned To => shankarb
2014-05-14 13:29 hgbot Checkin
2014-05-14 13:29 hgbot Note Added: 0067130
2014-05-14 13:29 hgbot Status new => resolved
2014-05-14 13:29 hgbot Resolution open => fixed
2014-05-14 13:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e44119bb1d49e8881da4c8a10a1b350ce755ca56 [^]
2014-05-15 13:17 shankarb Note Added: 0067147
2014-05-15 13:17 shankarb Status resolved => closed
2014-05-15 17:34 hudsonbot Checkin
2014-05-15 17:34 hudsonbot Note Added: 0067168
2014-10-01 16:38 plujan Regression introduced in release => 3.0MP29


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker