Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026511
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2014-05-12 12:252014-12-30 23:28
ReporterjecharriView Statuspublic 
Assigned Toumartirena 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision57da281af0de
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026511: Impossible to delete a order line after removing the picking list and reservation

DescriptionImpossible to delete a order line after removing the picking list and reservation
Steps To Reproduce-Create a sales order with a line
-mark the line as manual reservation
-Book it and create the picking list

Go to window stock reservation window:
-Select the reservation
-Press in "Put on Hold" and reactivate the reservation
-Delete the header
-Go to Picking list and cancel it

Go to order and reactivate it:
-you should be able to delete the line, but when you try it, you will receive error "Batch update returned unexpected row count from update [0]; actual row count: 0; expected: 1"

The problem is that when you cancel the picking list, this is creating a record in window stock reservation but without any reservation
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 00276803.0PR15Q1 closedfsoto82 Error not human readable when removing a sales order line with a reservation assigned 

-  Notes
(0072783)
hgbot (developer)
2014-12-22 19:16

Repository: erp/devel/pi
Changeset: 57da281af0de6af09bf2849f608cda4484d1964b
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Mon Dec 22 19:12:07 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/57da281af0de6af09bf2849f608cda4484d1964b [^]

Fixes Issue 26511: Display correct error message while deleting the orderline.

The problem on this issue is that the trigger is not able to delete the related reservation of the orderline and the given error is displayed. So in this case the error message displayed has been improved to warn the user that needs to remove the reservation manually before deleting the Sales Order Line.

---
M src-db/database/model/triggers/C_ORDERLINE_TRG.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0072854)
Sandrahuguet (developer)
2014-12-29 16:38

Code review + testing OK
(0073259)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-05-12 12:25 jecharri New Issue
2014-05-12 12:25 jecharri Assigned To => caristu
2014-11-26 15:08 fsoto82 Relationship added related to 0027680
2014-12-22 19:07 umartirena Relationship replaced has duplicate 0027680
2014-12-22 19:16 hgbot Checkin
2014-12-22 19:16 hgbot Note Added: 0072783
2014-12-22 19:16 hgbot Status new => resolved
2014-12-22 19:16 hgbot Resolution open => fixed
2014-12-22 19:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/57da281af0de6af09bf2849f608cda4484d1964b [^]
2014-12-23 10:00 umartirena Assigned To caristu => Sandrahuguet
2014-12-23 10:57 Sandrahuguet Assigned To Sandrahuguet => umartirena
2014-12-29 15:22 Sandrahuguet Review Assigned To => Sandrahuguet
2014-12-29 16:36 Sandrahuguet Project Modules => Openbravo ERP
2014-12-29 16:37 Sandrahuguet Modules => Core
2014-12-29 16:37 Sandrahuguet Triggers an Emergency Pack => No
2014-12-29 16:37 Sandrahuguet Category Warehouse Picking => 04. Warehouse management
2014-12-29 16:38 Sandrahuguet Note Added: 0072854
2014-12-29 16:38 Sandrahuguet Status resolved => closed
2014-12-29 16:38 Sandrahuguet Fixed in Version => 3.0PR15Q1
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073259


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker