Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026495
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminorhave not tried2014-05-08 13:432014-05-19 09:44
ReporterjonalegriaesarteView Statuspublic 
Assigned Toguillermogil 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchpiFixed in SCM revisioncb4a3042e3a5
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026495: External link entry in menu is not working

DescriptionExternal link entry in menu is not working
Steps To Reproduce- Menu, create a new entry.
- Action: External link
- Set a link: www.google.es
- Access using administatrion role
- System shows an error when using the link see attached
TagsNo tags attached.
Attached Filespng file icon errorexternallink.png [^] (60,395 bytes) 2014-05-08 13:45

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0067027)
shuehner (administrator)
2014-05-08 15:30

Hi i think to remember something similar:

Maybe worth testing button a proper (complete) url into the menu-item:
http://www.google.es [^]
https://www.google.es [^]

Maybe that makes a difference (don't remember perfectly)
(0067141)
hgbot (developer)
2014-05-15 11:55

Repository: erp/devel/pi
Changeset: cb4a3042e3a5940afd2472ce54fa1926da79bed3
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Thu May 15 11:53:24 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cb4a3042e3a5940afd2472ce54fa1926da79bed3 [^]

Fixed issue 26495:External link entry in menu is not working

openlinkinbrowser field has been created to open the link in a new browser's tab instead open it in an Openbravo's tab.
This has been done due browser's restrictions.
Also External link icon on Quick Launch has been added.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MENU.xml
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/QuickLaunchDataSource.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/templates/application-menu.js.ftl
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-application-menu.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.application/web/org.openbravo.userinterface.smartclient/openbravo/skins/Default/org.openbravo.client.application/ob-navigation-bar-styles.js
M modules/org.openbravo.client.myob/web/org.openbravo.client.myob/js/ob-myopenbravo.js
M modules/org.openbravo.client.myob/web/org.openbravo.userinterface.smartclient/openbravo/skins/Default/org.openbravo.client.myob/ob-myopenbravo-styles.js
M src-db/database/model/tables/AD_MENU.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
M src-db/database/sourcedata/AD_MENU.xml
---
(0067144)
hgbot (developer)
2014-05-15 12:24

Repository: erp/devel/pi
Changeset: ccf37f6a65a2c99fe3dc44b5fdf58631a6a7d2b9
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Thu May 15 12:19:17 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ccf37f6a65a2c99fe3dc44b5fdf58631a6a7d2b9 [^]

Related to issue 26495:External link entry in menu

Added missing exported entries

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_MENU.xml
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_MENU.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_MENU.xml
M modules/org.openbravo.financial.paymentreport/src-db/database/sourcedata/AD_MENU.xml
M modules/org.openbravo.reports.ordersawaitingdelivery/src-db/database/sourcedata/AD_MENU.xml
M modules/org.openbravo.service.datasource/src-db/database/sourcedata/AD_MENU.xml
M modules/org.openbravo.service.integration.google/src-db/database/sourcedata/AD_MENU.xml
---
(0067149)
hgbot (developer)
2014-05-15 13:50

Repository: erp/devel/pi
Changeset: a3b9b2e4b83abd88a1d5a0ba13dafb8f53631543
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Thu May 15 13:49:17 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a3b9b2e4b83abd88a1d5a0ba13dafb8f53631543 [^]

Related to issue 26495:External link entry in menu

Modified AD_MENU.xml

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MENU.xml
---
(0067158)
hgbot (developer)
2014-05-15 16:44

Repository: erp/devel/pi
Changeset: fd2538d17c0b42c0e7d47a1eb5b90c57271f3799
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Thu May 15 16:44:29 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fd2538d17c0b42c0e7d47a1eb5b90c57271f3799 [^]

Related to issue 26495:External link entry in menu

Added missing onCreateDefault

---
M src-db/database/model/tables/AD_MENU.xml
---
(0067187)
hudsonbot (developer)
2014-05-16 07:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/649d0b7eba54 [^]
Maturity status: Test
(0067189)
hudsonbot (developer)
2014-05-16 07:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/649d0b7eba54 [^]
Maturity status: Test
(0067190)
hudsonbot (developer)
2014-05-16 07:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/649d0b7eba54 [^]
Maturity status: Test
(0067191)
hudsonbot (developer)
2014-05-16 07:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/649d0b7eba54 [^]
Maturity status: Test
(0067240)
AugustoMauch (developer)
2014-05-18 19:09

I could not find a way to open an external link in an openbravo tab. Is it possible? If it is not possible, then the new Open Link in New Tab flag would not make any sense.
(0067242)
guillermogil (developer)
2014-05-19 09:29

In order to open an external link in an Openbravo tab it is needed to use an embed link.
By default 'X-Frame-Options' are set to 'SAMEORIGIN' and it is not possible to show it in a frame.

e.g.-
* //www.youtube.com/embed/vnCQe6ihoik -> can be shown in an Openbravo tab
* www.google.com -> cannot be shown in an Openbravo tab
(0067243)
AugustoMauch (developer)
2014-05-19 09:44

Using an embeddable link this functionality work as intended.

- Issue History
Date Modified Username Field Change
2014-05-08 13:43 jonalegriaesarte New Issue
2014-05-08 13:43 jonalegriaesarte Assigned To => AugustoMauch
2014-05-08 13:43 jonalegriaesarte Modules => Core
2014-05-08 13:43 jonalegriaesarte Triggers an Emergency Pack => No
2014-05-08 13:45 jonalegriaesarte File Added: errorexternallink.png
2014-05-08 15:30 shuehner Note Added: 0067027
2014-05-12 17:04 guillermogil Assigned To AugustoMauch => guillermogil
2014-05-14 09:09 guillermogil Relationship added related to 0021777
2014-05-14 09:10 guillermogil Relationship deleted related to 0021777
2014-05-15 11:50 guillermogil Issue Monitored: AugustoMauch
2014-05-15 11:50 guillermogil Review Assigned To => AugustoMauch
2014-05-15 11:55 hgbot Checkin
2014-05-15 11:55 hgbot Note Added: 0067141
2014-05-15 11:55 hgbot Status new => resolved
2014-05-15 11:55 hgbot Resolution open => fixed
2014-05-15 11:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cb4a3042e3a5940afd2472ce54fa1926da79bed3 [^]
2014-05-15 12:24 hgbot Checkin
2014-05-15 12:24 hgbot Note Added: 0067144
2014-05-15 13:50 hgbot Checkin
2014-05-15 13:50 hgbot Note Added: 0067149
2014-05-15 16:44 hgbot Checkin
2014-05-15 16:44 hgbot Note Added: 0067158
2014-05-16 07:19 hudsonbot Checkin
2014-05-16 07:19 hudsonbot Note Added: 0067187
2014-05-16 07:19 hudsonbot Checkin
2014-05-16 07:19 hudsonbot Note Added: 0067189
2014-05-16 07:19 hudsonbot Checkin
2014-05-16 07:19 hudsonbot Note Added: 0067190
2014-05-16 07:19 hudsonbot Checkin
2014-05-16 07:19 hudsonbot Note Added: 0067191
2014-05-18 19:09 AugustoMauch Note Added: 0067240
2014-05-18 19:09 AugustoMauch Status resolved => new
2014-05-18 19:09 AugustoMauch Resolution fixed => open
2014-05-19 09:29 guillermogil Note Added: 0067242
2014-05-19 09:42 AugustoMauch Status new => scheduled
2014-05-19 09:42 AugustoMauch fix_in_branch => pi
2014-05-19 09:43 AugustoMauch Status scheduled => resolved
2014-05-19 09:43 AugustoMauch Fixed in Version => PR14Q3
2014-05-19 09:43 AugustoMauch Resolution open => fixed
2014-05-19 09:44 AugustoMauch Note Added: 0067243
2014-05-19 09:44 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker