Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026420
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2014-04-29 16:332014-10-01 16:53
ReporterdbazView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revisionf96e99de3b0f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date
Regression introduced in release3.0PR14Q2
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026420: Cannot modify an existing "Table Tree Category" record

DescriptionCannot modify an existing "Table Tree Category" record.
Steps To ReproduceInstall "org.openbravo.platform.features" module

As "System Administrator" go to "Tables and Columns"
Select "Organization" table
Select "Table Tree Category" child tab
Open the existing record, try to modify, for example, any combo, and try to save. An error is shown saying that you are not able to create more than 1 record in this tab.

This is due TableTreeEventHandler.java -> checkTreeStructure -> if (obq.count > 0)


Delete the record and create it again is not an option, since it has Linked Items.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0067017)
hgbot (developer)
2014-05-08 10:50

Repository: erp/devel/pi
Changeset: f96e99de3b0f4bda541ef436c06eef455208d377
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu May 08 10:47:28 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f96e99de3b0f4bda541ef436c06eef455208d377 [^]

Fixes issue 26420: Cannot modify an existing AD Tree Table Tree Category record

The problem was that there was an event handler on the ADTableTree table that checked that at most one ADTree tree is defined for a particular table at all times.

The logic that handled this checked on record creation and edition that no ADTree trees were already defined for that table. But there was a bug: if an ADTree tree was modified, then that same tree was detected as an existing ADTree tree, and the event handler returned with an exception.

To fix this now the event handler takes into account the id of the ADTableTree being modified when looking for exisint ADTree trees.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/event/TableTreeEventHandler.java
---
(0067018)
AugustoMauch (developer)
2014-05-08 10:55

Test Plan:

As System Admin:
- Open the Tables and Columns table
- Select the Organization table
- Open in form the only record present in the Table Tree Category subtab
- Change its name from Organization to Organizations. This should work

- Create a new record in the Table Tree Category subtab: Name="Test", Tree Structure = "AD Tree Node".
- Try to save, it should not be possible.

- Create a new record in the Table Tree Category subtab: Name="Test", Tree Structure = "Custom", Datasource = "Model Datasource" (or any other, the selected datasource is not relevant).
- Save the record.
- Change its structure to "AD Tree Node" and try to save. It should not be possible.
(0067031)
hudsonbot (developer)
2014-05-08 18:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bb8873551df6 [^]
Maturity status: Test
(0067084)
alostale (developer)
2014-05-12 09:21

code reviewed + tested

- Issue History
Date Modified Username Field Change
2014-04-29 16:33 dbaz New Issue
2014-04-29 16:33 dbaz Assigned To => AugustoMauch
2014-04-29 16:33 dbaz Modules => Core
2014-04-29 16:33 dbaz Triggers an Emergency Pack => No
2014-05-08 10:43 AugustoMauch Issue Monitored: alostale
2014-05-08 10:43 AugustoMauch Review Assigned To => alostale
2014-05-08 10:50 hgbot Checkin
2014-05-08 10:50 hgbot Note Added: 0067017
2014-05-08 10:50 hgbot Status new => resolved
2014-05-08 10:50 hgbot Resolution open => fixed
2014-05-08 10:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f96e99de3b0f4bda541ef436c06eef455208d377 [^]
2014-05-08 10:55 AugustoMauch Note Added: 0067018
2014-05-08 18:33 hudsonbot Checkin
2014-05-08 18:33 hudsonbot Note Added: 0067031
2014-05-12 09:21 alostale Note Added: 0067084
2014-05-12 09:21 alostale Status resolved => closed
2014-05-12 09:21 alostale Fixed in Version => PR14Q3
2014-10-01 16:53 plujan Regression level => Production - QA Approved
2014-10-01 16:53 plujan Regression introduced in release => 3.0PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker