Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026386
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-04-25 12:052014-12-30 23:28
ReporterAugustoMauchView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision802c2c259fb8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026386: Process buttons are not shown in the tree grid view if no records are selected in the standard grid view

DescriptionProcess buttons are not shown in the tree grid view if no records are selected in the standard grid view.
Steps To ReproduceAs F&B Admin:
- Open the Assets window
- Create an asset named '1'. Leave the Static and Depreciate flags unchecked
- Click on the 'Almacén' asset. Check that the 'Create Amortization' button is shown. This is OK.
- Click on the '1' asset. Check that the 'Create Amortization' button is not shown. This is OK.
- Make sure no record is selected in the grid, and move to the tree grid view
- Click on the 'Almacén' asset. Check that the 'Create Amortization' button is not shown. This is wrong.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
causes defect 00284313.0PR15Q1 closedalostale some buttons are shown without having any record selected 

-  Notes
(0072396)
hgbot (developer)
2014-12-10 13:24

Repository: erp/devel/pi
Changeset: 5dc9dbf38c2299290c87c495a6c9653c79a31171
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Dec 10 13:20:48 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5dc9dbf38c2299290c87c495a6c9653c79a31171 [^]

Fixed issue 26386: Process buttons are not shown in the tree grid view.

Process buttons are not shown in the tree grid view if no records are selected in
the standard grid view.

It has been solved by controlling the current view: tree grid view or grid view.
Now, Process buttons are shown in the tree grid view if no records are selected in
the standard grid view.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
---
(0072399)
alostale (developer)
2014-12-10 14:05

code reviewed

tested following steps to reproduce + different combinations of selected records
(0072610)
hgbot (developer)
2014-12-17 11:16

Repository: erp/devel/pi
Changeset: ff40e616d7ebf5e5d80e2716a14f1117122034d1
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Dec 17 10:34:10 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ff40e616d7ebf5e5d80e2716a14f1117122034d1 [^]

related to bug 28431, related to bug 26386: revert previous changeset

  Removing previuos changeset to fix issue 26386 because it causes 28431

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
---
(0072612)
hgbot (developer)
2014-12-17 11:16

Repository: erp/devel/pi
Changeset: 802c2c259fb8c4fa3c054b5c5254a3c6e9a551ea
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Dec 17 11:15:15 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/802c2c259fb8c4fa3c054b5c5254a3c6e9a551ea [^]

fixed bug 28431, fixed bug 26386: fixed button display logic

  It takes into account whether current view is grid or tree

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-toolbar.js
---
(0073203)
hudsonbot (developer)
2014-12-30 23:27

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073231)
hudsonbot (developer)
2014-12-30 23:27

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073232)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073234)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-04-25 12:05 AugustoMauch New Issue
2014-04-25 12:05 AugustoMauch Assigned To => AugustoMauch
2014-04-25 12:05 AugustoMauch Modules => Core
2014-04-25 12:05 AugustoMauch Triggers an Emergency Pack => No
2014-11-28 09:49 alostale Assigned To AugustoMauch => inigosanchez
2014-12-10 13:19 inigosanchez Issue Monitored: alostale
2014-12-10 13:22 inigosanchez Review Assigned To => alostale
2014-12-10 13:22 inigosanchez Resolution open => fixed
2014-12-10 13:24 hgbot Checkin
2014-12-10 13:24 hgbot Note Added: 0072396
2014-12-10 13:25 hgbot Status new => resolved
2014-12-10 13:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5dc9dbf38c2299290c87c495a6c9653c79a31171 [^]
2014-12-10 14:05 alostale Note Added: 0072399
2014-12-10 14:05 alostale Status resolved => closed
2014-12-10 14:05 alostale Fixed in Version => 3.0PR15Q1
2014-12-17 10:29 alostale Relationship added causes 0028431
2014-12-17 11:16 hgbot Checkin
2014-12-17 11:16 hgbot Note Added: 0072610
2014-12-17 11:16 hgbot Checkin
2014-12-17 11:16 hgbot Note Added: 0072612
2014-12-17 11:16 hgbot Status closed => resolved
2014-12-17 11:16 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/5dc9dbf38c2299290c87c495a6c9653c79a31171 [^] => http://code.openbravo.com/erp/devel/pi/rev/802c2c259fb8c4fa3c054b5c5254a3c6e9a551ea [^]
2014-12-17 11:16 alostale Status resolved => closed
2014-12-30 23:27 hudsonbot Checkin
2014-12-30 23:27 hudsonbot Note Added: 0073203
2014-12-30 23:27 hudsonbot Checkin
2014-12-30 23:27 hudsonbot Note Added: 0073231
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073232
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073234


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker