Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026109
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-03-27 13:392014-05-26 05:18
ReportershuehnerView Statuspublic 
Assigned Toguillermogil 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revision0e4ee8136bfb
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026109: Error in log: SelectorDataSourceFilter - Error evaluating filter expression:

DescriptionThis error message is printed to logfile when running the ci: int-initial-pgsql test:

However it does not have enough information to be able to pinpoint the cause.


b3e0edee 2014-03-26 12:14:29,310 [TP-Processor8] ERROR org.openbravo.userinterface.selector.SelectorDataSourceFilter - Error evaluating filter expression: sun.org.mozilla.javascript.EvaluatorException: XML runtime not available (<Unknown source>#1) in <Unknown source> at line number 1
javax.script.ScriptException: sun.org.mozilla.javascript.EvaluatorException: XML runtime not available (<Unknown source>#1) in <Unknown source> at line number 1
    at com.sun.script.javascript.RhinoScriptEngine.eval(RhinoScriptEngine.java:183)
    at com.sun.script.javascript.RhinoScriptEngine.eval(RhinoScriptEngine.java:199)
    at javax.script.AbstractScriptEngine.eval(AbstractScriptEngine.java:264)
    at org.openbravo.client.application.ParameterUtils.getJSExpressionResult(ParameterUtils.java:161)
    at org.openbravo.userinterface.selector.SelectorDataSourceFilter.applyFilterExpression(SelectorDataSourceFilter.java:257)
    at org.openbravo.userinterface.selector.SelectorDataSourceFilter.doFilter(SelectorDataSourceFilter.java:88)
    at org.openbravo.service.datasource.DataSourceServlet.doFetch(DataSourceServlet.java:204)
    at org.openbravo.service.datasource.DataSourceServlet.doPost(DataSourceServlet.java:678)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
    at org.openbravo.base.HttpBaseServlet.serviceInitialized(HttpBaseServlet.java:225)
    at org.openbravo.base.secureApp.HttpSecureAppServlet.service(HttpSecureAppServlet.java:445)
    at org.openbravo.client.kernel.BaseKernelServlet.callServiceInSuper(BaseKernelServlet.java:87)
    at org.openbravo.client.kernel.BaseKernelServlet.service(BaseKernelServlet.java:63)
    at org.openbravo.service.datasource.DataSourceServlet.service(DataSourceServlet.java:138)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.openbravo.utils.SessionExpirationFilter.doFilter(SessionExpirationFilter.java:66)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.openbravo.utils.CharsetFilter.doFilter(CharsetFilter.java:35)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.openbravo.client.kernel.KernelFilter$1.doAction(KernelFilter.java:62)
    at org.openbravo.dal.core.ThreadHandler.run(ThreadHandler.java:46)
    at org.openbravo.client.kernel.KernelFilter.doFilter(KernelFilter.java:71)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.openbravo.dal.core.DalRequestFilter$1.doAction(DalRequestFilter.java:81)
    at org.openbravo.dal.core.ThreadHandler.run(ThreadHandler.java:46)
    at org.openbravo.dal.core.DalRequestFilter.doFilter(DalRequestFilter.java:103)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
    at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
    at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
    at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:776)
    at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:705)
    at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:898)
    at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
    at java.lang.Thread.run(Thread.java:679)
Caused by: sun.org.mozilla.javascript.EvaluatorException: XML runtime not available (<Unknown source>#1)
    at sun.org.mozilla.javascript.DefaultErrorReporter.runtimeError(DefaultErrorReporter.java:109)
    at sun.org.mozilla.javascript.DefaultErrorReporter.error(DefaultErrorReporter.java:96)
    at sun.org.mozilla.javascript.Parser.addError(Parser.java:230)
    at sun.org.mozilla.javascript.Parser.addError(Parser.java:208)
    at sun.org.mozilla.javascript.Parser.reportError(Parser.java:265)
    at sun.org.mozilla.javascript.Parser.reportError(Parser.java:252)
    at sun.org.mozilla.javascript.Parser.reportError(Parser.java:245)
    at sun.org.mozilla.javascript.Parser.mustHaveXML(Parser.java:422)
    at sun.org.mozilla.javascript.Parser.primaryExpr(Parser.java:2822)
    at sun.org.mozilla.javascript.Parser.memberExpr(Parser.java:2458)
    at sun.org.mozilla.javascript.Parser.unaryExpr(Parser.java:2368)
    at sun.org.mozilla.javascript.Parser.mulExpr(Parser.java:2291)
    at sun.org.mozilla.javascript.Parser.addExpr(Parser.java:2273)
    at sun.org.mozilla.javascript.Parser.shiftExpr(Parser.java:2252)
    at sun.org.mozilla.javascript.Parser.relExpr(Parser.java:2225)
    at sun.org.mozilla.javascript.Parser.eqExpr(Parser.java:2195)
    at sun.org.mozilla.javascript.Parser.bitAndExpr(Parser.java:2182)
    at sun.org.mozilla.javascript.Parser.bitXorExpr(Parser.java:2169)
    at sun.org.mozilla.javascript.Parser.bitOrExpr(Parser.java:2156)
    at sun.org.mozilla.javascript.Parser.andExpr(Parser.java:2143)
    at sun.org.mozilla.javascript.Parser.orExpr(Parser.java:2130)
    at sun.org.mozilla.javascript.Parser.condExpr(Parser.java:2106)
    at sun.org.mozilla.javascript.Parser.assignExpr(Parser.java:2075)
    at sun.org.mozilla.javascript.Parser.assignExpr(Parser.java:2087)
    at sun.org.mozilla.javascript.Parser.expr(Parser.java:2052)
    at sun.org.mozilla.javascript.Parser.parenExpr(Parser.java:2884)
    at sun.org.mozilla.javascript.Parser.primaryExpr(Parser.java:2819)
    at sun.org.mozilla.javascript.Parser.memberExpr(Parser.java:2458)
    at sun.org.mozilla.javascript.Parser.unaryExpr(Parser.java:2368)
    at sun.org.mozilla.javascript.Parser.mulExpr(Parser.java:2291)
    at sun.org.mozilla.javascript.Parser.addExpr(Parser.java:2273)
    at sun.org.mozilla.javascript.Parser.shiftExpr(Parser.java:2252)
    at sun.org.mozilla.javascript.Parser.relExpr(Parser.java:2225)
    at sun.org.mozilla.javascript.Parser.eqExpr(Parser.java:2195)
    at sun.org.mozilla.javascript.Parser.bitAndExpr(Parser.java:2182)
    at sun.org.mozilla.javascript.Parser.bitXorExpr(Parser.java:2169)
    at sun.org.mozilla.javascript.Parser.bitOrExpr(Parser.java:2156)
    at sun.org.mozilla.javascript.Parser.andExpr(Parser.java:2143)
    at sun.org.mozilla.javascript.Parser.orExpr(Parser.java:2130)
    at sun.org.mozilla.javascript.Parser.condExpr(Parser.java:2106)
    at sun.org.mozilla.javascript.Parser.assignExpr(Parser.java:2075)
    at sun.org.mozilla.javascript.Parser.expr(Parser.java:2052)
    at sun.org.mozilla.javascript.Parser.parenExpr(Parser.java:2884)
    at sun.org.mozilla.javascript.Parser.primaryExpr(Parser.java:2819)
    at sun.org.mozilla.javascript.Parser.memberExpr(Parser.java:2458)
    at sun.org.mozilla.javascript.Parser.unaryExpr(Parser.java:2368)
    at sun.org.mozilla.javascript.Parser.mulExpr(Parser.java:2291)
    at sun.org.mozilla.javascript.Parser.addExpr(Parser.java:2273)
    at sun.org.mozilla.javascript.Parser.shiftExpr(Parser.java:2252)
    at sun.org.mozilla.javascript.Parser.relExpr(Parser.java:2225)
    at sun.org.mozilla.javascript.Parser.eqExpr(Parser.java:2195)
    at sun.org.mozilla.javascript.Parser.bitAndExpr(Parser.java:2182)
    at sun.org.mozilla.javascript.Parser.bitXorExpr(Parser.java:2169)
    at sun.org.mozilla.javascript.Parser.bitOrExpr(Parser.java:2156)
    at sun.org.mozilla.javascript.Parser.andExpr(Parser.java:2143)
    at sun.org.mozilla.javascript.Parser.orExpr(Parser.java:2130)
    at sun.org.mozilla.javascript.Parser.condExpr(Parser.java:2106)
    at sun.org.mozilla.javascript.Parser.assignExpr(Parser.java:2075)
    at sun.org.mozilla.javascript.Parser.expr(Parser.java:2052)
    at sun.org.mozilla.javascript.Parser.statementHelper(Parser.java:1081)
    at sun.org.mozilla.javascript.Parser.statement(Parser.java:943)
    at sun.org.mozilla.javascript.Parser.parse(Parser.java:568)
    at sun.org.mozilla.javascript.Parser.parse(Parser.java:530)
    at sun.org.mozilla.javascript.Context.compileImpl(Context.java:2403)
    at sun.org.mozilla.javascript.Context.compileReader(Context.java:1328)
    at sun.org.mozilla.javascript.Context.compileReader(Context.java:1300)
    at sun.org.mozilla.javascript.Context.evaluateReader(Context.java:1139)
    at com.sun.script.javascript.RhinoScriptEngine.eval(RhinoScriptEngine.java:173)
    ... 45 more
Steps To Reproducehttps://ci.openbravo.com/job/int-initial-pgsql/lastSuccessfulBuild/artifact/SANDBOX/tomcat-logs/int-initial-pgsql.log [^]
Proposed Solution- Add more logging to the error message (tab,field,selector-field, filter expression)
- Fix the specific bug triggering this error
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00217773.0MP17 closedioritzCia role without permission for a new organization in some circumstances 
related to defect 00234193.0MP25 closedjecharri Impossible to add an organization to one role 

-  Notes
(0067021)
hgbot (developer)
2014-05-08 12:08

Repository: erp/devel/pi
Changeset: 945d5e9d9475012d0c050f6cb368423b83a30a0d
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Thu May 08 12:07:29 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/945d5e9d9475012d0c050f6cb368423b83a30a0d [^]

Related to issue 26109: Added more info to SelectorDataSourceFilter error

---
M modules/org.openbravo.userinterface.selector/src/org/openbravo/userinterface/selector/SelectorDataSourceFilter.java
---
(0067073)
hudsonbot (developer)
2014-05-09 16:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e8c0af2263a0 [^]
Maturity status: Test
(0067119)
guillermogil (developer)
2014-05-14 10:08

Filter expression was failing.

I have been talked to the person who created the selector and the wrong behavior has been fixed.
(0067123)
hgbot (developer)
2014-05-14 11:48

Repository: erp/devel/pi
Changeset: 0e4ee8136bfbf62fb95180af555f650e232098fa
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Wed May 14 10:09:44 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0e4ee8136bfbf62fb95180af555f650e232098fa [^]

Fixed issue 26109:SelectorDataSourceFilter-Error evaluating filter expression

Filter expression was failing

---
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
---
(0067128)
shuehner (administrator)
2014-05-14 13:10

Does the reopen some older problem for which the filter expression was added initially?
(0067129)
guillermogil (developer)
2014-05-14 13:20

No, the previous issues 21777 and 23419 are not reproducible anymore.
The selector was only used in org selector in org access tab and the filter expression was used to add new created organizations that our role does not have access. I have tested the selector and I couldn't reproduce the previous issues.
(0067167)
hudsonbot (developer)
2014-05-15 17:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8d6658b982c0 [^]
Maturity status: Test
(0067425)
shankarb (developer)
2014-05-26 05:18

Code reviewed and verified in pi changeset 2e8a0f241dc7.

- Issue History
Date Modified Username Field Change
2014-03-27 13:39 shuehner New Issue
2014-03-27 13:39 shuehner Assigned To => AugustoMauch
2014-03-27 13:39 shuehner Modules => Core
2014-03-27 13:39 shuehner Triggers an Emergency Pack => No
2014-04-07 15:23 alostale Target Version => PR14Q3
2014-04-14 16:53 guillermogil Assigned To AugustoMauch => guillermogil
2014-05-08 12:08 hgbot Checkin
2014-05-08 12:08 hgbot Note Added: 0067021
2014-05-09 16:21 hudsonbot Checkin
2014-05-09 16:21 hudsonbot Note Added: 0067073
2014-05-14 09:10 guillermogil Relationship added related to 0021777
2014-05-14 09:10 guillermogil Relationship added related to 0023419
2014-05-14 10:06 guillermogil Issue Monitored: shankarb
2014-05-14 10:08 guillermogil Review Assigned To => shankarb
2014-05-14 10:08 guillermogil Note Added: 0067119
2014-05-14 11:48 hgbot Checkin
2014-05-14 11:48 hgbot Note Added: 0067123
2014-05-14 11:48 hgbot Status new => resolved
2014-05-14 11:48 hgbot Resolution open => fixed
2014-05-14 11:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0e4ee8136bfbf62fb95180af555f650e232098fa [^]
2014-05-14 13:10 shuehner Note Added: 0067128
2014-05-14 13:20 guillermogil Note Added: 0067129
2014-05-15 17:34 hudsonbot Checkin
2014-05-15 17:34 hudsonbot Note Added: 0067167
2014-05-26 05:18 shankarb Note Added: 0067425
2014-05-26 05:18 shankarb Status resolved => closed
2014-05-26 05:18 shankarb Fixed in Version => PR14Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker