Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026049
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementmajoralways2014-03-20 17:072014-03-24 12:01
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revisionad1b6b290146
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-12-16
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/08e8dd69188fc9a592ce4cc0efb5f5ec425cee34 [^]
Triggers an Emergency PackNo
Summary

0026049: The filtering on the value tab under product characteristics window does not work

DescriptionFiltering on the name field does always return no results
Steps To Reproduce-Go to product characteristics window.
-Create a row on the header
-go to the value tab
-Create a new value with name blue
-Create a new value with name green
-Go to grid view
-filter on the name field with bl
*No results are returned
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0026481 closedguillermogil Filtering not working when parent column is displayed in grid 

-  Notes
(0065314)
AugustoMauch (developer)
2014-03-20 17:23

This is the criteria that was generated in MP30.3 when filtering 'b':

criteria:{"fieldName":"name","operator":"iContains","value":"b"}
criteria:{"fieldName":"characteristic","operator":"equals","value":"59A27874E55C44E8BC232DC3C8257896"}

This is the criteria that was generated in MP31.2 when filtering 'b':

criteria:{"fieldName":"name","operator":"iContains","value":"b"}
criteria:{"fieldName":"characteristic$_identifier","operator":"iEquals","value":"FF11721554E0438F999FC5C4A3732CF0"}
criteria:{"fieldName":"characteristic","operator":"equals","value":"FF11721554E0438F999FC5C4A3732CF0"}
(0065377)
hgbot (developer)
2014-03-23 23:34

Repository: erp/devel/pi
Changeset: ad1b6b290146c793d425ed93fe3e232a71b67239
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Sun Mar 23 23:32:45 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ad1b6b290146c793d425ed93fe3e232a71b67239 [^]

Fixes issue 26049: Filter on the product characteristics window is not working

The problem was that the Characteristic field of the Value subtab was being shown. That field act as link to the parent tab, and if it is shown the criteria used to fetch the subtab records could not be properly formed. This has been fixed by not showing the field in grid view.

---
M src-db/database/sourcedata/AD_FIELD.xml
---
(0065378)
hudsonbot (developer)
2014-03-24 07:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/cf9ad5b34ce3 [^]
Maturity status: Test
(0065386)
shankarb (developer)
2014-03-24 12:01

Code reviewed and verified in pi changeset b24d8a94df0e.

- Issue History
Date Modified Username Field Change
2014-03-20 17:07 egoitz New Issue
2014-03-20 17:07 egoitz Assigned To => AugustoMauch
2014-03-20 17:07 egoitz Modules => Core
2014-03-20 17:07 egoitz Triggers an Emergency Pack => No
2014-03-20 17:23 AugustoMauch Note Added: 0065314
2014-03-21 10:18 extra Issue Monitored: extra
2014-03-21 18:31 AugustoMauch Regression level => Production - Confirmed Stable
2014-03-21 18:31 AugustoMauch Regression date => 2013-12-16
2014-03-21 18:31 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/08e8dd69188fc9a592ce4cc0efb5f5ec425cee34 [^]
2014-03-23 23:31 AugustoMauch Issue Monitored: shankarb
2014-03-23 23:31 AugustoMauch Review Assigned To => shankarb
2014-03-23 23:34 hgbot Checkin
2014-03-23 23:34 hgbot Note Added: 0065377
2014-03-23 23:34 hgbot Status new => resolved
2014-03-23 23:34 hgbot Resolution open => fixed
2014-03-23 23:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ad1b6b290146c793d425ed93fe3e232a71b67239 [^]
2014-03-24 07:10 hudsonbot Checkin
2014-03-24 07:10 hudsonbot Note Added: 0065378
2014-03-24 12:01 shankarb Note Added: 0065386
2014-03-24 12:01 shankarb Status resolved => closed
2014-03-24 12:01 shankarb Fixed in Version => PR14Q2
2014-05-07 10:17 shankarb Relationship added related to 0026481


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker