Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025988
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-03-13 18:402014-03-16 06:31
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision0630b904462c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025988: The Grid Configuration is not working properly if an operator that does not ignore the case is used

DescriptionThe Grid Configuration is not working properly if an operator that does not ignore the case is used.

For example, if the contains operator is selected for all text fields, then entering in a text filter any lowercase string will not produce any results.
Steps To Reproduce- Open the Grid Configuration at System Level window
- Create a new record, pick the 'contains' operator in the Text Field Filter Behaviour field.
- Clear the cache
- Open the Windows, Tabs and Fields window
- Enter 'w' in the name filter. No results are returned (at least 4 should have been returned
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0065144)
hgbot (developer)
2014-03-13 18:46

Repository: erp/devel/pi
Changeset: 0630b904462cfaa365569b3430020ee91e56a30a
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 13 18:44:57 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0630b904462cfaa365569b3430020ee91e56a30a [^]

Fixes issue 25988: The ignoreCase method of AdvancedQueryBuilder does not work

The ignoreCase method is not working properly, because it is returning true for some operators that should not ignore the text casing. The contains, startsWith and endWith operators have been excluded from the list of operators that ignore the text casing.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
---
(0065184)
hudsonbot (developer)
2014-03-15 03:04

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8396ec753aec [^]
Maturity status: Test
(0065202)
shankarb (developer)
2014-03-16 06:31

Code reviewed and verified in pi changeset 09baf685138e.

- Issue History
Date Modified Username Field Change
2014-03-13 18:40 AugustoMauch New Issue
2014-03-13 18:40 AugustoMauch Assigned To => AugustoMauch
2014-03-13 18:40 AugustoMauch Modules => Core
2014-03-13 18:40 AugustoMauch Triggers an Emergency Pack => No
2014-03-13 18:45 AugustoMauch Issue Monitored: shankarb
2014-03-13 18:45 AugustoMauch Review Assigned To => shankarb
2014-03-13 18:46 hgbot Checkin
2014-03-13 18:46 hgbot Note Added: 0065144
2014-03-13 18:46 hgbot Status new => resolved
2014-03-13 18:46 hgbot Resolution open => fixed
2014-03-13 18:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0630b904462cfaa365569b3430020ee91e56a30a [^]
2014-03-15 03:04 hudsonbot Checkin
2014-03-15 03:04 hudsonbot Note Added: 0065184
2014-03-16 06:31 shankarb Note Added: 0065202
2014-03-16 06:31 shankarb Status resolved => closed
2014-03-16 06:31 shankarb Fixed in Version => PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker