Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025946
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-03-11 11:142014-03-13 19:38
ReportercaristuView Statuspublic 
Assigned Toszapata 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revisione74230fb5c88
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025946: Date selectors in reports not working in reports for Japanase language

DescriptionDate selectors in reports not working in reports for Japanase language, the calendar language translation file is not correct
Steps To Reproduce1) Configure Openbravo to use Japanese as System Language
2) Go to the Sales Invoice Dimensional Report
3) Click on the Date selector. The calendar won't appear.
Proposed SolutionRename the calendar-jp.js file to calendar-ja.js (The Japanese correct ISO code is ja)

Fill the file with the correct configuration
TagsNo tags attached.
Attached Files? file icon calendar-ja.js [^] (3,909 bytes) 2014-03-12 10:26

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0065105)
hgbot (developer)
2014-03-13 00:28

Repository: erp/devel/pi
Changeset: e74230fb5c88863967c3c94dd47ac16b23706651
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Wed Mar 12 20:26:41 2014 -0300
URL: http://code.openbravo.com/erp/devel/pi/rev/e74230fb5c88863967c3c94dd47ac16b23706651 [^]

Fixed issue 25946 show calendar in manual forms for japaneese

---
A web/js/jscalendar/lang/calendar-ja.js
R web/js/jscalendar/lang/calendar-jp.js
---
(0065120)
hudsonbot (developer)
2014-03-13 11:14

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ed77dba8a2e6 [^]
Maturity status: Test
(0065150)
AugustoMauch (developer)
2014-03-13 19:38

Code reviewed and verified in pi@eb415e9bc94f

Not only the problem was solved, also the calendar is now translated to japanese.

- Issue History
Date Modified Username Field Change
2014-03-11 11:14 caristu New Issue
2014-03-11 11:14 caristu Assigned To => AugustoMauch
2014-03-11 11:14 caristu Modules => Core
2014-03-11 11:14 caristu Triggers an Emergency Pack => No
2014-03-11 11:15 caristu Proposed Solution updated
2014-03-11 11:15 caristu Issue Monitored: networkb
2014-03-11 11:46 caristu Target Version => PR14Q2
2014-03-12 09:46 caristu Assigned To AugustoMauch => caristu
2014-03-12 09:51 caristu Review Assigned To => AugustoMauch
2014-03-12 09:52 caristu Assigned To caristu => szapata
2014-03-12 10:26 caristu File Added: calendar-ja.js
2014-03-13 00:28 hgbot Checkin
2014-03-13 00:28 hgbot Note Added: 0065105
2014-03-13 00:28 hgbot Status new => resolved
2014-03-13 00:28 hgbot Resolution open => fixed
2014-03-13 00:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e74230fb5c88863967c3c94dd47ac16b23706651 [^]
2014-03-13 11:14 hudsonbot Checkin
2014-03-13 11:14 hudsonbot Note Added: 0065120
2014-03-13 19:38 AugustoMauch Note Added: 0065150
2014-03-13 19:38 AugustoMauch Status resolved => closed
2014-03-13 19:38 AugustoMauch Fixed in Version => PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker