Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025922
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-03-06 11:502014-03-15 16:19
ReporterdmiguelezView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision39e474a762db
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2014-02-26
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
Triggers an Emergency PackNo
Summary

0025922: process definition with multiple selector fails

DescriptionWhen clicking on a button that was previously working, it does nothing.
This is a button from the Analytics Module that opens a new Parameter Window.

This happens for all process definitions that include a multiple selector.
Steps To ReproduceInstall Analtyics Module.
Change Role to System Admin.
Go to Cube Definition Window.
Click on FDR - Financial Dimensional Cubes.
A button will appear named Generate Cubes.
Click on it.
Nothing happens.
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2014-03-06 11:41:40.png [^] (230,248 bytes) 2014-03-06 11:51

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0025574 closeddbaz Upgrade SmartClient 10.0d 

-  Notes
(0064931)
hgbot (developer)
2014-03-06 16:35

Repository: erp/devel/pi
Changeset: 00a151751c86199732b7e99e29aa74ad07089035
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Mar 06 16:34:41 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/00a151751c86199732b7e99e29aa74ad07089035 [^]

fixed bug 25922: process definition with multiple selector fails

 Resetting with is no longer required as now it is properly updated, setting it
 caused an exception

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-multi-selector-item.js
---
(0064941)
dmiguelez (developer)
2014-03-06 19:43

Reopen because it is giving an error because the fixWith function that has been removed is being used in:

https://code.openbravo.com/erp/devel/pi/file/00a151751c86/modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-multi-selector-item.js#l276 [^]
(0064948)
hudsonbot (developer)
2014-03-07 05:25

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9364dd72aca6 [^]
Maturity status: Test
(0064950)
hgbot (developer)
2014-03-07 07:57

Repository: erp/devel/pi
Changeset: 39e474a762db34de77036b6003949d2ebb5a1695
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 07 07:49:14 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/39e474a762db34de77036b6003949d2ebb5a1695 [^]

fixed issue 25922: removed pending reference to fixWidth

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-multi-selector-item.js
---
(0064964)
hudsonbot (developer)
2014-03-07 17:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8b1b6bf2d1 [^]
Maturity status: Test
(0065195)
shankarb (developer)
2014-03-15 16:19

Code reviewed and verified in pi changeset 09baf685138e.

- Issue History
Date Modified Username Field Change
2014-03-06 11:50 dmiguelez New Issue
2014-03-06 11:50 dmiguelez Assigned To => alostale
2014-03-06 11:50 dmiguelez Modules => Core
2014-03-06 11:50 dmiguelez Triggers an Emergency Pack => No
2014-03-06 11:51 dmiguelez Relationship added related to 0025574
2014-03-06 11:51 dmiguelez File Added: Screenshot from 2014-03-06 11:41:40.png
2014-03-06 16:30 alostale Regression level => Pre packaging ( pi )
2014-03-06 16:30 alostale Regression date => 2014-02-26
2014-03-06 16:30 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
2014-03-06 16:30 alostale Priority urgent => immediate
2014-03-06 16:30 alostale Summary Button is not working => process definition with multiple selector fails
2014-03-06 16:30 alostale Description Updated View Revisions
2014-03-06 16:31 alostale Review Assigned To => shankarb
2014-03-06 16:35 hgbot Checkin
2014-03-06 16:35 hgbot Note Added: 0064931
2014-03-06 16:35 hgbot Status new => resolved
2014-03-06 16:35 hgbot Resolution open => fixed
2014-03-06 16:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/00a151751c86199732b7e99e29aa74ad07089035 [^]
2014-03-06 19:43 dmiguelez Note Added: 0064941
2014-03-06 19:43 dmiguelez Status resolved => new
2014-03-06 19:43 dmiguelez Resolution fixed => open
2014-03-07 05:25 hudsonbot Checkin
2014-03-07 05:25 hudsonbot Note Added: 0064948
2014-03-07 07:57 hgbot Checkin
2014-03-07 07:57 hgbot Note Added: 0064950
2014-03-07 07:57 hgbot Status new => resolved
2014-03-07 07:57 hgbot Resolution open => fixed
2014-03-07 07:57 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/00a151751c86199732b7e99e29aa74ad07089035 [^] => http://code.openbravo.com/erp/devel/pi/rev/39e474a762db34de77036b6003949d2ebb5a1695 [^]
2014-03-07 17:43 hudsonbot Checkin
2014-03-07 17:43 hudsonbot Note Added: 0064964
2014-03-15 16:19 shankarb Note Added: 0065195
2014-03-15 16:19 shankarb Status resolved => closed
2014-03-15 16:19 shankarb Fixed in Version => PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker