Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025863
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2014-02-28 00:432015-03-05 01:00
ReporterjecharriView Statuspublic 
Assigned Tomalsasua 
PriorityimmediateResolutionfixedFixed in VersionRR14Q2
StatusclosedFix in branchFixed in SCM revision79590f8f5ee7
ProjectionnoneETAnoneTarget VersionRR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomigueldejuana
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025863: Cash up is not working fine

DescriptionCash up is not working fine.

The problem is that is some cases, not all the shipment lines are related to the invoice, due to that some shipments will keep as invoiceable forever.
Steps To Reproduce-Login to Web POS
-Create and order with one product and 2 units
-Configure the product stock to have one unit in one storage bin and another unit in another storage bin
-Pay and complete the order

After that you will have an order line related to 2 shipment lines with different storage bin.

-Execute the cash up

Verify that only one shipment line is related with cash up invoice line. Due to that, if you create an invoice for same BP you will see that you are able to select the shipment that it should be already completelly invoiced

This issue needs a modules script to fix wrong data.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks feature request 0028933RR16Q1 closedRetail QA: RR15Q2: Add tests for Mobile applications 
causes defect 0029053 closedmarvintm wrong invoices when products are retrieved from two bin locations 
causes defect 0029087 closedmarvintm wrong invoices (taxes wrong calculated) when products are retrieved from two bin locators 
causes defect 0029122 closedmarvintm wrong invoices when products are retrieved from two bin locations and is paid with credit 

-  Notes
(0065205)
hgbot (developer)
2014-03-17 09:26

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 7663e79231d43372e1792fc6f7da0c12da51a82e
Author: Miguel A. Alsasua <miguel.alsasua <at> openbravo.com>
Date: Mon Mar 17 09:25:32 2014 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7663e79231d43372e1792fc6f7da0c12da51a82e [^]

fixed issue 25863: Cash up is not working fine

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0065222)
hgbot (developer)
2014-03-17 13:03

Repository: erp/pmods/org.openbravo.retail.posterminal.cirque
Changeset: 7663e79231d43372e1792fc6f7da0c12da51a82e
Author: Miguel A. Alsasua <miguel.alsasua <at> openbravo.com>
Date: Mon Mar 17 09:25:32 2014 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.cirque/rev/7663e79231d43372e1792fc6f7da0c12da51a82e [^]

fixed issue 25863: Cash up is not working fine

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0065475)
hgbot (developer)
2014-03-26 16:38

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 79590f8f5ee71ea4d4dc523ab8349a5bfcf977aa
Author: Miguel A. Alsasua <miguel.alsasua <at> openbravo.com>
Date: Wed Mar 26 16:37:22 2014 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/79590f8f5ee71ea4d4dc523ab8349a5bfcf977aa [^]

fixed issue 25863:invoiced qty in sales order is not updated

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
---
(0066141)
hgbot (developer)
2014-04-03 16:45

Repository: erp/pmods/org.openbravo.retail.posterminal.cds
Changeset: 79590f8f5ee71ea4d4dc523ab8349a5bfcf977aa
Author: Miguel A. Alsasua <miguel.alsasua <at> openbravo.com>
Date: Wed Mar 26 16:37:22 2014 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.cds/rev/79590f8f5ee71ea4d4dc523ab8349a5bfcf977aa [^]

fixed issue 25863:invoiced qty in sales order is not updated

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
---
(0066414)
migueldejuana (developer)
2014-04-15 09:45

Tested and reviewed in d46a2ad684c2

- Issue History
Date Modified Username Field Change
2014-02-28 00:43 jecharri New Issue
2014-02-28 00:43 jecharri Assigned To => marvintm
2014-02-28 00:43 jecharri Triggers an Emergency Pack => No
2014-03-06 11:49 malsasua Assigned To marvintm => malsasua
2014-03-17 09:26 hgbot Checkin
2014-03-17 09:26 hgbot Note Added: 0065205
2014-03-17 09:26 hgbot Status new => resolved
2014-03-17 09:26 hgbot Resolution open => fixed
2014-03-17 09:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7663e79231d43372e1792fc6f7da0c12da51a82e [^]
2014-03-17 13:03 hgbot Checkin
2014-03-17 13:03 hgbot Note Added: 0065222
2014-03-17 13:03 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7663e79231d43372e1792fc6f7da0c12da51a82e [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.cirque/rev/7663e79231d43372e1792fc6f7da0c12da51a82e [^]
2014-03-26 16:38 hgbot Checkin
2014-03-26 16:38 hgbot Note Added: 0065475
2014-03-26 16:38 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.cirque/rev/7663e79231d43372e1792fc6f7da0c12da51a82e [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/79590f8f5ee71ea4d4dc523ab8349a5bfcf977aa [^]
2014-03-31 13:25 marvintm Review Assigned To => marvintm
2014-03-31 13:25 marvintm Status resolved => closed
2014-03-31 13:25 marvintm Fixed in Version => RR14Q2
2014-04-03 16:45 hgbot Checkin
2014-04-03 16:45 hgbot Note Added: 0066141
2014-04-03 16:45 hgbot Status closed => resolved
2014-04-03 16:45 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/79590f8f5ee71ea4d4dc523ab8349a5bfcf977aa [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.cds/rev/79590f8f5ee71ea4d4dc523ab8349a5bfcf977aa [^]
2014-04-15 09:45 migueldejuana Review Assigned To marvintm => migueldejuana
2014-04-15 09:45 migueldejuana Note Added: 0066414
2014-04-15 09:45 migueldejuana Status resolved => closed
2015-02-26 19:45 dmitry_mezentsev Relationship added causes 0029053
2015-03-02 13:56 dmitry_mezentsev Relationship added causes 0029087
2015-03-04 12:53 dmitry_mezentsev Relationship added caused by 0029122
2015-03-04 12:54 dmitry_mezentsev Relationship replaced causes 0029122
2015-03-05 01:00 Orekaria Relationship added blocks 0028933


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker