Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025534
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminorhave not tried2014-01-22 13:002014-03-16 06:30
ReporterjonalegriaesarteView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision7d16e05fa5bd
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025534: When grouping enabled is set in sales invoice window, the window is not correctly refreshed after booking an entry

DescriptionWhen grouping enabled is set in sales invoice window, the window is not correctly refreshed after booking an entry
Steps To Reproduce- Preferences: enable "Grouping enabled" property
- Sales invoice: group by business partner
- Create a new entry
- In grid view, book it. The action is not refreshing correctly the grid
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00259473.0PR14Q2 closedAugustoMauch Grouping is not working properly in the grid 

-  Notes
(0064528)
alostale (developer)
2014-02-24 16:32
edited on: 2014-02-24 16:33

Two problematic cases found.

1. If the BP the new invoice is created for is unfolded:

This JS error is raisen.

Uncaught TypeError: Object [object Object] has no method 'findByKey' f9907d9ed80a907a7d57d25c843f6246.js:27190
isc.OBViewGrid.addProperties.refreshGrid f9907d9ed80a907a7d57d25c843f6246.js:27190
isc.OBStandardView.addProperties.refresh f9907d9ed80a907a7d57d25c843f6246.js:20860
OB.Utilities.callAction f9907d9ed80a907a7d57d25c843f6246.js:3420
saveCallback f9907d9ed80a907a7d57d25c843f6246.js:18530

problem is in refreshGrid, trying to do this.data.findByKey being data a tree view which doesn't have the method

2. Having the BP folded.

In this case the new record is not properly set in the grid, lines are not properly managed. After saving new header message about no parent selected is still present.

(0064997)
hgbot (developer)
2014-03-10 18:58

Repository: erp/devel/pi
Changeset: e3c9611f5f63be36fff4878a31d6d5a5665bf142
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 10 18:56:44 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e3c9611f5f63be36fff4878a31d6d5a5665bf142 [^]

Fixes issue 25534: Problem when creating records in grouped grids

When a record was created in a grouped grid, the created record was not included in the grid until it was refreshed manually. Now it is updated automatically,
 its parent record is opened and the created record is scrolled to the middle of the grid.

Also, calling refreshCurrentRecord did not update the grouped grid, and closeProcessPopup did not update it either.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
---
(0065026)
AugustoMauch (developer)
2014-03-11 10:20

Reopened because the fix does not work with the upgraded version of smartclient
(0065041)
hgbot (developer)
2014-03-11 13:00

Repository: erp/devel/pi
Changeset: 1bc9b57dcfc1d332128a0894483cdeb7c5a4cda6
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Mar 11 10:21:56 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1bc9b57dcfc1d332128a0894483cdeb7c5a4cda6 [^]

Related to issue 25534: Fix has been backed out because it is not proper

The fix did not work with the upgraded smartclient version

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
---
(0065046)
hgbot (developer)
2014-03-11 16:22

Repository: erp/devel/pi
Changeset: 7d16e05fa5bdf51375bc2e07e43d616bb20b3a7e
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Mar 11 16:21:47 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/7d16e05fa5bdf51375bc2e07e43d616bb20b3a7e [^]

Fixes issue 25534: Problem when creating records in grouped grids

When a record was created in a grouped grid, the created record was not included in the grid until it was refreshed manually. Now it is updated automatically,
 its parent record is opened and the created record is scrolled to the middle of the grid.

Also, calling refreshCurrentRecord did not update the grouped grid, and closeProcessPopup did not update it either.

Fix reapplied after fixing 25947

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
---
(0065047)
hgbot (developer)
2014-03-11 16:23

Repository: erp/devel/pi
Changeset: fe3e47544cdaccc5785b903e5174e328e79e4f28
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Mar 11 16:23:16 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/fe3e47544cdaccc5785b903e5174e328e79e4f28 [^]

Related to issue 25534: Adds check in case the grid data is not a tree

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0065053)
hudsonbot (developer)
2014-03-11 17:04

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0d35a09c7eb8 [^]
Maturity status: Test
(0065074)
hudsonbot (developer)
2014-03-12 05:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/82d89b03cb26 [^]
Maturity status: Test
(0065076)
hudsonbot (developer)
2014-03-12 05:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/82d89b03cb26 [^]
Maturity status: Test
(0065077)
hudsonbot (developer)
2014-03-12 05:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/82d89b03cb26 [^]
Maturity status: Test
(0065201)
shankarb (developer)
2014-03-16 06:30

Code reviewed and verified in pi changeset 09baf685138e.

- Issue History
Date Modified Username Field Change
2014-01-22 13:00 jonalegriaesarte New Issue
2014-01-22 13:00 jonalegriaesarte Assigned To => AugustoMauch
2014-01-22 13:00 jonalegriaesarte Modules => Core
2014-01-22 13:00 jonalegriaesarte Triggers an Emergency Pack => No
2014-02-24 16:15 alostale Assigned To AugustoMauch => alostale
2014-02-24 16:32 alostale Note Added: 0064528
2014-02-24 16:33 alostale Note Edited: 0064528 View Revisions
2014-03-05 13:01 alostale Target Version PR14Q3 => PR14Q2
2014-03-10 18:58 AugustoMauch Issue Monitored: shankarb
2014-03-10 18:58 AugustoMauch Review Assigned To => shankarb
2014-03-10 18:58 AugustoMauch Assigned To alostale => AugustoMauch
2014-03-10 18:58 hgbot Checkin
2014-03-10 18:58 hgbot Note Added: 0064997
2014-03-10 18:58 hgbot Status new => resolved
2014-03-10 18:58 hgbot Resolution open => fixed
2014-03-10 18:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e3c9611f5f63be36fff4878a31d6d5a5665bf142 [^]
2014-03-11 10:20 AugustoMauch Note Added: 0065026
2014-03-11 10:20 AugustoMauch Status resolved => new
2014-03-11 10:20 AugustoMauch Resolution fixed => open
2014-03-11 11:26 AugustoMauch Relationship added related to 0025947
2014-03-11 13:00 hgbot Checkin
2014-03-11 13:00 hgbot Note Added: 0065041
2014-03-11 16:22 hgbot Checkin
2014-03-11 16:22 hgbot Note Added: 0065046
2014-03-11 16:22 hgbot Status new => resolved
2014-03-11 16:22 hgbot Resolution open => fixed
2014-03-11 16:22 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/e3c9611f5f63be36fff4878a31d6d5a5665bf142 [^] => http://code.openbravo.com/erp/devel/pi/rev/7d16e05fa5bdf51375bc2e07e43d616bb20b3a7e [^]
2014-03-11 16:23 hgbot Checkin
2014-03-11 16:23 hgbot Note Added: 0065047
2014-03-11 17:04 hudsonbot Checkin
2014-03-11 17:04 hudsonbot Note Added: 0065053
2014-03-12 05:19 hudsonbot Checkin
2014-03-12 05:19 hudsonbot Note Added: 0065074
2014-03-12 05:19 hudsonbot Checkin
2014-03-12 05:19 hudsonbot Note Added: 0065076
2014-03-12 05:19 hudsonbot Checkin
2014-03-12 05:19 hudsonbot Note Added: 0065077
2014-03-16 06:30 shankarb Note Added: 0065201
2014-03-16 06:30 shankarb Status resolved => closed
2014-03-16 06:30 shankarb Fixed in Version => PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker