Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025512
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-01-20 11:122014-03-06 10:28
ReportercaristuView Statuspublic 
Assigned Toshankarb 
PriorityhighResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revisionab055e5f30e8
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025512: Not possible to use different email definitions when sending multiple documents by email

DescriptionIs not possible to use different email definitions when sending multiple documents by email, the default email definition is used for populating the email pop-up. And this is the information that will be sent.

So, this causes that sending multiple documents is not working in different cases:

a) If we send different document types.

b) If we have an email definition for different languages depending on the business partner is not possible to use a different definition depending on it.
Steps To ReproduceAs system admin:
1) Display the Language field for the Business Partner header
As group admin:
2) Create a business partner with English language
3) Create another business partner with Spanish language
4) Create two email definitions for the Standard Order document type, one for English language and the other one for Spanish
5) Create two sales order, one for the every business partner.
6) Send by email the sales orders individually. Notice that the email definition is chosen correctly depending on the business partner language.
7) Send by email the two sales order at the same time. Notice that the default email definition is used for both.
Proposed SolutionIf the email template and business partner language is the same, it will work as always: showing the email template

If the email templates are different or the business partner language is different then:

1) Show a message: "Different email templates selected, if you click OK default email templates for every document will be used"
2) Don't show the pop-up and send the emails using the default email templates

This can be done in the line 921 of the PrintController class, because currently the first template in the report array is selected using: reports.values().iterator().next().getEmailDefinition();
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00269863.0PR14Q4 closedshankarb Some characters are not printed after switching the template to use in the Email options window 
related to feature request 0030758 newTriage Finance Send Documents via email from grid in multiple languages. 

-  Notes
(0064506)
hgbot (developer)
2014-02-24 09:58

Repository: erp/devel/pi
Changeset: ab055e5f30e85c08dc1769f2bfb68b77f9c540bd
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Mon Feb 24 14:15:24 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/ab055e5f30e85c08dc1769f2bfb68b77f9c540bd [^]

Fixes Issue 0025512: Not possible to use different email definitions when sending multiple documents by email

Handled the following cases:
Case 1: When document types are different
1. Emails are sent using the default email configurations.
2. Subject and Message body are not editable

Case 2: When there are multiple email configurations for the same document type
1. Option to choose default email configuration.
2. Option to select other email configurations.
3. Subject and message body are editable.

---
M src/org/openbravo/erpCommon/utility/reporting/EmailDefinition_data.xsql
M src/org/openbravo/erpCommon/utility/reporting/Report.java
M src/org/openbravo/erpCommon/utility/reporting/TemplateInfo.java
M src/org/openbravo/erpCommon/utility/reporting/printing/EmailOptions.html
M src/org/openbravo/erpCommon/utility/reporting/printing/EmailOptions.xml
M src/org/openbravo/erpCommon/utility/reporting/printing/PrintController.java
---
(0064517)
hgbot (developer)
2014-02-24 11:27

Repository: erp/devel/pi
Changeset: 0a97d797843c7630eaf32304d0efb273767b12f6
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Mon Feb 24 15:56:38 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/0a97d797843c7630eaf32304d0efb273767b12f6 [^]

Related to Issue 25512 : Added text interface definitions

---
M src-db/database/sourcedata/AD_TEXTINTERFACES.xml
---
(0064585)
hudsonbot (developer)
2014-02-25 20:14

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7579d638a80a [^]
Maturity status: Test
(0064586)
hudsonbot (developer)
2014-02-25 20:14

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7579d638a80a [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-01-20 11:12 caristu New Issue
2014-01-20 11:12 caristu Assigned To => AugustoMauch
2014-01-20 11:12 caristu Modules => Core
2014-01-20 11:12 caristu Triggers an Emergency Pack => No
2014-01-20 11:13 caristu Issue Monitored: networkb
2014-01-20 11:13 caristu Description Updated View Revisions
2014-02-06 10:53 caristu Type design defect => defect
2014-02-06 10:53 caristu version => pi
2014-02-06 10:53 caristu Target Version => 3.0MP32
2014-02-06 10:53 caristu Description Updated View Revisions
2014-02-06 10:53 caristu Proposed Solution updated
2014-02-06 12:38 daniOpenbravo Issue Monitored: daniOpenbravo
2014-02-09 12:26 shankarb Assigned To AugustoMauch => shankarb
2014-02-24 09:56 shankarb Review Assigned To => alostale
2014-02-24 09:58 hgbot Checkin
2014-02-24 09:58 hgbot Note Added: 0064506
2014-02-24 09:58 hgbot Status new => resolved
2014-02-24 09:58 hgbot Resolution open => fixed
2014-02-24 09:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ab055e5f30e85c08dc1769f2bfb68b77f9c540bd [^]
2014-02-24 11:27 hgbot Checkin
2014-02-24 11:27 hgbot Note Added: 0064517
2014-02-25 20:14 hudsonbot Checkin
2014-02-25 20:14 hudsonbot Note Added: 0064585
2014-02-25 20:14 hudsonbot Checkin
2014-02-25 20:14 hudsonbot Note Added: 0064586
2014-03-06 10:28 alostale Status resolved => closed
2014-03-06 10:28 alostale Fixed in Version => PR14Q2
2014-07-01 13:15 caristu Relationship added related to 0026986
2015-09-03 19:13 mfuertes Relationship added related to 0030758


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker