Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025284
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformmajoralways2013-12-06 09:422013-12-19 12:30
ReporteregoitzView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0MP31
StatusclosedFix in branchFixed in SCM revision13e17bb49f68
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025284: When changing the value of a datetime field using the date selector, the time is changed to the current time

DescriptionWhen changing the value of a datetime field using the date selector, the time is changed to the current time
Steps To Reproduce-Go to good shipment window
-Create a new header
-Go to the more information section
-Fill the ship date field with a date and a time different than the current date.
-Change manually with the keyboard the value of the date and not the time.
-The record is properly saved.
-Open the date selector and select a differente date.
*The time is changed to the curent time.
Proposed Solution-The datetime selector should complete the value with the current time if the field was not previously filled.
-If it was filled it should change only the date
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0020790 closedalostale The date selector on the datetime references should fill the time with the current time after selet a date 
related to design defect 0020701 acknowledgedplatform The datetime selector does not allow to specify the time 

-  Notes
(0062672)
johnfandl (reporter)
2013-12-09 18:17

Note that it is very easy for the user to inadvertently create incorrect time information due to this bug.

The only case it could make sense to automatically set the time to the current system time (current behavior) is if the selected date is TODAY. And even then:

- the system must act consistently between date picker and manual change of date
- if the system is automatically defaulting a new value (over a value the user has previously entered), the system should offer this override to the user explicitly, and allow the user to reject it.
(0062690)
hgbot (developer)
2013-12-10 15:10

Repository: erp/devel/pi
Changeset: 13e17bb49f6804f12c795ca8f5f4540ac09bffec
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Dec 10 15:09:35 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/13e17bb49f6804f12c795ca8f5f4540ac09bffec [^]

fixed issue 25284: in date-time, preserve time if date is changed from selector

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-datetime.js
---
(0062731)
johnfandl (reporter)
2013-12-13 19:13

Hi, can you indicate what MP this fix will be included in?
(0062791)
dbaz (developer)
2013-12-18 14:56

Reviewed @ changeset: 21661 - e16bf47ff9ce
(0062843)
hudsonbot (developer)
2013-12-19 12:30

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b878bb51dc09 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-12-06 09:42 egoitz New Issue
2013-12-06 09:42 egoitz Assigned To => AugustoMauch
2013-12-06 09:42 egoitz Modules => Core
2013-12-06 09:42 egoitz Triggers an Emergency Pack => No
2013-12-06 09:44 egoitz Type defect => design defect
2013-12-06 15:15 egoitz Type design defect => defect
2013-12-09 10:03 egoitz Type defect => design defect
2013-12-09 18:11 johnfandl Issue Monitored: johnfandl
2013-12-09 18:17 johnfandl Note Added: 0062672
2013-12-10 15:01 alostale Relationship added related to 0020790
2013-12-10 15:05 alostale Relationship added related to 0020701
2013-12-10 15:07 alostale Review Assigned To => dbaz
2013-12-10 15:08 alostale Assigned To AugustoMauch => alostale
2013-12-10 15:10 hgbot Checkin
2013-12-10 15:10 hgbot Note Added: 0062690
2013-12-10 15:10 hgbot Status new => resolved
2013-12-10 15:10 hgbot Resolution open => fixed
2013-12-10 15:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/13e17bb49f6804f12c795ca8f5f4540ac09bffec [^]
2013-12-13 19:13 johnfandl Note Added: 0062731
2013-12-18 14:56 dbaz Note Added: 0062791
2013-12-18 14:56 dbaz Status resolved => closed
2013-12-18 14:56 dbaz Fixed in Version => 3.0MP31
2013-12-19 12:30 hudsonbot Checkin
2013-12-19 12:30 hudsonbot Note Added: 0062843


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker