Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025255
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2013-11-29 09:102014-03-06 11:56
ReporterjonalegriaesarteView Statuspublic 
Assigned Todbaz 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchpiFixed in SCM revision764603e2f149
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025255: Some major issues after update to IE11

DescriptionSome major issues after update to IE11
Steps To ReproduceMajor compatibility issues with Internet Explorer 11

- scrollbars do not function

- layers show in wrong design

- buttons do not function
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0022376 closeddbaz Openbravo ERP Openbravo ERP doesn't render well in IE10 
depends on feature request 0025574 closeddbaz Openbravo ERP Upgrade SmartClient 10.0d 
blocks defect 0025479 closeddbaz Modules Calendar does not show available time in IE9 

-  Notes
(0063758)
alostale (developer)
2014-01-28 14:53

Will be fixed by upgrading SC: 0025574
(0063818)
dbaz (developer)
2014-01-30 22:43
edited on: 2014-01-30 22:52

I am going to introduce a patch to do a IE9 emulation and also a fix for the login supported browsers message. This will make IE10 and IE11 operate like if it were IE9. This is a provisional solution until the Smartclient library upgrade be done.

The fix is going to be done in two pushes. The first one is the fix itself, what should be shared with anyone who wants to fix the issue in his own instance. The second one is just copyright year updates and a trigger to enforce the user to refresh the cache (to load the new js code properly). There is not need to share this second push.

IMPORTANT: IE11 has some intranet policies that can prevent this IE9 emulation works if Openbravo is being accessed from an Intranet. To deactivate them and let the patch work ok, go to the IE11 menu and enter into "Compatibility View Settings". There UNCHECK the "Display intranet sites in Compatibility View" option.

(0063819)
hgbot (developer)
2014-01-30 22:58

Repository: erp/devel/pi
Changeset: 764603e2f14934043920c1a056bbd3fc67aff718
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Thu Jan 30 22:54:06 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/764603e2f14934043920c1a056bbd3fc67aff718 [^]

Fixed issue 25255: Added IE9 compatibiliy mode
to ensure Openbravo works ok in IE10 and IE11

---
M src/index.jsp
M web/js/utils.js
---
(0063820)
hgbot (developer)
2014-01-30 22:58

Repository: erp/devel/pi
Changeset: b4873ea66b7b2765b2547072977196283b5c60e0
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Thu Jan 30 22:58:13 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b4873ea66b7b2765b2547072977196283b5c60e0 [^]

Related to issue 25255: Updated copyrights and the revision control number

---
M src/index.jsp
M src/org/openbravo/erpCommon/security/Login.html
M src/org/openbravo/erpCommon/security/Login_F1.html
M web/js/utils.js
---
(0063866)
hgbot (developer)
2014-02-03 16:45

Repository: erp/devel/pi
Changeset: 56ee77f9d094a966eb47fbb7c7c947411ae8930f
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Mon Feb 03 16:45:02 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/56ee77f9d094a966eb47fbb7c7c947411ae8930f [^]

Related to issue 25255: Prevented JS error while trying to load resources
in random circumstances in IE11 with IE9 compatibility mode.

With some Smartclient versions randomly there is a JS error loading uncompressed sources
due that some js located inside the uncompressed file is loaded before other childs
inside it.

This load order change doesn't affect to the deployment of Smartclient, but isc
variable is needed in order to avoid de JS error

---
M src/index.jsp
---
(0064139)
hudsonbot (developer)
2014-02-12 18:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test
(0064140)
hudsonbot (developer)
2014-02-12 18:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test
(0064150)
hudsonbot (developer)
2014-02-12 18:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test
(0064627)
hgbot (developer)
2014-02-26 16:25

Repository: erp/devel/pi
Changeset: b2f7d8ccc2c3dbe2f484adea85efb603c0083969
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Wed Feb 26 16:25:23 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b2f7d8ccc2c3dbe2f484adea85efb603c0083969 [^]

Related to issue 25255: Removed IE9 compatibility mode
since it is not needed anymore due to the Smartclient 10.0d upgrade

---
M src/index.jsp
---
(0064697)
hudsonbot (developer)
2014-02-28 19:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2a3305b1338e [^]
Maturity status: Test
(0064907)
AugustoMauch (developer)
2014-03-06 11:56

Code reviewed and verified in pi@9484419af022

- Issue History
Date Modified Username Field Change
2013-11-29 09:10 jonalegriaesarte New Issue
2013-11-29 09:10 jonalegriaesarte Assigned To => AugustoMauch
2013-11-29 09:10 jonalegriaesarte Modules => Core
2013-11-29 09:10 jonalegriaesarte Triggers an Emergency Pack => No
2014-01-24 08:42 alostale Assigned To AugustoMauch => dbaz
2014-01-24 09:33 alostale Relationship added related to 0022376
2014-01-28 11:56 dbaz Relationship added depends on 0025574
2014-01-28 14:53 alostale Note Added: 0063758
2014-01-28 14:53 alostale Target Version 3.0MP32 => 3.0MP33
2014-01-30 22:43 dbaz Note Added: 0063818
2014-01-30 22:52 dbaz Note Edited: 0063818 View Revisions
2014-01-30 22:58 hgbot Checkin
2014-01-30 22:58 hgbot Note Added: 0063819
2014-01-30 22:58 hgbot Status new => resolved
2014-01-30 22:58 hgbot Resolution open => fixed
2014-01-30 22:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/764603e2f14934043920c1a056bbd3fc67aff718 [^]
2014-01-30 22:58 hgbot Checkin
2014-01-30 22:58 hgbot Note Added: 0063820
2014-02-03 16:45 hgbot Checkin
2014-02-03 16:45 hgbot Note Added: 0063866
2014-02-04 20:30 dbaz Status resolved => new
2014-02-04 20:30 dbaz Resolution fixed => open
2014-02-04 20:30 dbaz Review Assigned To => AugustoMauch
2014-02-04 20:31 dbaz Status new => scheduled
2014-02-04 20:31 dbaz fix_in_branch => pi
2014-02-04 20:31 dbaz Status scheduled => resolved
2014-02-04 20:31 dbaz Resolution open => fixed
2014-02-04 20:31 dbaz Issue Monitored: AugustoMauch
2014-02-12 18:29 hudsonbot Checkin
2014-02-12 18:29 hudsonbot Note Added: 0064139
2014-02-12 18:29 hudsonbot Checkin
2014-02-12 18:29 hudsonbot Note Added: 0064140
2014-02-12 18:29 hudsonbot Checkin
2014-02-12 18:29 hudsonbot Note Added: 0064150
2014-02-26 16:25 hgbot Checkin
2014-02-26 16:25 hgbot Note Added: 0064627
2014-02-28 19:50 hudsonbot Checkin
2014-02-28 19:50 hudsonbot Note Added: 0064697
2014-03-06 11:56 AugustoMauch Note Added: 0064907
2014-03-06 11:56 AugustoMauch Status resolved => closed
2014-03-06 11:56 AugustoMauch Fixed in Version => PR14Q2
2014-03-11 16:24 jonalegriaesarte Relationship added blocks 0025479


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker