Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025215
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-11-26 12:412013-12-02 17:01
ReporterioritzCiaView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP30
StatusclosedFix in branchFixed in SCM revisionc758874d50d4
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_22
OS VersionUbuntu 10.04Database version8.4Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2013-10-07
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/94d0fb15191969d20c2f89b919bec8a95ad33110 [^]
Triggers an Emergency PackNo
Summary

0025215: Close button shows unlock option instead of close the first time.

DescriptionClose button shows unlock option instead of close the first time.

It happens in live in MP29 and does not in MP28.
Steps To Reproduce- Go to a completed Sales Order (it happens in invoices too and probably in other documents).
- Close it, the options in the popup are Reactivate and Unlock, they should be Close and Reactivate.
- Close the popup and open it again.
- Now Close and Reactivate options appear.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0062461)
hgbot (developer)
2013-11-28 18:29

Repository: erp/devel/pi
Changeset: c758874d50d4a817f4c6d12d789c6be499ab2063
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Nov 28 18:14:17 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c758874d50d4a817f4c6d12d789c6be499ab2063 [^]

Fixes issue 25215: All buttons are included in the grid datasource response

Initially only the buttons with label values were considered required for the grid. This was not enough, because there are buttons with docAction that need to have their value present when the button is pressed in order to compute its combos properly.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewTab.java
---
(0062471)
shankarb (developer)
2013-12-01 10:36

Code reviewed and verified in pi changeset da5abac33c8f
(0062493)
hudsonbot (developer)
2013-12-02 17:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9732e7b65447 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-11-26 12:41 ioritzCia New Issue
2013-11-26 12:41 ioritzCia Assigned To => AugustoMauch
2013-11-26 12:41 ioritzCia Modules => Core
2013-11-26 12:41 ioritzCia Triggers an Emergency Pack => No
2013-11-26 12:44 ioritzCia Regression level => Production - QA Approved
2013-11-26 12:44 ioritzCia Description Updated View Revisions
2013-11-26 12:52 ioritzCia Description Updated View Revisions
2013-11-28 18:15 AugustoMauch Issue Monitored: shankarb
2013-11-28 18:15 AugustoMauch Review Assigned To => shankarb
2013-11-28 18:19 AugustoMauch Regression date => 2013-10-07
2013-11-28 18:19 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/94d0fb15191969d20c2f89b919bec8a95ad33110 [^]
2013-11-28 18:29 hgbot Checkin
2013-11-28 18:29 hgbot Note Added: 0062461
2013-11-28 18:29 hgbot Status new => resolved
2013-11-28 18:29 hgbot Resolution open => fixed
2013-11-28 18:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c758874d50d4a817f4c6d12d789c6be499ab2063 [^]
2013-12-01 10:36 shankarb Note Added: 0062471
2013-12-01 10:36 shankarb Status resolved => closed
2013-12-01 10:36 shankarb Fixed in Version => 3.0MP30
2013-12-02 17:01 hudsonbot Checkin
2013-12-02 17:01 hudsonbot Note Added: 0062493


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker