Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025153
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2013-11-14 10:442014-02-12 18:29
ReporterVictorVillarView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionc096dcacef4a
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToVictorVillar
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025153: Costing background process should take into account costing registers already created/imported

DescriptionCosting background process should take into account costing registers already created/imported in order to avoid date range overlapping.
Steps To ReproduceAs group admin role,
Create a new product for * Org. level
  Assign it a purchase price list
  create a new register in Costing tab:
     Starting date: today + 1
     Ending date: 31/12/9999
     Warehouse: blank
     Cost: 5
Create physical inventory for this product --> Qty count: 10 and process it.
Launch the Costing background process, you realise that the process has finished successfully

Check the Costing tab, and realise that there are two registers:
   1.- Starting date: today + 1
     Ending date: 31/12/9999
   2.- Starting date: today
     Ending date: 31/12/9999

There is dates range overlapping.

Also, it is necessary to check with the first transaction as Production. Because the process called is different (ma_production_cost function) than the Costing Background Process due to is a production transaction

 
Proposed SolutionThe solution should be:

   1.- Starting date: today + 1
     Ending date: 31/12/9999
   2.- Starting date: today
     Ending date: today + 1
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0063696)
AtulOpenbravo (developer)
2014-01-27 08:52

Test Plan
- Login as F&B International Group Admin role.
- Create a new product for in '*' Org.
- Set price for it in Purchase Price List.
- Create a new record in Costing tab for product:
     Starting date: today + 1
     Ending date: 31/12/9999
     Warehouse: blank
     Cost: 5
- Create physical inventory for this product --> Qty count: 10 and process it.
- Launch the Costing background process, check that process has finished successfully.
- Check the Costing tab, and there are two records:

   1. Starting date: today
      Ending date : today + 1

   2. Starting date: today + 1
      Ending date : 31/12/9999
(0063764)
hgbot (developer)
2014-01-28 18:23

Repository: erp/devel/pi
Changeset: c096dcacef4a6b9d1c6de800befc9fe53bc0d279
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Fri Jan 24 15:45:25 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/c096dcacef4a6b9d1c6de800befc9fe53bc0d279 [^]

Fixes Issue 25153 Costing process should consider manual costing entries

---
M src/org/openbravo/costing/AverageAlgorithm.java
---
(0063811)
VictorVillar (developer)
2014-01-30 13:49

Verified
(0064130)
hudsonbot (developer)
2014-02-12 18:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-11-14 10:44 VictorVillar New Issue
2013-11-14 10:44 VictorVillar Assigned To => dmiguelez
2013-11-14 10:44 VictorVillar Modules => Core
2013-11-14 10:44 VictorVillar Triggers an Emergency Pack => No
2013-11-14 10:44 VictorVillar Assigned To dmiguelez => jonalegriaesarte
2013-11-14 10:44 VictorVillar Issue Monitored: networkb
2013-11-18 16:26 jonalegriaesarte Target Version 3.0MP30 => 3.0MP31
2014-01-02 12:38 jonalegriaesarte Target Version 3.0MP31 => 3.0MP32
2014-01-07 12:50 jonalegriaesarte Assigned To jonalegriaesarte => pramakrishnan
2014-01-10 07:54 AtulOpenbravo Assigned To pramakrishnan => AtulOpenbravo
2014-01-10 07:54 AtulOpenbravo Status new => scheduled
2014-01-10 07:54 AtulOpenbravo fix_in_branch => pi
2014-01-27 08:52 AtulOpenbravo Note Added: 0063696
2014-01-28 18:19 AtulOpenbravo Review Assigned To => VictorVillar
2014-01-28 18:19 AtulOpenbravo fix_in_branch pi =>
2014-01-28 18:23 hgbot Checkin
2014-01-28 18:23 hgbot Note Added: 0063764
2014-01-28 18:23 hgbot Status scheduled => resolved
2014-01-28 18:23 hgbot Resolution open => fixed
2014-01-28 18:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c096dcacef4a6b9d1c6de800befc9fe53bc0d279 [^]
2014-01-30 13:49 VictorVillar Note Added: 0063811
2014-01-30 13:49 VictorVillar Status resolved => closed
2014-02-12 18:29 hudsonbot Checkin
2014-02-12 18:29 hudsonbot Note Added: 0064130


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker