Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025115
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementminoralways2013-11-08 10:222014-02-12 18:29
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision9b47b9cdf8c1
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025115: Not possible to use update characteristics depending on the characteristic name

DescriptionIs not possible to use update characteristics if the characteristic name contains a slash (/)
Steps To Reproduce1) Go to product characteristics window and create a new non-variant characteristic with the following name: A/B
2) Create some values for this characteristic
3) Go to the product window, and create a new product an assign the characteristic created in step 1) to it.
4) Click on the Update Characteristics button. Notice that the drop down list is not displaying any value.
5) In the Product Characteristic window again, update the characteristic name, removing the slash: AB
6) Click on the Update Characteristics button. Now the drop down list displays the characteristics values
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0063720)
alostale (developer)
2014-01-27 15:49

The problem is in SC.

In PickList.formatPickListValue this.pickList.getField(fieldName) returns null because ListGrid.getField assumes a name having / is a "data path" which has a different logic.
(0063721)
hgbot (developer)
2014-01-27 16:03

Repository: erp/devel/pi
Changeset: 9b47b9cdf8c15ff3223c5b3ed832e3a1b11911e7
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jan 27 16:03:14 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9b47b9cdf8c15ff3223c5b3ed832e3a1b11911e7 [^]

fixed bug 25115: cannot update characteristics depending on its name

  SC client doesn't support field names with / character

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/event/UpdateInvariantCharacteristicsHandler.java
M web/js/productCharacteristicsProcess.js
---
(0063753)
AugustoMauch (developer)
2014-01-28 13:17

Code reviewed and verified in pi@9b47b9cdf8c1
(0064120)
hudsonbot (developer)
2014-02-12 18:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-11-08 10:22 caristu New Issue
2013-11-08 10:22 caristu Assigned To => caristu
2013-11-08 10:22 caristu Modules => Core
2013-11-08 10:22 caristu Triggers an Emergency Pack => No
2013-11-08 10:22 caristu Issue Monitored: networkb
2013-11-08 10:29 caristu Assigned To caristu => jonalegriaesarte
2013-11-11 16:38 jonalegriaesarte Target Version 3.0MP30 => 3.0MP31
2013-12-09 16:11 jonalegriaesarte Target Version 3.0MP31 => 3.0MP32
2014-01-19 08:54 gauravdeshmukh Assigned To jonalegriaesarte => gauravdeshmukh
2014-01-27 11:39 dmiguelez Assigned To gauravdeshmukh => dbaz
2014-01-27 15:49 alostale Note Added: 0063720
2014-01-27 15:59 alostale Assigned To dbaz => alostale
2014-01-27 15:59 alostale Review Assigned To => AugustoMauch
2014-01-27 16:03 hgbot Checkin
2014-01-27 16:03 hgbot Note Added: 0063721
2014-01-27 16:03 hgbot Status new => resolved
2014-01-27 16:03 hgbot Resolution open => fixed
2014-01-27 16:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9b47b9cdf8c15ff3223c5b3ed832e3a1b11911e7 [^]
2014-01-28 13:17 AugustoMauch Note Added: 0063753
2014-01-28 13:17 AugustoMauch Status resolved => closed
2014-01-28 13:17 AugustoMauch Fixed in Version => 3.0MP32
2014-02-12 18:29 hudsonbot Checkin
2014-02-12 18:29 hudsonbot Note Added: 0064120


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker