Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025108
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-11-07 18:232014-03-31 18:11
ReporterioritzCiaView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchpiFixed in SCM revisiona6a8aa7884ae
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025108: export.config.script no taking in account templates dependency

Descriptionexport.config.script no taking in account templates dependency

it results in inconsistent changes in the configScript.xml.
Steps To Reproduce1) Create 3 templates with the following hierarchy
 - Openbravo 3
 --- Template A (depends on Openbravo 3)
 ------ Template B (depends on A)
 --------- Template C (depends on B)

2) ant export.config.script

it wont fail but it is exporting invalid changes
TagsNo tags attached.
Attached Filesgz file icon templates.tar.gz [^] (1,757 bytes) 2014-03-21 09:51

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0022529 closedAugustoMauch export.config.script no taking in account templates dependency 

-  Notes
(0065333)
hgbot (developer)
2014-03-21 08:56

Repository: erp/devel/dbsm-main
Changeset: 3f0764688bff165a7ea614eb0c24de3edaa6f2f7
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Mar 21 08:55:19 2014 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/3f0764688bff165a7ea614eb0c24de3edaa6f2f7 [^]

Fixes issue 25108: export.config.script takes into account templates dependency

The ExportConfigScript class now orders the templates according to its dependencies.

---
M src/org/openbravo/ddlutils/task/ExportConfigScript.java
---
(0065337)
hgbot (developer)
2014-03-21 09:48

Repository: erp/devel/pi
Changeset: bcdd38a8d45e3c1d6afeab5a37bd1c9038b4429c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Mar 21 08:57:54 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/bcdd38a8d45e3c1d6afeab5a37bd1c9038b4429c [^]

Fixes issue 25108: export.config.script takes into account templates dependency

The ExportConfigScript class now orders the templates according to its dependencies.

---
M src-db/database/lib/dbsourcemanager.jar
---
(0065338)
hgbot (developer)
2014-03-21 09:48

Repository: erp/devel/pi
Changeset: a6a8aa7884ae1cd80cc57169235f9e598ab75493
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Mar 21 09:47:44 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a6a8aa7884ae1cd80cc57169235f9e598ab75493 [^]

Fixes issue 25108: export.config.script takes into account templates dependency

The ExportConfigScript class now orders the templates according to its dependencies.

---
M src-db/database/lib/dbsourcemanager.jar
---
(0065339)
AugustoMauch (developer)
2014-03-21 09:51

Reopened to include an attachment
(0065343)
AugustoMauch (developer)
2014-03-21 10:02

Test Plan:
- Download the attached file templates.tar.gz and extract it in the modules/ folder. It contains three templates:
* org.openbravo.a.template1. Depends from the Openbravo template. Changes the seqno of a tab from 10 to 20.
* org.openbravo.b.template2. Depends from org.openbravo.a.template1. Changes the seqno of the same tab from 20 to 30.
* org.openbravo.c.template3. Depends from org.openbravo.b.template2. It does not have any changes
- Change the 'In Development' flag of the modules so the only module in development is the org.openbravo.c.template3 template.
- Execute ant export.database -Dforce=yes -DcheckTranslationConsistency=no and ant export.config.script.
- Check that the file modules/org.openbravo.c.template3/src-db/database/configScript.xml does not contain any changes. Before the fix, it would have contained the change of the tab seqno from 20 to 30.
(0065370)
hudsonbot (developer)
2014-03-22 04:14

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b70224bef848 [^]
Maturity status: Test
(0065371)
hudsonbot (developer)
2014-03-22 04:14

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b70224bef848 [^]
Maturity status: Test
(0065630)
marvintm (developer)
2014-03-31 18:11

Works

- Issue History
Date Modified Username Field Change
2013-11-07 18:23 ioritzCia New Issue
2013-11-07 18:23 ioritzCia Assigned To => AugustoMauch
2013-11-07 18:23 ioritzCia Modules => Core
2013-11-07 18:23 ioritzCia Triggers an Emergency Pack => No
2013-11-07 18:23 ioritzCia Issue generated from 0022529
2013-11-07 18:23 ioritzCia Relationship added duplicate of 0022529
2014-03-11 17:17 jonalegriaesarte Target Version => PR14Q2
2014-03-21 08:56 hgbot Checkin
2014-03-21 08:56 hgbot Note Added: 0065333
2014-03-21 08:56 hgbot Status new => resolved
2014-03-21 08:56 hgbot Resolution open => fixed
2014-03-21 08:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/dbsm-main/rev/3f0764688bff165a7ea614eb0c24de3edaa6f2f7 [^]
2014-03-21 08:56 AugustoMauch Issue Monitored: marvintm
2014-03-21 08:57 AugustoMauch Review Assigned To => marvintm
2014-03-21 08:57 AugustoMauch Status resolved => closed
2014-03-21 08:57 AugustoMauch Status closed => new
2014-03-21 08:57 AugustoMauch Resolution fixed => open
2014-03-21 09:48 hgbot Checkin
2014-03-21 09:48 hgbot Note Added: 0065337
2014-03-21 09:48 hgbot Status new => resolved
2014-03-21 09:48 hgbot Resolution open => fixed
2014-03-21 09:48 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/dbsm-main/rev/3f0764688bff165a7ea614eb0c24de3edaa6f2f7 [^] => http://code.openbravo.com/erp/devel/pi/rev/bcdd38a8d45e3c1d6afeab5a37bd1c9038b4429c [^]
2014-03-21 09:48 hgbot Checkin
2014-03-21 09:48 hgbot Note Added: 0065338
2014-03-21 09:48 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/bcdd38a8d45e3c1d6afeab5a37bd1c9038b4429c [^] => http://code.openbravo.com/erp/devel/pi/rev/a6a8aa7884ae1cd80cc57169235f9e598ab75493 [^]
2014-03-21 09:51 AugustoMauch Note Added: 0065339
2014-03-21 09:51 AugustoMauch Status resolved => new
2014-03-21 09:51 AugustoMauch Resolution fixed => open
2014-03-21 09:51 AugustoMauch File Added: templates.tar.gz
2014-03-21 09:51 AugustoMauch Status new => scheduled
2014-03-21 09:51 AugustoMauch fix_in_branch => pi
2014-03-21 09:52 AugustoMauch Status scheduled => resolved
2014-03-21 09:52 AugustoMauch Resolution open => fixed
2014-03-21 10:02 AugustoMauch Note Added: 0065343
2014-03-22 04:14 hudsonbot Checkin
2014-03-22 04:14 hudsonbot Note Added: 0065370
2014-03-22 04:14 hudsonbot Checkin
2014-03-22 04:14 hudsonbot Note Added: 0065371
2014-03-31 18:11 marvintm Note Added: 0065630
2014-03-31 18:11 marvintm Status resolved => closed
2014-03-31 18:11 marvintm Fixed in Version => PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker