Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025102
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementminoralways2013-11-07 16:392014-02-12 18:29
ReporterVictorVillarView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revisionea464ad6a487
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToVictorVillar
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025102: Product Characteristic change restriction

DescriptionProduct Characteristic change restriction, the application should avoid to change the Variant flag in Characteristic tab of Product window when all the explode has been done.
Steps To ReproduceAs group admin role,
navigate to Product Characteristics window and create a new one:
  - name Color
  - Variant: Yes

 Values tab:
     - Rojo
     - Verde

Go to product window and create a new one:
    name: Pantalones
 navigate to Characteristics tab:
     create a new register selecting Color --> Variant: Yes
Click on Create All button
change Variant flag = No, save it, and realise that is possible to do it.
Try to change the Variant value= Yes, you can not save it, because there are products that have been created and they are variants.

It should not be possible to change the Variant value in Characteristics tab of Prodeuct window once the explode has already done.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0063448)
AtulOpenbravo (developer)
2014-01-16 18:34

Test Plan
- Login as F&B International Group Admin role.
- Go to Product Characteristics window and create a new record.
  - Name : Color
  - Variant: Yes
- Go to Values tab & create two records.
     - Rojo
     - Verde
- Go to product window and create a new one:
     - Name: Pantalones
- Go to Navigate to Characteristics tab and create a new record selecting Color characteristic, set Variant=Yes.
- Using Create Variant button, create variants.
- Check that once the product variants are created, Variant flag cannot be changed.
(0063564)
hgbot (developer)
2014-01-21 10:38

Repository: erp/devel/pi
Changeset: ea464ad6a487c19f5a1df5da825d5e3bb97d9841
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Jan 16 20:22:11 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/ea464ad6a487c19f5a1df5da825d5e3bb97d9841 [^]

Fixes Issue 0025102:Product Characteristic change restriction

---
M src/org/openbravo/event/ProductCharacteristicEventHandler.java
---
(0063567)
VictorVillar (developer)
2014-01-21 10:59

Verified
(0064098)
hudsonbot (developer)
2014-02-12 18:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-11-07 16:39 VictorVillar New Issue
2013-11-07 16:39 VictorVillar Assigned To => dmiguelez
2013-11-07 16:39 VictorVillar Modules => Core
2013-11-07 16:39 VictorVillar Triggers an Emergency Pack => No
2013-11-07 16:39 VictorVillar Issue Monitored: networkb
2013-11-07 16:41 VictorVillar Target Version 3.0MP29 => 3.0MP31
2013-11-08 12:14 dmiguelez Assigned To dmiguelez => jonalegriaesarte
2013-12-16 09:52 jonalegriaesarte Target Version 3.0MP31 => 3.0MP32
2014-01-14 07:10 AtulOpenbravo Assigned To jonalegriaesarte => AtulOpenbravo
2014-01-14 09:36 AtulOpenbravo Status new => scheduled
2014-01-14 09:36 AtulOpenbravo fix_in_branch => pi
2014-01-16 18:34 AtulOpenbravo Note Added: 0063448
2014-01-21 10:38 hgbot Checkin
2014-01-21 10:38 hgbot Note Added: 0063564
2014-01-21 10:38 hgbot Status scheduled => resolved
2014-01-21 10:38 hgbot Resolution open => fixed
2014-01-21 10:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ea464ad6a487c19f5a1df5da825d5e3bb97d9841 [^]
2014-01-21 10:59 VictorVillar Review Assigned To => VictorVillar
2014-01-21 10:59 VictorVillar Note Added: 0063567
2014-01-21 10:59 VictorVillar Status resolved => closed
2014-02-12 18:29 hudsonbot Checkin
2014-02-12 18:29 hudsonbot Note Added: 0064098


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker