Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025090
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2013-11-05 23:482013-11-19 19:07
ReporterVictorVillarView Statuspublic 
Assigned Todmiguelez 
PriorityurgentResolutionfixedFixed in Version3.0MP30
StatusclosedFix in branchFixed in SCM revisiondd09c73c704e
ProjectionnoneETAnoneTarget Version3.0MP30
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tojonalegriaesarte
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025090: Physical Inventory fails under some circumstancies

DescriptionPhysical Inventory fails under some circumstancies.
The problem is that when you have a product with some Attribute Set Value specified with a Use Attribute Set Value As field set to
Specification, it is not possible to process the Physical Inventory containing this product, it always displays an error message "In line 10
the product has no attribute set".
Steps To ReproduceThe problem is that when you have a product with some Attribute Set Value specified with a Use Attribute Set Value As field set to
Specification, it is not possible to process the Physical Inventory containing this product, it always displays an error message "In line 10
the product has no attribute set".
Proposed SolutionThe problem seems to be fixed by modifying the file /src/org/openbravo/materialmgmt/InventoryCountProcess.java in the function
runChecks around line number 226, from:

where.append(" and coalesce(p." + Product.PROPERTY_ATTRIBUTESETVALUE + ", '-') <> 'F'");

to:

where.append(" and coalesce(p." + Product.PROPERTY_USEATTRIBUTESETVALUEAS + ", '-') <> 'F'");
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0062033)
hgbot (developer)
2013-11-06 00:04

Repository: erp/devel/pi
Changeset: dd09c73c704e0adaab07a7e57bb8ad17709fcc3a
Author: Victor Villar <victor.villar <at> openbravo.com>
Date: Wed Nov 06 00:03:12 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/dd09c73c704e0adaab07a7e57bb8ad17709fcc3a [^]

Fixed issue 25090: Physical Inventory fails
under some circumstancies

---
M src/org/openbravo/materialmgmt/InventoryCountProcess.java
---
(0062041)
jonalegriaesarte (reporter)
2013-11-06 11:23

Closed working fine in customer side.
(0062237)
hudsonbot (developer)
2013-11-19 19:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ab71e0273dc1 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-11-05 23:48 VictorVillar New Issue
2013-11-05 23:48 VictorVillar Assigned To => dmiguelez
2013-11-05 23:48 VictorVillar Modules => Core
2013-11-05 23:48 VictorVillar Triggers an Emergency Pack => No
2013-11-05 23:48 VictorVillar Issue Monitored: networkb
2013-11-06 00:04 hgbot Checkin
2013-11-06 00:04 hgbot Note Added: 0062033
2013-11-06 00:04 hgbot Status new => resolved
2013-11-06 00:04 hgbot Resolution open => fixed
2013-11-06 00:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/dd09c73c704e0adaab07a7e57bb8ad17709fcc3a [^]
2013-11-06 11:23 jonalegriaesarte Review Assigned To => jonalegriaesarte
2013-11-06 11:23 jonalegriaesarte Note Added: 0062041
2013-11-06 11:23 jonalegriaesarte Status resolved => closed
2013-11-06 11:23 jonalegriaesarte Fixed in Version => 3.0MP30
2013-11-19 19:07 hudsonbot Checkin
2013-11-19 19:07 hudsonbot Note Added: 0062237


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker