Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025049
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalalways2013-10-30 16:092013-11-01 01:07
ReporterdbazView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP29
StatusclosedFix in branchpiFixed in SCM revision5a980493ea05
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2013-09-24
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/92740d37c7e2b5b786417a1e03f808cb5b721ec1 [^]
Triggers an Emergency PackNo
Summary

0025049: Filter "and" clause is not working ok

DescriptionIf there is the word "and" in a filter FK item, the text content changes. See "Steps To Reproduce"
Steps To ReproduceGo to "Sales Invoice" window

In the filter row write "Alimentos and Supermercados" in the Business Partner filter (without the quotes)

Tab away

Note that the text has changed to "Alimentos"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0061989)
hgbot (developer)
2013-10-30 23:39

Repository: erp/devel/pi
Changeset: 5a980493ea05c1db4353fc0c1ca127356628bd7c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Oct 30 23:39:07 2013 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5a980493ea05c1db4353fc0c1ca127356628bd7c [^]

Fixes issue 25049: Filter "and" clause is not working ok

This happened because a criterion with an 'and' operation does not include the fieldName as a root property. This property can be accessed from any of its inner criteria.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---
(0061991)
sureshbabu (reporter)
2013-10-31 06:55

still at ERP, in Sales order header section at status bar Total Net Amount shows wrong value.
(0061992)
AugustoMauch (developer)
2013-10-31 10:14

Setting it as fixed again, because it was reopened by mistake
(0061996)
shankarb (developer)
2013-10-31 10:58

Code reviewed and tested in pi changeset 4a43e052de88.
(0062013)
hudsonbot (developer)
2013-11-01 01:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2d6c59f6dc4a [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-10-30 16:09 dbaz New Issue
2013-10-30 16:09 dbaz Assigned To => AugustoMauch
2013-10-30 16:09 dbaz Modules => Core
2013-10-30 16:09 dbaz Triggers an Emergency Pack => No
2013-10-30 18:20 AugustoMauch Regression level => Production - QA Approved
2013-10-30 18:20 AugustoMauch Regression date => 2013-09-24
2013-10-30 18:20 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/92740d37c7e2b5b786417a1e03f808cb5b721ec1 [^]
2013-10-30 23:36 AugustoMauch Issue Monitored: shankarb
2013-10-30 23:36 AugustoMauch Review Assigned To => shankarb
2013-10-30 23:39 hgbot Checkin
2013-10-30 23:39 hgbot Note Added: 0061989
2013-10-30 23:39 hgbot Status new => resolved
2013-10-30 23:39 hgbot Resolution open => fixed
2013-10-30 23:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5a980493ea05c1db4353fc0c1ca127356628bd7c [^]
2013-10-31 06:55 sureshbabu Assigned To AugustoMauch => guilleaer
2013-10-31 06:55 sureshbabu Note Added: 0061991
2013-10-31 06:55 sureshbabu Status resolved => new
2013-10-31 06:55 sureshbabu Resolution fixed => open
2013-10-31 10:14 AugustoMauch Assigned To guilleaer => AugustoMauch
2013-10-31 10:14 AugustoMauch Status new => scheduled
2013-10-31 10:14 AugustoMauch fix_in_branch => pi
2013-10-31 10:14 AugustoMauch Note Added: 0061992
2013-10-31 10:14 AugustoMauch Status scheduled => resolved
2013-10-31 10:14 AugustoMauch Resolution open => fixed
2013-10-31 10:58 shankarb Note Added: 0061996
2013-10-31 10:58 shankarb Status resolved => closed
2013-10-31 10:58 shankarb Fixed in Version => 3.0MP29
2013-11-01 01:07 hudsonbot Checkin
2013-11-01 01:07 hudsonbot Note Added: 0062013


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker