Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024780
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajorhave not tried2013-09-16 13:422013-09-17 19:03
ReporteradrianromeroView Statuspublic 
Assigned Toshankarb 
PriorityurgentResolutionfixedFixed in Version3.0MP28
StatusclosedFix in branchFixed in SCM revisiona549285cc9f0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2009-02-02
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/353de8982dab [^]
Triggers an Emergency PackNo
Summary

0024780: Process type PL/SQL Procedure cannot be executed as scheduled

DescriptionA process defined as a PL/SQL Procedure and scheduled throws the following exception when the scheduler tries to execute the process:


674357 [DefaultQuartzScheduler_Worker-9] ERROR org.openbravo.scheduling.DefaultJob - Error executing process org.openbravo.scheduling.ProcessBundle@1cdce2d
java.lang.InstantiationException
    at sun.reflect.InstantiationExceptionConstructorAccessorImpl.newInstance(InstantiationExceptionConstructorAccessorImpl.java:30)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
    at java.lang.Class.newInstance0(Class.java:355)
    at java.lang.Class.newInstance(Class.java:308)
    at org.openbravo.scheduling.DefaultJob.execute(DefaultJob.java:47)
    at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
    at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:525)
Steps To Reproduce* Create a sample PL/SQL Procedure and register it in the window 'Report and Proceses'. Mark it as 'background process' (http://wiki.openbravo.com/wiki/Processes [^])
* Go to the window 'Process request' and create a new request that executes the previous process inmediatelly
* Schedule the process
* Verify that the process has not been executed and that in the openbravo.log is logged the exception described in the previous field
Proposed SolutionIt seems that the problem is because the scheduler tries to instantiate the abstract class org.openbravo.erpCommon.ad_process.ProcedureProcess. The solution is replace the code and instantiate instead the class org.openbravo.erpCommon.ad_process.PinstanceProcedure

The attached patch fixes this issue
TagsRegression
Attached Filespatch file icon scheduleprocess.patch [^] (949 bytes) 2013-09-16 13:42 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0061184)
hgbot (developer)
2013-09-17 08:33

Repository: erp/devel/pi
Changeset: a549285cc9f06226f1fd5567340749d3dd325312
Author: Adrián Romero <adrianromero <at> openbravo.com>
Date: Tue Sep 17 12:00:46 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/a549285cc9f06226f1fd5567340749d3dd325312 [^]

Fixes Issue 0024780: Process type PL/SQL Procedure cannot be executed as scheduled

The scheduler tries to instantiate the abstract class org.openbravo.erpCommon.ad_process.ProcedureProcess.
Instead of tha instantiating the class org.openbravo.erpCommon.ad_process.PinstanceProcedure.

---
M src/org/openbravo/scheduling/ProcessBundle.java
---
(0061185)
shankarb (developer)
2013-09-17 08:34

Code reviewed and verified in pi changeset a549285cc9f0.
(0061262)
hudsonbot (developer)
2013-09-17 19:03

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c53d622fc50 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-09-16 13:42 adrianromero New Issue
2013-09-16 13:42 adrianromero Assigned To => dmiguelez
2013-09-16 13:42 adrianromero File Added: scheduleprocess.patch
2013-09-16 13:42 adrianromero Modules => Core
2013-09-16 13:42 adrianromero Triggers an Emergency Pack => No
2013-09-16 13:42 adrianromero Tag Attached: Regression
2013-09-16 15:56 adrianromero Review Assigned To => shankarb
2013-09-17 08:27 shankarb Regression level => Production - Confirmed Stable
2013-09-17 08:27 shankarb Regression date => 2009-02-02
2013-09-17 08:27 shankarb Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/353de8982dab [^]
2013-09-17 08:27 shankarb Review Assigned To shankarb => AugustoMauch
2013-09-17 08:27 shankarb Assigned To dmiguelez => shankarb
2013-09-17 08:32 shankarb Review Assigned To AugustoMauch => shankarb
2013-09-17 08:33 hgbot Checkin
2013-09-17 08:33 hgbot Note Added: 0061184
2013-09-17 08:33 hgbot Status new => resolved
2013-09-17 08:33 hgbot Resolution open => fixed
2013-09-17 08:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a549285cc9f06226f1fd5567340749d3dd325312 [^]
2013-09-17 08:34 shankarb Note Added: 0061185
2013-09-17 08:34 shankarb Status resolved => closed
2013-09-17 08:34 shankarb Fixed in Version => 3.0MP28
2013-09-17 19:03 hudsonbot Checkin
2013-09-17 19:03 hudsonbot Note Added: 0061262


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker