Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024750
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2013-09-12 11:042013-09-17 19:03
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0MP28
StatusclosedFix in branchFixed in SCM revisionc4ab8576a7ee
ProjectionnoneETAnoneTarget Version3.0MP28
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2013-09-11
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/290c9b12a211 [^]
Triggers an Emergency PackNo
Summary

0024750: characteristics filter fails in Product window with adaptive filtering

DescriptionAfter pushing adaptive filtering capability (https://code.openbravo.com/erp/devel/pi/rev/290c9b12a211 [^]), Product Characteristics filter is not working in Product window.

The problem occurs when the number of products is <= 100, in this case when the Product window is opened, the whole set of data is retrieved in a single page without any criteria.

When SmartClient determines if a criteria is more restrictive to decide if adaptive filtering can be applied, checks data was retrieved without any criteria so as a new one has been added it is always more restrictive without need of checking it for the operator.

In client filtering cannot be used for characteristics because there is no enough information at client side, so whenever this filter changes, a request to backend is required.
Steps To ReproduceHaving less than 100 products in database:
- Open Product window
- Filter by product characteristics
  * No filter is applied
  * A javascript error is thrown:
Uncaught TypeError: Object #<Object> has no method 'condition' DataSource.js:19568
isc.DataSource.addMethods.evaluateCriterion DataSource.js:19568
isc.Class.addClassMethods.invokeSuper Class.js:1099
isc.Class.addClassMethods.Super Class.js:944
isc.OBRestDataSource.addProperties.evaluateCriterion 9c70f4b1eb82d9921b4dd68073402d5e.js:3944
booleanOperator
Proposed SolutionWhenever filter for characteristics is changed, force backed request by removing cached localData
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0061089)
hgbot (developer)
2013-09-12 11:09

Repository: erp/devel/pi
Changeset: c4ab8576a7eed9e9616b4a9c0568fcf91719a3a6
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Sep 12 11:09:04 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c4ab8576a7eed9e9616b4a9c0568fcf91719a3a6 [^]

fixed bug 24750: characteristics filter fails in Product window

  Forcing backend call whenever filter changes

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-characteristics.js
---
(0061115)
AugustoMauch (developer)
2013-09-12 18:20

Code reviewed and verified in pi@74a1c5d100ae
(0061241)
hudsonbot (developer)
2013-09-17 19:03

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c53d622fc50 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-09-12 11:04 alostale New Issue
2013-09-12 11:04 alostale Assigned To => alostale
2013-09-12 11:04 alostale Modules => Core
2013-09-12 11:04 alostale Triggers an Emergency Pack => No
2013-09-12 11:04 alostale Regression level => Pre packaging ( pi )
2013-09-12 11:04 alostale Regression date => 2013-09-11
2013-09-12 11:04 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/290c9b12a211 [^]
2013-09-12 11:05 alostale Review Assigned To => AugustoMauch
2013-09-12 11:09 hgbot Checkin
2013-09-12 11:09 hgbot Note Added: 0061089
2013-09-12 11:09 hgbot Status new => resolved
2013-09-12 11:09 hgbot Resolution open => fixed
2013-09-12 11:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c4ab8576a7eed9e9616b4a9c0568fcf91719a3a6 [^]
2013-09-12 18:20 AugustoMauch Note Added: 0061115
2013-09-12 18:20 AugustoMauch Status resolved => closed
2013-09-12 18:20 AugustoMauch Fixed in Version => 3.0MP28
2013-09-17 19:03 hudsonbot Checkin
2013-09-17 19:03 hudsonbot Note Added: 0061241


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker