Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024696
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementminoralways2013-09-05 12:002013-09-17 19:02
ReporteregoitzView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0MP28
StatusclosedFix in branchFixed in SCM revision208c8406036f
ProjectionnoneETAnoneTarget Version3.0MP28
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-01-16
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/38af5fb36bd9 [^]
Triggers an Emergency PackNo
Summary

0024696: When you are writing on a product field on the order window, when you delete all the text, you get a error on the log

DescriptionWhen you are writing on a product field on the order window, when you delete all the text, you get a error on the log
Steps To Reproduce-Open the sales order window
-Create a header
-Create a new line
-ON product field start writting to find a product
-Then delete all the text.
*When you delete all the text a error is shown on the openbravo.log at tomcat.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0060927)
alostale (developer)
2013-09-05 12:14
edited on: 2013-09-05 12:15

This is the error:
1f923ef8 3676632 [http-8080-2] ERROR org.openbravo.client.application.window.FormInitializationComponent - Couldn't parse callout response. The parsed response was: var calloutName='SL_Order_Product';

var respuesta = new Array(new Array("inpcUomId", ""),new Array("inppricelist", 0),new Array("inppricelimit", 0),new Array("inppricestd", 0),new Array("inppriceactual", ),new Array("inpcCurrencyId", "102"),new Array("inpdiscount", 0),new Array("inpmProductUomId", null
),new Array("EXECUTE", "displayLogic();"),
new Array("CURSOR_FIELD", "inpqtyordered")
, new Array("CURSOR_FIELD", "inpquantityorder")
);
org.mozilla.javascript.EvaluatorException: syntax error (<cmd>#3)

Problem is in:

new Array("inppriceactual", )

(0060928)
hgbot (developer)
2013-09-05 12:19

Repository: erp/devel/pi
Changeset: 208c8406036f6e63283df451d069a9836cf5505c
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Sep 05 12:18:56 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/208c8406036f6e63283df451d069a9836cf5505c [^]

fixed bug 24696: error in log when empty product selector in Order window

  if price actual is not calculated because there's no product set 0 instead of blank

---
M src/org/openbravo/erpCommon/ad_callouts/SL_Order_Product.java
---
(0061151)
shankarb (developer)
2013-09-14 15:12

Code reviewed and tested in pi changeset ceeb08524ec9.
(0061221)
hudsonbot (developer)
2013-09-17 19:02

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c53d622fc50 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-09-05 12:00 egoitz New Issue
2013-09-05 12:00 egoitz Assigned To => alostale
2013-09-05 12:00 egoitz Modules => Core
2013-09-05 12:00 egoitz Triggers an Emergency Pack => No
2013-09-05 12:01 egoitz Regression level => Production - Confirmed Stable
2013-09-05 12:01 egoitz Regression date => 2013-01-16
2013-09-05 12:01 egoitz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/38af5fb36bd9 [^]
2013-09-05 12:14 alostale Severity major => minor
2013-09-05 12:14 alostale Note Added: 0060927
2013-09-05 12:15 alostale Note Edited: 0060927 View Revisions
2013-09-05 12:19 alostale Review Assigned To => shankarb
2013-09-05 12:19 hgbot Checkin
2013-09-05 12:19 hgbot Note Added: 0060928
2013-09-05 12:19 hgbot Status new => resolved
2013-09-05 12:19 hgbot Resolution open => fixed
2013-09-05 12:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/208c8406036f6e63283df451d069a9836cf5505c [^]
2013-09-14 15:12 shankarb Note Added: 0061151
2013-09-14 15:12 shankarb Status resolved => closed
2013-09-14 15:12 shankarb Fixed in Version => 3.0MP28
2013-09-17 19:02 hudsonbot Checkin
2013-09-17 19:02 hudsonbot Note Added: 0061221


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker