Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024689
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-09-04 13:582013-09-17 19:02
ReporterpsarobeView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0MP27
StatusclosedFix in branchFixed in SCM revision48a572198722
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024689: New search selector for characteristic description is not working well

DescriptionIt is filtering by the natural tree of the organization you have login instead of the organization your role has access to
Steps To Reproduce1. Create a product characteristic in US inc
2. Enter a couple of values
3. Logout and login (Openbravo/openbravo). Notice that by default you login with org España-Norte
4. Go to Product window and open the new search selector by going to the field Characteristic description. Click the button
5. No items are shown. This is wrong since Openbravo has access to all organizations

You should see the characteristics created
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0060914)
alostale (developer)
2013-09-04 14:00

It should filter by the organizations within in the trees of all granted ones.
(0060915)
hgbot (developer)
2013-09-04 14:02

Repository: erp/devel/pi
Changeset: 48a572198722d8cac0515753378fdf62ac218281
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Sep 04 14:01:08 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/48a572198722d8cac0515753378fdf62ac218281 [^]

fixed bug 24689: incorrect org filter in characteristics pop up

---
M src/org/openbravo/materialmgmt/ProductCharacteristicsDS.java
---
(0060920)
AugustoMauch (developer)
2013-09-04 15:58

Code reviewed and verified in pi@21070:48a572198722
(0061215)
hudsonbot (developer)
2013-09-17 19:02

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c53d622fc50 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-09-04 13:58 psarobe New Issue
2013-09-04 13:58 psarobe Assigned To => AugustoMauch
2013-09-04 13:58 psarobe Modules => Core
2013-09-04 13:58 psarobe Triggers an Emergency Pack => No
2013-09-04 14:00 alostale Note Added: 0060914
2013-09-04 14:02 hgbot Checkin
2013-09-04 14:02 hgbot Note Added: 0060915
2013-09-04 14:02 hgbot Status new => resolved
2013-09-04 14:02 hgbot Resolution open => fixed
2013-09-04 14:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/48a572198722d8cac0515753378fdf62ac218281 [^]
2013-09-04 14:02 alostale Assigned To AugustoMauch => alostale
2013-09-04 14:03 alostale Review Assigned To => AugustoMauch
2013-09-04 15:58 AugustoMauch Note Added: 0060920
2013-09-04 15:58 AugustoMauch Status resolved => closed
2013-09-04 15:58 AugustoMauch Fixed in Version => 3.0MP27
2013-09-17 19:02 hudsonbot Checkin
2013-09-17 19:02 hudsonbot Note Added: 0061215


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker