Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024660
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsminoralways2013-09-02 13:222014-03-14 10:53
ReportersureshbabuView Statuspublic 
Assigned Toguilleaer 
PrioritylowResolutionfixedFixed in VersionRMP26.1
StatusclosedFix in branchpiFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024660: RMP26.1: Precision issue in Price list not inclusive of taxes when applying receipt discount Disc_fixed_5_Perc is applied

Description Precision issue in Price list not inclusive of taxes when applying receipt discount Disc_fixed_5_Perc is applied
Steps To Reproduce1) create a receipt with below details
Product: Base camp Lantern Qty:1
Product: Torch Mini Qty:1

2) Then apply Receipt discounts "Disc_fixed_5_Perc"

3) Check the discount amount(precision issue) in both the line items

Defect:
For line 1, Product: Base camp Lantern actual Discount amount is 2.77 where as the expected one is 2.78

For line 2, Product: Torch Mini actual Discount amount is 0.67 where as the expected one is 0.68


Taxable amount shown as 65.56 but the expected taxable amount is 65.54

TagsNo tags attached.
Attached Filespng file icon Precision issue in Price list not inclusive of taxes when applying receipt discount Disc_fixed_5_Perc is applied.png [^] (225,423 bytes) 2013-09-02 13:22

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0060885)
guilleaer (developer)
2013-09-03 10:34

https://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/d3d9aeb381a4a6fd6c15961fbaf4a0f10db9a7bd [^]
(0065153)
sureshbabu (reporter)
2014-03-14 07:57

@Guilleaer: Not sure what is the expected result here..because i am finding the same behavior here.
(0065159)
guilleaer (developer)
2014-03-14 10:53

It is working fine.
----------
line 1:
price: 55.5
disc: 5%

55.5 * 0.95 = 52.725 -> round -> 52.73
55.5 - 52.73 = 2.77 -> Fine!
---------------

line 2:
price: 13.5
disc: 5%

13.5 * 0.95 = 12.825 -> round -> 12.83
13.5 - 12.83 = 0.67 -> fine!
---------------

Taxable amount is fine -> (55.5 - 2.77) + (13.5 - 0.67) = 65.56

- Issue History
Date Modified Username Field Change
2013-09-02 13:22 sureshbabu New Issue
2013-09-02 13:22 sureshbabu Assigned To => marvintm
2013-09-02 13:22 sureshbabu File Added: Precision issue in Price list not inclusive of taxes when applying receipt discount Disc_fixed_5_Perc is applied.png
2013-09-02 13:22 sureshbabu Triggers an Emergency Pack => No
2013-09-03 10:33 guilleaer Assigned To marvintm => guilleaer
2013-09-03 10:33 guilleaer Status new => scheduled
2013-09-03 10:33 guilleaer fix_in_branch => pi
2013-09-03 10:34 guilleaer Note Added: 0060885
2013-09-03 10:34 guilleaer Status scheduled => resolved
2013-09-03 10:34 guilleaer Fixed in Version => RMP26.1
2013-09-03 10:34 guilleaer Resolution open => fixed
2013-09-03 17:07 marvintm Review Assigned To => marvintm
2013-09-03 17:07 marvintm Status resolved => closed
2014-03-14 07:57 sureshbabu Note Added: 0065153
2014-03-14 10:53 guilleaer Note Added: 0065159


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker