Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024636
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2013-08-30 13:222013-09-17 19:01
ReporterVictorVillarView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision521d66167db4
ProjectionnoneETAnoneTarget Version3.0MP28
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToVictorVillar
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024636: Physical inventories with Non Stocakble Products generate warehouse transactions

DescriptionPhysical inventories with Non Stocakble Products generate warehouse transactions and it should not. There are registers in the m_transaction table and it should not. This situation does not happen with other warehouse transactions documents.
Steps To ReproduceAs group Admin role,
Go to Product window,
 create a new register-- Stockable = No

Go to Physical inventory window,
   Create a new register
     Lines tab:
         * Select the product created before (remove the selector filter)
           Qty count = 5
Process it.
Go to Product window || Transactions tab for this product
     Realise that there is a transaction and it should not because it is not a stockable product.
    
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0060889)
hgbot (developer)
2013-09-03 12:16

Repository: erp/devel/pi
Changeset: 521d66167db4eb6457834b1f9f7ebbb490e03e61
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Sep 03 12:15:31 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/521d66167db4eb6457834b1f9f7ebbb490e03e61 [^]

fixes issue 24636: Physical inventories with
Non Stocakble Products generate warehouse transactions

---
M src/org/openbravo/materialmgmt/InventoryCountProcess.java
---
(0060891)
hgbot (developer)
2013-09-03 12:50

Repository: erp/devel/pi
Changeset: 407350b7255b14d8f158578a4bb207f914222d3f
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Sep 03 12:48:56 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/407350b7255b14d8f158578a4bb207f914222d3f [^]

related to issue 24636: code improved to use entity properties

---
M src/org/openbravo/materialmgmt/InventoryCountProcess.java
---
(0061068)
VictorVillar (developer)
2013-09-11 01:14

Verified
(0061205)
hudsonbot (developer)
2013-09-17 19:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c53d622fc50 [^]

Maturity status: Test
(0061206)
hudsonbot (developer)
2013-09-17 19:01

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c53d622fc50 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-08-30 13:22 VictorVillar New Issue
2013-08-30 13:22 VictorVillar Assigned To => dmiguelez
2013-08-30 13:22 VictorVillar Modules => Core
2013-08-30 13:22 VictorVillar Triggers an Emergency Pack => No
2013-08-30 13:22 VictorVillar Issue Monitored: networkb
2013-09-02 06:26 anherzog Issue Monitored: anherzog
2013-09-03 09:35 jonalegriaesarte Assigned To dmiguelez => caristu
2013-09-03 12:16 hgbot Checkin
2013-09-03 12:16 hgbot Note Added: 0060889
2013-09-03 12:16 hgbot Status new => resolved
2013-09-03 12:16 hgbot Resolution open => fixed
2013-09-03 12:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/521d66167db4eb6457834b1f9f7ebbb490e03e61 [^]
2013-09-03 12:50 hgbot Checkin
2013-09-03 12:50 hgbot Note Added: 0060891
2013-09-11 01:14 VictorVillar Review Assigned To => VictorVillar
2013-09-11 01:14 VictorVillar Note Added: 0061068
2013-09-11 01:14 VictorVillar Status resolved => closed
2013-09-17 19:01 hudsonbot Checkin
2013-09-17 19:01 hudsonbot Note Added: 0061205
2013-09-17 19:01 hudsonbot Checkin
2013-09-17 19:01 hudsonbot Note Added: 0061206


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker