Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024613
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2013-08-28 13:032013-10-07 16:58
ReporterjonalegriaesarteView Statuspublic 
Assigned Toumartirena 
PrioritynormalResolutionfixedFixed in VersionRMP27
StatusclosedFix in branchFixed in SCM revision1ad625e1ae55
ProjectionnoneETAnoneTarget VersionRMP27
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRMP25SCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024613: Search window in WebPOS is not working when the amount of business partners is large

DescriptionSearch window in WebPOS is not working when the amount of business partners is large
Steps To ReproduceWith 10000 business partners try to search one in WebPOS. The window does not work
Proposed SolutionOne of the issues, is the search for eg. customers (total bps > 10'000): when you
do a search the table jumps to the last entry of the alphabetically sorted list. Users are used to see the first record of such a list on top. Possible solution:
----- BEGIN CODE ------
enyo.kind({
name: 'OB.UI.ScrollableTable',

....some code....

this.collection.on('add', function (model, prop, options) {

this.$.tempty.hide();
this.$.tbody.show();

this._addModelToCollection(model, options.index);

if (this.listStyle === 'list') {
if (!this.selected) {
model.trigger('selected', model);
}
} else if (this.listStyle === 'edit') {
model.trigger('selected', model);
}
//Put scroller in the position of new item
/*
* BEGIN CHANGE
* @author a.herzog
*/
//this.getScrollArea().scrollToControl(this.$.tbody.getComponents()[options.index]);
this.getScrollArea().scrollToControl(this.$.tbody.getComponents()[0]);
/*
* END CHANGE
*/
}, this);

------ END CODE ------
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0060800)
marvintm (developer)
2013-08-28 13:07

The main issue here is that the window behaves very poorly, because it's not paginated (it should probably work like the product browser does, with an upper limit on how many records are shown in the list).

Apart from this, there is another usability issue which is that the browser will automatically navigate to the last element in the list. This in general should not happen.
(0061085)
hgbot (developer)
2013-09-11 20:01

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 1ad625e1ae55fbeab4717569d52a67d743bd23e8
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Sep 11 19:59:23 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1ad625e1ae55fbeab4717569d52a67d743bd23e8 [^]

Fixes Issue 24613: Search window in WebPOS is not working when the amount of business partners is large

---
M web/org.openbravo.mobile.core/source/component/ob-scrollabletable.js
---
(0061199)
marvintm (developer)
2013-09-17 16:58

Finally the only change has been to move the focus to the first line of the scroller. The models were already limited, like the product browser, and the performance of the window is adequate even when a big amount of business partners is present in the system.
(0061542)
hgbot (developer)
2013-10-04 09:33

Repository: erp/pmods/org.openbravo.mobile.core-levelpricing
Changeset: 1ad625e1ae55fbeab4717569d52a67d743bd23e8
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Sep 11 19:59:23 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core-levelpricing/rev/1ad625e1ae55fbeab4717569d52a67d743bd23e8 [^]

Fixes Issue 24613: Search window in WebPOS is not working when the amount of business partners is large

---
M web/org.openbravo.mobile.core/source/component/ob-scrollabletable.js
---
(0061589)
guilleaer (developer)
2013-10-07 16:58

reclosed

- Issue History
Date Modified Username Field Change
2013-08-28 13:03 jonalegriaesarte New Issue
2013-08-28 13:03 jonalegriaesarte Assigned To => marvintm
2013-08-28 13:03 jonalegriaesarte Triggers an Emergency Pack => No
2013-08-28 13:07 marvintm Note Added: 0060800
2013-09-03 18:32 marvintm Assigned To marvintm => umartirena
2013-09-11 20:01 hgbot Checkin
2013-09-11 20:01 hgbot Note Added: 0061085
2013-09-11 20:01 hgbot Status new => resolved
2013-09-11 20:01 hgbot Resolution open => fixed
2013-09-11 20:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1ad625e1ae55fbeab4717569d52a67d743bd23e8 [^]
2013-09-17 16:58 marvintm Review Assigned To => marvintm
2013-09-17 16:58 marvintm Note Added: 0061199
2013-09-17 16:58 marvintm Status resolved => closed
2013-09-17 16:58 marvintm Fixed in Version => RMP27
2013-10-04 09:33 hgbot Checkin
2013-10-04 09:33 hgbot Note Added: 0061542
2013-10-04 09:33 hgbot Status closed => resolved
2013-10-04 09:33 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1ad625e1ae55fbeab4717569d52a67d743bd23e8 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core-levelpricing/rev/1ad625e1ae55fbeab4717569d52a67d743bd23e8 [^]
2013-10-07 16:58 guilleaer Note Added: 0061589
2013-10-07 16:58 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker