Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024454
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacecriticalhave not tried2013-07-31 10:512013-07-31 20:56
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP26
StatusclosedFix in branchFixed in SCM revision7e5e4ef85dc7
ProjectionnoneETAnoneTarget Version3.0MP27
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2013-06-16
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4060f2b5e6bd [^]
Triggers an Emergency PackNo
Summary

0024454: The datetime fields are not working

DescriptionThe datetime field are not working. When opening the popup to select the date, after select a field the field is not filled.
Also if changing the month on a field previously filled, the field is cleared.
Steps To Reproduce-Define a template
-As system administrator change the definition of the transactions tab on Product window by changing it from read only to standard
-Logout and login
-Go to product window
-Select a product and go to transactions tab
-Try to change the month of the Transaction Process Date field
*the field is cleared

-Click on new and try to enter a datetime from the date selector on the Transaction Process Date field.
*the field is not filled
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0060397)
hgbot (developer)
2013-07-31 11:42

Repository: erp/devel/pi
Changeset: 7e5e4ef85dc78c06a8baf0357651b70ea20e9055
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Jul 31 11:40:49 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7e5e4ef85dc78c06a8baf0357651b70ea20e9055 [^]

Fixes issue 24454: Datetime fields can be edited

The problem was that at one point the date format was being used to format a datetime value. Depending on the type of value (date or datetime), a different format needs to be used.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-date.js
---
(0060403)
shankarb (developer)
2013-07-31 12:27

Code reviewed and tested in pi changeset 7e5e4ef85dc7.
(0060443)
hudsonbot (developer)
2013-07-31 20:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4dbc2065ad03 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-07-31 10:51 egoitz New Issue
2013-07-31 10:51 egoitz Assigned To => dbaz
2013-07-31 10:51 egoitz Modules => Core
2013-07-31 10:51 egoitz Triggers an Emergency Pack => No
2013-07-31 10:53 egoitz Regression level => Production - QA Approved
2013-07-31 10:53 egoitz Triggers an Emergency Pack No => Yes
2013-07-31 11:11 AugustoMauch Assigned To dbaz => AugustoMauch
2013-07-31 11:40 AugustoMauch Issue Monitored: shankarb
2013-07-31 11:41 AugustoMauch Review Assigned To => shankarb
2013-07-31 11:42 hgbot Checkin
2013-07-31 11:42 hgbot Note Added: 0060397
2013-07-31 11:42 hgbot Status new => resolved
2013-07-31 11:42 hgbot Resolution open => fixed
2013-07-31 11:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7e5e4ef85dc78c06a8baf0357651b70ea20e9055 [^]
2013-07-31 12:09 plujan Triggers an Emergency Pack Yes => No
2013-07-31 12:10 plujan Regression date => 2013-06-16
2013-07-31 12:10 plujan Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/4060f2b5e6bd [^]
2013-07-31 12:27 shankarb Note Added: 0060403
2013-07-31 12:27 shankarb Status resolved => closed
2013-07-31 12:27 shankarb Fixed in Version => 3.0MP26
2013-07-31 20:56 hudsonbot Checkin
2013-07-31 20:56 hudsonbot Note Added: 0060443


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker