Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024402
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2013-07-23 15:232013-10-17 11:32
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0MP29
StatusclosedFix in branchpiFixed in SCM revision94d0fb151919
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024402: API Change: When the datasource is called from the grid, only the visible columns are fetched

DescriptionSo far, when the grid fetches data from its datasource, the datasource returned all the entity properties for each record, even if some of them are not shown in the grid.

This has been changed, so now only the columns that are visible in the grid are fetched (plus some other mandatory ones, like the id and those properties who are part of display logic of buttons).

This change may affect manual processes [1]. Someone might have written a manual process that uses a column that is no longer available in the grid. To prevent this developers should use the best practice that consists in sending the id of the selected row to the Java process. There, the full entity can be obtained with all its properties.


[1] http://wiki.openbravo.com/wiki/How_to_create_a_Manual_UI_Process#JavaScript_Implementation [^]
Steps To Reproduce-
Proposed SolutionIf someone has been affected by this change in a manual process, they should just send the id of the selected record (or records) and then fetch the full entity in the back end process.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 00244033.0MP29 closedAugustoMauch When the grid calls the datasource, it should not retrieve the properties that are not shown in the grid. 
related to design defect 0036166 acknowledgedplatform Cannot add a product to a commission line if Currency is not shown in header 

-  Notes
(0060178)
dmitry_mezentsev (developer)
2013-07-23 15:54

Approved.
(0060535)
hgbot (developer)
2013-08-07 16:27

Repository: erp/devel/pi
Changeset: 8b3d1a079183a8132c233d52b48014f492d2c530
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Aug 07 16:26:59 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8b3d1a079183a8132c233d52b48014f492d2c530 [^]

fixed bug 24504, fixed bug 24502, related to bug 24403, related to bug 24402

  Backout of fix for issue 0024403 as it creates regressions 0024504 and 0024502

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/ob-view-grid.js.ftl
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewFieldHandler.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0060539)
alostale (developer)
2013-08-07 16:29

Reopening because issue 0024403 has been backed out
(0060636)
hudsonbot (developer)
2013-08-16 20:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/59a1180e7f4f [^]

Maturity status: Test
(0061592)
hgbot (developer)
2013-10-07 17:27

Repository: erp/devel/pi
Changeset: 94d0fb15191969d20c2f89b919bec8a95ad33110
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Oct 07 17:17:08 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/94d0fb15191969d20c2f89b919bec8a95ad33110 [^]

Fixes bug 24402, fixes bug 24403: Grid Datasource load minimum property set

Changes with respect to changeset 20851:
- In the FIC, do not try to set in the session the values of properties that are empty in the request due to being shown only in grid view. In this case the value that will prevail will be the one present in the database.
- New mandatory property fields:
      * Client and organization
      * Button fields with label values
      * Link to parent properties
- In the grid, do not detect as a change if a value change from undefined to not undefined. Otherwise, when the user opens a record in form view the record would appear as changed. This happens because the properties that are present in the form but not in the grid change from undefined to not undefined.
- The fieldStateChanged function has been deleted. This function handled the case when the user added a new column to the grid while it was being edited. This action is no longer allowed, so the function serves no purpose.
- The FIC call in the setContextInfo has been changed from SETSESSION to EDIT, because now in the response we need the values of all the view fields, not only the shown in the grid. A callback has been defined to apply this new values to the grid.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/ob-view-grid.js.ftl
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewFieldHandler.java
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view-datasource.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-toolbar.js
---
(0061730)
hudsonbot (developer)
2013-10-16 19:46

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/51315988909a [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-07-23 15:23 AugustoMauch New Issue
2013-07-23 15:23 AugustoMauch Assigned To => dmitry_mezentsev
2013-07-23 15:23 AugustoMauch Modules => Core
2013-07-23 15:23 AugustoMauch Triggers an Emergency Pack => No
2013-07-23 15:54 dmitry_mezentsev Note Added: 0060178
2013-07-23 15:55 dmitry_mezentsev Assigned To dmitry_mezentsev => AugustoMauch
2013-07-23 16:44 AugustoMauch Relationship added related to 0024403
2013-08-06 17:25 alostale Status new => scheduled
2013-08-06 17:25 alostale fix_in_branch => pi
2013-08-06 17:25 alostale Status scheduled => resolved
2013-08-06 17:25 alostale Fixed in SCM revision => -
2013-08-06 17:25 alostale Resolution open => fixed
2013-08-06 17:25 alostale Status resolved => closed
2013-08-07 16:17 alostale Relationship added related to 0024504
2013-08-07 16:18 alostale Relationship deleted related to 0024504
2013-08-07 16:27 hgbot Checkin
2013-08-07 16:27 hgbot Note Added: 0060535
2013-08-07 16:29 alostale Note Added: 0060539
2013-08-07 16:29 alostale Status closed => new
2013-08-07 16:29 alostale Resolution fixed => open
2013-08-16 20:32 hudsonbot Checkin
2013-08-16 20:32 hudsonbot Note Added: 0060636
2013-10-07 17:27 hgbot Checkin
2013-10-07 17:27 hgbot Note Added: 0061592
2013-10-07 17:27 hgbot Status new => resolved
2013-10-07 17:27 hgbot Resolution open => fixed
2013-10-07 17:27 hgbot Fixed in SCM revision - => http://code.openbravo.com/erp/devel/pi/rev/94d0fb15191969d20c2f89b919bec8a95ad33110 [^]
2013-10-16 19:46 hudsonbot Checkin
2013-10-16 19:46 hudsonbot Note Added: 0061730
2013-10-17 11:32 AugustoMauch Status resolved => closed
2013-10-17 11:32 AugustoMauch Fixed in Version => 3.0MP29
2017-06-22 17:25 caristu Relationship added related to 0036166


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker