Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024320
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2013-07-11 18:092013-08-20 13:01
ReporteradrianromeroView Statuspublic 
Assigned Toguilleaer 
PriorityurgentResolutionfixedFixed in VersionRMP26
StatusclosedFix in branchpiFixed in SCM revisiond66b1b2010ce
ProjectionnoneETAnoneTarget VersionRMP26
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024320: Going to the login page does not log out from web pos

DescriptionAfter a successfully login while you are in the main retail page:

web/org.openbravo.retail.posterminal/?terminal=VBS-1#retail.pointofsale

if you go directly to the login page without loggin out first:

web/org.openbravo.retail.posterminal/?terminal=VBS-1#login
 
You are not logged out from the first session.

This is specially important in ondemand instances because one user is allowed to have only one session active at a time: http://wiki.openbravo.com/wiki/Openbravo_On_Demand_FAQ#What_is_an_active_named_user.3F [^]

So if a user that successfully logs in into the application and goes to the login page without logging out first, it will not be prevented to log in again because there is an active session for him. The only way to unlock this situation is to ask an administrator to kill the session from the Openbravo backoffice.
Steps To ReproduceIn description
Proposed SolutionTwo possible approach

* Every time the user goes to the login page the application must log out automatically if there is an active session

* If the user goes to the login page and there is an active session, the application goes to the main page.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0059960)
dmitry_mezentsev (developer)
2013-07-12 19:56

I like the second approach more as it is similar to the back office.
(0060505)
hgbot (developer)
2013-08-05 19:24

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: d66b1b2010ce218c0ff791f3e43e17608fa0de9e
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Mon Aug 05 19:14:54 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d66b1b2010ce218c0ff791f3e43e17608fa0de9e [^]

fixed issue 24320: If login route is inserted manually in the url the login page is shown only if you are not logged. Otherwise main page will be shown

---
M web/org.openbravo.retail.posterminal/js/login/model/login-model.js
---

- Issue History
Date Modified Username Field Change
2013-07-11 18:09 adrianromero New Issue
2013-07-11 18:09 adrianromero Assigned To => marvintm
2013-07-12 19:56 dmitry_mezentsev Note Added: 0059960
2013-07-15 12:23 jecharri Target Version RMP25 => RMP26
2013-08-05 19:24 hgbot Checkin
2013-08-05 19:24 hgbot Note Added: 0060505
2013-08-05 19:24 hgbot Status new => resolved
2013-08-05 19:24 hgbot Resolution open => fixed
2013-08-05 19:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d66b1b2010ce218c0ff791f3e43e17608fa0de9e [^]
2013-08-20 12:55 marvintm Review Assigned To => marvintm
2013-08-20 12:55 marvintm Status resolved => closed
2013-08-20 12:55 marvintm Fixed in Version => RMP26
2013-08-20 12:58 guilleaer Assigned To marvintm => guilleaer
2013-08-20 12:58 guilleaer Note Added: 0060679
2013-08-20 12:58 guilleaer Status closed => new
2013-08-20 12:58 guilleaer Resolution fixed => open
2013-08-20 12:58 guilleaer Fixed in Version RMP26 =>
2013-08-20 12:59 guilleaer Note Deleted: 0060679
2013-08-20 13:00 guilleaer Status new => acknowledged
2013-08-20 13:00 guilleaer Status acknowledged => scheduled
2013-08-20 13:00 guilleaer fix_in_branch => pi
2013-08-20 13:00 guilleaer Status scheduled => resolved
2013-08-20 13:00 guilleaer Fixed in Version => RMP26
2013-08-20 13:00 guilleaer Resolution open => fixed
2013-08-20 13:01 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker