Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024012
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalhave not tried2013-06-06 14:442013-06-20 02:07
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0MP25
StatusclosedFix in branchFixed in SCM revision581ac6b95048
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-03-05
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/75cf7457df9c102c24bc8a1e51d67b7eae4cf2b4 [^]
Triggers an Emergency PackNo
Summary

0024012: Problem with query list widgets with boolean columns

DescriptionIf a query list widget has a boolean column whose value is taken from a boolean database column a java.lang.ClassCastException exception is thrown
Steps To Reproduce- Create a query list column, use this hql: select active as myBoolean1, 'N' as myBoolean2 from Product where name = 'Lemonade'
- Define two query YesNo parameters: myBoolean1 and myBoolean2
- Restart tomcat.
- Log in again and add the new widget to the workspace. It will not show any records and a ClassCastException will be thrown in the server
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0023200 closedAugustoMauch YesNo reference not working properly in Query/List widgets 

-  Notes
(0059247)
hgbot (developer)
2013-06-06 14:51

Repository: erp/devel/pi
Changeset: 581ac6b950488ffb6c65d682f0e22a1f907adba6
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Jun 06 14:51:21 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/581ac6b950488ffb6c65d682f0e22a1f907adba6 [^]

Fixes issue 24012: Query list widgets with boolean parameters works

Before trying to convert a 'Y' or 'N' string to boolean in this line [1], check that the value is a string, because sometimes at that point the value attribute can already be a boolean.

[1] https://code.openbravo.com/erp/devel/pi/file/4cd557c40816/modules/org.openbravo.client.querylist/src/org/openbravo/client/querylist/QueryListDataSource.java#l221 [^]

---
M modules/org.openbravo.client.querylist/src/org/openbravo/client/querylist/QueryListDataSource.java
---
(0059406)
shankarb (developer)
2013-06-13 08:44

Code reviewed and verified in pi changeset a148e16b1057
(0059546)
hudsonbot (developer)
2013-06-20 02:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5caf871044ad [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-06-06 14:44 AugustoMauch New Issue
2013-06-06 14:44 AugustoMauch Assigned To => AugustoMauch
2013-06-06 14:44 AugustoMauch Modules => Core
2013-06-06 14:44 AugustoMauch Triggers an Emergency Pack => No
2013-06-06 14:46 AugustoMauch Regression level => Production - Confirmed Stable
2013-06-06 14:46 AugustoMauch Regression date => 2013-03-05
2013-06-06 14:46 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/75cf7457df9c102c24bc8a1e51d67b7eae4cf2b4 [^]
2013-06-06 14:47 AugustoMauch Steps to Reproduce Updated View Revisions
2013-06-06 14:48 AugustoMauch Relationship added related to 0023200
2013-06-06 14:48 AugustoMauch Issue Monitored: shankarb
2013-06-06 14:49 AugustoMauch Review Assigned To => shankarb
2013-06-06 14:51 hgbot Checkin
2013-06-06 14:51 hgbot Note Added: 0059247
2013-06-06 14:51 hgbot Status new => resolved
2013-06-06 14:51 hgbot Resolution open => fixed
2013-06-06 14:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/581ac6b950488ffb6c65d682f0e22a1f907adba6 [^]
2013-06-13 08:44 shankarb Note Added: 0059406
2013-06-13 08:44 shankarb Status resolved => closed
2013-06-13 08:44 shankarb Fixed in Version => 3.0MP25
2013-06-20 02:07 hudsonbot Checkin
2013-06-20 02:07 hudsonbot Note Added: 0059546


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker