Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024005
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-06-06 12:202013-06-20 02:08
ReporteregoitzView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0MP24
StatusclosedFix in branchpiFixed in SCM revisiona01dafe2de40
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2011-02-09
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/3cc3d1a740b29ae39c0eadb9e2f498124c980514 [^]
Triggers an Emergency PackNo
Summary

0024005: When doing changes on an element using dal the Ad_context_info is not filled so the audit does not work properly

DescriptionWhen doing changes on an element using dal the Ad_context_info is not filled so the audit does not work properly.

When saving or changing a row of and audited table, from an standard window, the audit saves the user, the process and process type, taking it from the ad_context_info table.

If the changes are done from a java class using DAL, and the java class implements org.openbravo.scheduling.Process , in these case the audit does not save the user, process and processtype.

Steps To Reproduce-Create a new column on the m_product table.
-Create the column and field on an application dictionary.
-Create a java process implementing org.openbravo.scheduling.Process. The java will update the description of the product.
-Define the process on AD and assign to the new column.
-Check the m_product table to be audited and run update audit infrastructure prcoess.
-After compile all the previous changes go to the application.
-Change a product using the window.
-See that on the ad_audit_trail table a new row is inserted for that change. This also includes user, process and process type values.
-Execute the button
*See that a new row is inserted on ad_audit_trail table, but the columns user,process and processtype are not updated.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00158742.50MP27 closedalostale Permissions to processes are not respected 
related to defect 0034766 closedalostale Incomplete audit trail info for elements created from WebPOS 

-  Notes
(0059316)
alostale (developer)
2013-06-11 09:49

Review also P&E and Param Windows
(0059368)
alostale (developer)
2013-06-11 17:34
edited on: 2013-06-11 17:36

Test plan for this issue is in TestLink -> Audit Trail -> Communit-7300:Audit trail in processes

Tested with DAL and XSQL. In XSQL tested getting connection with bundle.getConnection and new DalConnectionProvider()

(0059369)
hgbot (developer)
2013-06-11 17:38

Repository: erp/devel/pi
Changeset: a01dafe2de400a60e3c13af40d3e53400e3ad3a3
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jun 11 17:32:55 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a01dafe2de400a60e3c13af40d3e53400e3ad3a3 [^]

fixed bug 24005: incomplete audit trail info in processes

  Audit trail information was missing process and/or user in the following cases:

   1. Java processes using DAL invoked from generated windows
   2. Java processes using DAL invoked from menu
   3. Process definition

  In cases 1 and 2, the problem was audit info was set in ThreadLocal after the
  DB temporary table was updated.

  In case 3, it was not set at all.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/process/BaseProcessActionHandler.java
M src-core/src/org/openbravo/database/SessionInfo.java
M src-db/database/sourcedata/AD_REF_LIST.xml
M src-wad/src/org/openbravo/wad/ActionButtonJava_Responser.javaxml
M src-wad/src/org/openbravo/wad/ActionButton_Responser.javaxml
M src-wad/src/org/openbravo/wad/Wad.java
M src-wad/src/org/openbravo/wad/javasource.javaxml
M src-wad/src/org/openbravo/wad/javasource.xml
M src/org/openbravo/erpCommon/businessUtility/AuditTrailPopup.java
M src/org/openbravo/scheduling/ProcessBundle.java
---
(0059374)
alostale (developer)
2013-06-12 08:26

Regression introduced in 2.50MP27/3.0RC4
(0059424)
AugustoMauch (developer)
2013-06-13 17:06

Code reviewed and verified in pi@bde534f03bd4
(0059568)
hudsonbot (developer)
2013-06-20 02:08

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5caf871044ad [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-06-06 12:20 egoitz New Issue
2013-06-06 12:20 egoitz Assigned To => AugustoMauch
2013-06-06 12:20 egoitz Modules => Core
2013-06-06 12:20 egoitz Triggers an Emergency Pack => No
2013-06-06 16:02 egoitz Priority urgent => immediate
2013-06-11 09:49 alostale Note Added: 0059316
2013-06-11 17:04 alostale Assigned To AugustoMauch => alostale
2013-06-11 17:05 alostale Review Assigned To => AugustoMauch
2013-06-11 17:34 alostale Note Added: 0059368
2013-06-11 17:36 alostale Note Edited: 0059368 View Revisions
2013-06-11 17:38 hgbot Checkin
2013-06-11 17:38 hgbot Note Added: 0059369
2013-06-11 17:38 hgbot Status new => resolved
2013-06-11 17:38 hgbot Resolution open => fixed
2013-06-11 17:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a01dafe2de400a60e3c13af40d3e53400e3ad3a3 [^]
2013-06-12 08:25 alostale Status resolved => new
2013-06-12 08:25 alostale Resolution fixed => open
2013-06-12 08:26 alostale Regression level => Production - Confirmed Stable
2013-06-12 08:26 alostale Regression date => 2011-02-09
2013-06-12 08:26 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/3cc3d1a740b29ae39c0eadb9e2f498124c980514 [^]
2013-06-12 08:26 alostale Relationship added related to 0015874
2013-06-12 08:26 alostale Note Added: 0059374
2013-06-12 08:27 alostale Status new => scheduled
2013-06-12 08:27 alostale fix_in_branch => pi
2013-06-12 08:27 alostale Status scheduled => resolved
2013-06-12 08:27 alostale Resolution open => fixed
2013-06-13 17:06 AugustoMauch Note Added: 0059424
2013-06-13 17:06 AugustoMauch Status resolved => closed
2013-06-13 17:06 AugustoMauch Fixed in Version => 3.0MP24
2013-06-20 02:08 hudsonbot Checkin
2013-06-20 02:08 hudsonbot Note Added: 0059568
2016-12-19 11:02 alostale Relationship added related to 0034766


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker