Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023972
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-06-04 07:152013-06-06 11:51
ReportersureshbabuView Statuspublic 
Assigned Toadrianromero 
PriorityhighResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revision921fe0406ce5
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023972: In layaway order When i do a partial payment, payment details are not getting updated in the database

DescriptionIn layaway order When i do a partial payment, payment details are not getting updated in the database
Steps To Reproduce1) Create a layaway order for amount 494.55, and do a partial payment for amount 400 euros. Then close the layaway order by clicking the Layaway button

2) Then reopen the layaway order and do another partial payment for amount 40 euros and close the layaway order by clicking the Layaway button

Defect: Then reopen the layaway order and verify the payment details in the Payment breakdown section in webpos, only 400 euros appears in the payment breakdown section and not the 40 euros.

Also in the ERP, at sales order, at payment plan only 400 euros appears in Received column.

Note: But in the print ticker copy shows both the payment details


TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0059140)
hgbot (developer)
2013-06-04 09:21

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 921fe0406ce5c1190f76837346b18aca92bbc2ac
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Tue Jun 04 09:21:28 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/921fe0406ce5c1190f76837346b18aca92bbc2ac [^]

Fixed issue 23972. Partial payments in layaways will now be created correctly.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0059146)
guilleaer (developer)
2013-06-04 10:35

verified
(0059159)
hgbot (developer)
2013-06-04 10:54

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: 921fe0406ce5c1190f76837346b18aca92bbc2ac
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Tue Jun 04 09:21:28 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/921fe0406ce5c1190f76837346b18aca92bbc2ac [^]

Fixed issue 23972. Partial payments in layaways will now be created correctly.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0059229)
guilleaer (developer)
2013-06-06 11:51

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-06-04 07:15 sureshbabu New Issue
2013-06-04 07:15 sureshbabu Assigned To => adrianromero
2013-06-04 07:21 sureshbabu Steps to Reproduce Updated View Revisions
2013-06-04 09:21 hgbot Checkin
2013-06-04 09:21 hgbot Note Added: 0059140
2013-06-04 09:21 hgbot Status new => resolved
2013-06-04 09:21 hgbot Resolution open => fixed
2013-06-04 09:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/921fe0406ce5c1190f76837346b18aca92bbc2ac [^]
2013-06-04 10:35 guilleaer Review Assigned To => guilleaer
2013-06-04 10:35 guilleaer Note Added: 0059146
2013-06-04 10:35 guilleaer Status resolved => closed
2013-06-04 10:35 guilleaer Fixed in Version => RMP23
2013-06-04 10:54 hgbot Checkin
2013-06-04 10:54 hgbot Note Added: 0059159
2013-06-04 10:54 hgbot Status closed => resolved
2013-06-04 10:54 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/921fe0406ce5c1190f76837346b18aca92bbc2ac [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/921fe0406ce5c1190f76837346b18aca92bbc2ac [^]
2013-06-06 11:51 guilleaer Note Added: 0059229
2013-06-06 11:51 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker