Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023905
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminorhave not tried2013-05-23 17:022013-06-06 11:53
ReportermarvintmView Statuspublic 
Assigned Tomarvintm 
PrioritynormalResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revision2c937f978d56
ProjectionnoneETAnoneTarget VersionRMP23
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023905: Wrong message when logging out in offline situation

DescriptionCurrently, in the Web POS, if the user logs out of the application while being offline, or in general if he reloads the page, a Javascript alert will be shown, with the following message:

"You should not close this window in offline mode."

This alert is wrong, because currently offline mode exists and can be used without problems, and the user will be wrongly alarmed by it.
Steps To Reproduce- Log in the Web POS.
- Go offline
- Log out. Verify that after the normal enyo confirm dialog, a standard Javascript alert will be shown with the described message.
Proposed SolutionThis alert should be removed as it's no longer useful.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0058914)
hgbot (developer)
2013-05-23 17:57

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 2c937f978d56ba3cf4321645500f196f15b3fcc9
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu May 23 17:56:55 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2c937f978d56ba3cf4321645500f196f15b3fcc9 [^]

Fixed issue 23905. Removed wrong alert shown when offline

---
M web/org.openbravo.retail.posterminal/js/main.js
---
(0058985)
guilleaer (developer)
2013-05-28 12:22

verified
(0059039)
hgbot (developer)
2013-05-29 12:20

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: 2c937f978d56ba3cf4321645500f196f15b3fcc9
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu May 23 17:56:55 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/2c937f978d56ba3cf4321645500f196f15b3fcc9 [^]

Fixed issue 23905. Removed wrong alert shown when offline

---
M web/org.openbravo.retail.posterminal/js/main.js
---
(0059232)
guilleaer (developer)
2013-06-06 11:53

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-05-23 17:02 marvintm New Issue
2013-05-23 17:02 marvintm Assigned To => marvintm
2013-05-23 17:57 hgbot Checkin
2013-05-23 17:57 hgbot Note Added: 0058914
2013-05-23 17:57 hgbot Status new => resolved
2013-05-23 17:57 hgbot Resolution open => fixed
2013-05-23 17:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2c937f978d56ba3cf4321645500f196f15b3fcc9 [^]
2013-05-28 12:22 guilleaer Review Assigned To => guilleaer
2013-05-28 12:22 guilleaer Note Added: 0058985
2013-05-28 12:22 guilleaer Status resolved => closed
2013-05-28 12:22 guilleaer Fixed in Version => RMP23
2013-05-29 12:20 hgbot Checkin
2013-05-29 12:20 hgbot Note Added: 0059039
2013-05-29 12:20 hgbot Status closed => resolved
2013-05-29 12:20 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2c937f978d56ba3cf4321645500f196f15b3fcc9 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/2c937f978d56ba3cf4321645500f196f15b3fcc9 [^]
2013-06-06 11:53 guilleaer Note Added: 0059232
2013-06-06 11:53 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker