Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023770
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-05-08 18:292013-06-27 18:17
ReporteregoitzView Statuspublic 
Assigned Toshankarb 
PriorityurgentResolutionduplicateFixed in Version
StatusclosedFix in branchFixed in SCM revisionb580f0596d0e
ProjectionnoneETAnoneTarget Version3.0MP25
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023770: The warning from Jasper are creating big logs of tomcat and the log is not readable

DescriptionThe warning from Jasper are creating big logs of tomcat and the log is not readable
Steps To Reproduce-Access to sales invoice window
-Print the report
-Check the openbravo.log at tomcat
*See that there are a lot of warning related with Jasper
Proposed SolutionAdd on log4j.lcf file the following line to show only the errors:

log4j.category.net.sf.jasperreports=ERROR
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of design defect 0020600 scheduledTriage Finance Arabic characters set are not printed on the standar reports. 

-  Notes
(0058512)
hgbot (developer)
2013-05-09 08:17

Repository: erp/devel/pi
Changeset: b580f0596d0e41a782117fefd0b499a1d51e7661
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu May 09 11:44:03 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/b580f0596d0e41a782117fefd0b499a1d51e7661 [^]

Fixes Issue 0023770: The warning from Jasper are creating big logs of tomcat and the log is not readable

---
M config/log4j.lcf.template
---
(0058513)
hgbot (developer)
2013-05-09 08:23

Repository: erp/devel/pi
Changeset: 1143dac7c18c59880d85812025a65e0b53c01d65
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu May 09 11:52:52 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/1143dac7c18c59880d85812025a65e0b53c01d65 [^]

Related to Issue 23770 : Updated copyright year

---
M config/log4j.lcf.template
---
(0058686)
AugustoMauch (developer)
2013-05-17 14:29

Code reviewed and verified in pi@2f11b5d67c9a
(0058781)
hudsonbot (developer)
2013-05-23 01:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/97c7f6256af7 [^]

Maturity status: Test
(0058782)
hudsonbot (developer)
2013-05-23 01:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/97c7f6256af7 [^]

Maturity status: Test
(0059076)
hgbot (developer)
2013-05-30 16:58

Repository: erp/devel/pi
Changeset: 1693de72b307b58c297756ed589a605236b359d8
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu May 30 16:56:01 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1693de72b307b58c297756ed589a605236b359d8 [^]

Related to issue 23770: Backed out change, some warning should be logged

The approach used in this fix (modifying the template so only the jasper error are logged by default) should be improved. Instead of not logging any warning, we should try to reduce the number of warnings logged by fixing them. I.e. lots of warnings are related to the use of deprecated methods, those can be avoided by using the @supresswarnings annotation or by using a not deprecated method.

---
M config/log4j.lcf.template
---
(0059111)
hudsonbot (developer)
2013-06-01 02:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/31f9b82dde77 [^]

Maturity status: Test
(0059418)
AugustoMauch (developer)
2013-06-13 13:47

JRProperties.getBooleanProperty(propertiesHolder, JRStyledText.PROPERTY_AWT_IGNORE_MISSING_FONT, false)
(0059715)
AugustoMauch (developer)
2013-06-27 18:17

Almost all of the warnings shown when a Jasper Report is opened is caused by a missing font warning.

In the fix of the issue 20600 all fonts were changed, but the fix was backed out because all reports had to be checked.

- Issue History
Date Modified Username Field Change
2013-05-08 18:29 egoitz New Issue
2013-05-08 18:29 egoitz Assigned To => AugustoMauch
2013-05-08 18:29 egoitz Modules => Core
2013-05-08 18:29 egoitz Triggers an Emergency Pack => No
2013-05-09 05:06 shankarb Status new => scheduled
2013-05-09 05:06 shankarb fix_in_branch => pi
2013-05-09 05:06 shankarb Assigned To AugustoMauch => shankarb
2013-05-09 08:16 alostale Severity critical => trivial
2013-05-09 08:16 alostale fix_in_branch pi =>
2013-05-09 08:16 shankarb Review Assigned To => AugustoMauch
2013-05-09 08:16 shankarb Severity trivial => critical
2013-05-09 08:17 shankarb Issue Monitored: AugustoMauch
2013-05-09 08:17 hgbot Checkin
2013-05-09 08:17 hgbot Note Added: 0058512
2013-05-09 08:17 hgbot Status scheduled => resolved
2013-05-09 08:17 hgbot Resolution open => fixed
2013-05-09 08:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b580f0596d0e41a782117fefd0b499a1d51e7661 [^]
2013-05-09 08:23 hgbot Checkin
2013-05-09 08:23 hgbot Note Added: 0058513
2013-05-17 14:29 AugustoMauch Note Added: 0058686
2013-05-17 14:29 AugustoMauch Status resolved => closed
2013-05-17 14:29 AugustoMauch Fixed in Version => 3.0MP24
2013-05-23 01:32 hudsonbot Checkin
2013-05-23 01:32 hudsonbot Note Added: 0058781
2013-05-23 01:32 hudsonbot Checkin
2013-05-23 01:32 hudsonbot Note Added: 0058782
2013-05-30 16:57 AugustoMauch Status closed => new
2013-05-30 16:57 AugustoMauch Resolution fixed => open
2013-05-30 16:57 AugustoMauch Fixed in Version 3.0MP24 =>
2013-05-30 16:58 hgbot Checkin
2013-05-30 16:58 hgbot Note Added: 0059076
2013-05-30 16:58 AugustoMauch Target Version 3.0MP24 => 3.0MP25
2013-06-01 02:15 hudsonbot Checkin
2013-06-01 02:15 hudsonbot Note Added: 0059111
2013-06-03 10:33 AugustoMauch Priority immediate => urgent
2013-06-03 10:33 AugustoMauch Severity critical => major
2013-06-13 13:47 AugustoMauch Note Added: 0059418
2013-06-27 18:17 AugustoMauch Relationship added duplicate of 0020600
2013-06-27 18:17 AugustoMauch Note Added: 0059715
2013-06-27 18:17 AugustoMauch Status new => closed
2013-06-27 18:17 AugustoMauch Resolution open => duplicate


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker