Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023769
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-05-08 18:042013-06-06 11:57
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityimmediateResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revisioncf2253c04fb2
ProjectionnoneETAnoneTarget VersionRMP23
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRMP21SCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023769: Problem with hardware manager and network

DescriptionProblem with hardware manager and network

If the network has a short cut when you send the ticket to be printed, the ticket is not printed and the error is not displayed in web POS
Steps To Reproduce-login in web POS
-create a ticket
-push in total
-push in Ok button
-when you are going to push the done button unplug the network in the hardware manager PC

Verify that the ticket is not printed and the error is not shown in the web POS
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0058622)
hgbot (developer)
2013-05-13 15:44

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: cf2253c04fb27caf770ed2c9b36a36e526611c3a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 13 15:38:35 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/cf2253c04fb27caf770ed2c9b36a36e526611c3a [^]

Fixed issue 23769. Two changes have been made:
- A timeout has been added to the print ajax request. This ensures that the user will be notified in a reasonable time that the printing request failed.
- In case a whole receipt is being printed, the red error message has been replaced by a popup confirmation dialog, which allows the user to reissue the printing command in case it failed.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/datasource.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-print.js
---
(0058860)
hgbot (developer)
2013-05-23 07:51

Repository: erp/pmods/org.openbravo.retail.posterminal.ch
Changeset: cf2253c04fb27caf770ed2c9b36a36e526611c3a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 13 15:38:35 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/cf2253c04fb27caf770ed2c9b36a36e526611c3a [^]

Fixed issue 23769. Two changes have been made:
- A timeout has been added to the print ajax request. This ensures that the user will be notified in a reasonable time that the printing request failed.
- In case a whole receipt is being printed, the red error message has been replaced by a popup confirmation dialog, which allows the user to reissue the printing command in case it failed.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/datasource.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-print.js
---
(0059022)
hgbot (developer)
2013-05-29 12:18

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: cf2253c04fb27caf770ed2c9b36a36e526611c3a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 13 15:38:35 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/cf2253c04fb27caf770ed2c9b36a36e526611c3a [^]

Fixed issue 23769. Two changes have been made:
- A timeout has been added to the print ajax request. This ensures that the user will be notified in a reasonable time that the printing request failed.
- In case a whole receipt is being printed, the red error message has been replaced by a popup confirmation dialog, which allows the user to reissue the printing command in case it failed.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.retail.posterminal/js/datasource.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-print.js
---
(0059236)
guilleaer (developer)
2013-06-06 11:57

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-05-08 18:04 jecharri New Issue
2013-05-08 18:04 jecharri Assigned To => marvintm
2013-05-08 18:06 jecharri Priority high => immediate
2013-05-13 15:44 hgbot Checkin
2013-05-13 15:44 hgbot Note Added: 0058622
2013-05-13 15:44 hgbot Status new => resolved
2013-05-13 15:44 hgbot Resolution open => fixed
2013-05-13 15:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/cf2253c04fb27caf770ed2c9b36a36e526611c3a [^]
2013-05-23 07:51 hgbot Checkin
2013-05-23 07:51 hgbot Note Added: 0058860
2013-05-23 07:51 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/cf2253c04fb27caf770ed2c9b36a36e526611c3a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/cf2253c04fb27caf770ed2c9b36a36e526611c3a [^]
2013-05-28 13:49 guilleaer Review Assigned To => guilleaer
2013-05-28 13:49 guilleaer Status resolved => closed
2013-05-28 13:49 guilleaer Fixed in Version => RMP23
2013-05-29 12:18 hgbot Checkin
2013-05-29 12:18 hgbot Note Added: 0059022
2013-05-29 12:18 hgbot Status closed => resolved
2013-05-29 12:18 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/cf2253c04fb27caf770ed2c9b36a36e526611c3a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/cf2253c04fb27caf770ed2c9b36a36e526611c3a [^]
2013-06-06 11:57 guilleaer Note Added: 0059236
2013-06-06 11:57 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker