Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023749
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-05-07 00:492013-06-06 11:57
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityurgentResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revision095233ac9d38
ProjectionnoneETAnoneTarget VersionRMP23
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRMP21SCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023749: When the server is collapsed work in web POS is impossible

DescriptionWhen the server is collapsed work in web POS is impossible.

You need to logout and login. In this way the application knows that the server is not working fine and it does the login in offline mode.

It will be really interesting if this change will be automatic. For example if you are working an answer from the server is taking a long time, the application should go to offline mode
Steps To Reproduce-collapse the system and verify that you can not work in web POS if you do not logout and login

P.S.: if you want to collapse the server you can start tomcat with really low memory
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0058476)
mtaal (manager)
2013-05-07 08:55

To add, the client should do to offline mode also when requests to the server take too long time. You don't need to let the server collapse to test this. Add a thread wait here and there in the server side code to simulate a request to wait long.
(0058624)
hgbot (developer)
2013-05-13 18:03

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 095233ac9d388e6ca23ef535659181b42558f1f4
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 13 18:02:53 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/095233ac9d388e6ca23ef535659181b42558f1f4 [^]

Fixed issue 23749. Added timeout to order and customer creation, so that they don't fail if the server is overloaded

---
M web/org.openbravo.retail.posterminal/js/data/datacustomersave.js
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
M web/org.openbravo.retail.posterminal/js/utils/customersSyncUtils.js
M web/org.openbravo.retail.posterminal/js/utils/ordersSyncUtils.js
---
(0058625)
hgbot (developer)
2013-05-13 18:06

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: f66c3c7d64157fae91b64ebfe53dedf203ebd64a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 13 18:03:26 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/f66c3c7d64157fae91b64ebfe53dedf203ebd64a [^]

Fixed issue 23749. Added the ability to specify a timeout in a datasource request

---
M web/org.openbravo.mobile.core/source/data/ob-datasource.js
---
(0058861)
hgbot (developer)
2013-05-23 07:51

Repository: erp/pmods/org.openbravo.retail.posterminal.ch
Changeset: 095233ac9d388e6ca23ef535659181b42558f1f4
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 13 18:02:53 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/095233ac9d388e6ca23ef535659181b42558f1f4 [^]

Fixed issue 23749. Added timeout to order and customer creation, so that they don't fail if the server is overloaded

---
M web/org.openbravo.retail.posterminal/js/data/datacustomersave.js
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
M web/org.openbravo.retail.posterminal/js/utils/customersSyncUtils.js
M web/org.openbravo.retail.posterminal/js/utils/ordersSyncUtils.js
---
(0058878)
hgbot (developer)
2013-05-23 07:55

Repository: erp/pmods/org.openbravo.mobile.core.ch
Changeset: f66c3c7d64157fae91b64ebfe53dedf203ebd64a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 13 18:03:26 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core.ch/rev/f66c3c7d64157fae91b64ebfe53dedf203ebd64a [^]

Fixed issue 23749. Added the ability to specify a timeout in a datasource request

---
M web/org.openbravo.mobile.core/source/data/ob-datasource.js
---
(0058998)
guilleaer (developer)
2013-05-28 16:10

verified
(0059023)
hgbot (developer)
2013-05-29 12:18

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: 095233ac9d388e6ca23ef535659181b42558f1f4
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon May 13 18:02:53 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/095233ac9d388e6ca23ef535659181b42558f1f4 [^]

Fixed issue 23749. Added timeout to order and customer creation, so that they don't fail if the server is overloaded

---
M web/org.openbravo.retail.posterminal/js/data/datacustomersave.js
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
M web/org.openbravo.retail.posterminal/js/utils/customersSyncUtils.js
M web/org.openbravo.retail.posterminal/js/utils/ordersSyncUtils.js
---
(0059237)
guilleaer (developer)
2013-06-06 11:57

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-05-07 00:49 jecharri New Issue
2013-05-07 00:49 jecharri Assigned To => marvintm
2013-05-07 08:55 mtaal Note Added: 0058476
2013-05-13 18:03 hgbot Checkin
2013-05-13 18:03 hgbot Note Added: 0058624
2013-05-13 18:03 hgbot Status new => resolved
2013-05-13 18:03 hgbot Resolution open => fixed
2013-05-13 18:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/095233ac9d388e6ca23ef535659181b42558f1f4 [^]
2013-05-13 18:06 hgbot Checkin
2013-05-13 18:06 hgbot Note Added: 0058625
2013-05-13 18:06 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/095233ac9d388e6ca23ef535659181b42558f1f4 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/f66c3c7d64157fae91b64ebfe53dedf203ebd64a [^]
2013-05-23 07:51 hgbot Checkin
2013-05-23 07:51 hgbot Note Added: 0058861
2013-05-23 07:51 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/f66c3c7d64157fae91b64ebfe53dedf203ebd64a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/095233ac9d388e6ca23ef535659181b42558f1f4 [^]
2013-05-23 07:55 hgbot Checkin
2013-05-23 07:55 hgbot Note Added: 0058878
2013-05-23 07:55 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/095233ac9d388e6ca23ef535659181b42558f1f4 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core.ch/rev/f66c3c7d64157fae91b64ebfe53dedf203ebd64a [^]
2013-05-28 16:10 guilleaer Review Assigned To => guilleaer
2013-05-28 16:10 guilleaer Note Added: 0058998
2013-05-28 16:10 guilleaer Status resolved => closed
2013-05-28 16:10 guilleaer Fixed in Version => RMP23
2013-05-29 12:18 hgbot Checkin
2013-05-29 12:18 hgbot Note Added: 0059023
2013-05-29 12:18 hgbot Status closed => resolved
2013-05-29 12:18 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core.ch/rev/f66c3c7d64157fae91b64ebfe53dedf203ebd64a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/095233ac9d388e6ca23ef535659181b42558f1f4 [^]
2013-06-06 11:57 guilleaer Note Added: 0059237
2013-06-06 11:57 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker