Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023515
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-04-09 12:542013-06-06 11:59
ReportercaristuView Statuspublic 
Assigned Tomigueldejuana 
PrioritynormalResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revisionb8a074f5c266
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023515: Not possible to delete reconciliations

DescriptionIt is not possible to delete a reconciliation generated by a cash-up because of the Cash Up History related to it is not deleted.
Steps To Reproduce1) Execute the cash-up in web pos
2) Go to [Financial Account] and look for the reconciliation generated by the cash-up
3) Reactivate it. It will be in Draft status.
4) Delete it. This can't be done. Check the linked items. Notice that the Cash Up History from the POS Terminal is present.
Proposed SolutionPut the foreign key for fin_reconciliation_id in the obpos_app_cash_reconcil to on delete cascade. Also the related register must be remove from the obpos_app_cashup table.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0058755)
hgbot (developer)
2013-05-22 17:34

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: b8a074f5c2661032b91854cd4daf11476f13c099
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 22 17:29:04 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b8a074f5c2661032b91854cd4daf11476f13c099 [^]

Fixed issue 23515. Reconciliations will now be deleteable even if their history is saved (provided that they are not associated with any transaction)

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0058875)
hgbot (developer)
2013-05-23 07:52

Repository: erp/pmods/org.openbravo.retail.posterminal.ch
Changeset: b8a074f5c2661032b91854cd4daf11476f13c099
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 22 17:29:04 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/b8a074f5c2661032b91854cd4daf11476f13c099 [^]

Fixed issue 23515. Reconciliations will now be deleteable even if their history is saved (provided that they are not associated with any transaction)

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0058904)
guilleaer (developer)
2013-05-23 13:03

verified
(0059037)
hgbot (developer)
2013-05-29 12:20

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: b8a074f5c2661032b91854cd4daf11476f13c099
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 22 17:29:04 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/b8a074f5c2661032b91854cd4daf11476f13c099 [^]

Fixed issue 23515. Reconciliations will now be deleteable even if their history is saved (provided that they are not associated with any transaction)

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0059240)
guilleaer (developer)
2013-06-06 11:59

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-04-09 12:54 caristu New Issue
2013-04-09 12:54 caristu Assigned To => migueldejuana
2013-04-09 12:55 caristu Issue Monitored: networkb
2013-05-22 17:34 hgbot Checkin
2013-05-22 17:34 hgbot Note Added: 0058755
2013-05-22 17:34 hgbot Status new => resolved
2013-05-22 17:34 hgbot Resolution open => fixed
2013-05-22 17:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b8a074f5c2661032b91854cd4daf11476f13c099 [^]
2013-05-23 07:52 hgbot Checkin
2013-05-23 07:52 hgbot Note Added: 0058875
2013-05-23 07:52 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b8a074f5c2661032b91854cd4daf11476f13c099 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/b8a074f5c2661032b91854cd4daf11476f13c099 [^]
2013-05-23 13:03 guilleaer Review Assigned To => guilleaer
2013-05-23 13:03 guilleaer Note Added: 0058904
2013-05-23 13:03 guilleaer Status resolved => closed
2013-05-23 13:03 guilleaer Fixed in Version => RMP23
2013-05-29 12:20 hgbot Checkin
2013-05-29 12:20 hgbot Note Added: 0059037
2013-05-29 12:20 hgbot Status closed => resolved
2013-05-29 12:20 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/b8a074f5c2661032b91854cd4daf11476f13c099 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/b8a074f5c2661032b91854cd4daf11476f13c099 [^]
2013-06-06 11:59 guilleaer Note Added: 0059240
2013-06-06 11:59 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker