Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023423
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-03-27 17:282013-06-19 11:52
ReportersureshbabuView Statuspublic 
Assigned Toguilleaer 
PriorityurgentResolutionfixedFixed in VersionRMP24
StatusclosedFix in branchpiFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023423: if you add payments to a layaway in differents days, the payment breakdown information always shows the order date

Description if you add payments to a layaway in differents days, the payment breakdown information always shows the order date in all payments done instead of the date when the payment was done.
Steps To Reproduce if you add payments to a layaway in differents days, the payment breakdown information always shows the order date in all payments done instead of the date when the payment was done.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0023467 closedguilleaer when i reopen the layaway order at payment breakdown section , server(ERP) date is displayed instead of payment date 

-  Notes
(0057510)
guilleaer (developer)
2013-03-27 17:31

resolved by this changeset:

https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f659a58d0bf0 [^]
(0057557)
marvintm (developer)
2013-04-02 10:45

The fix has two main problems:

- It will not work correctly if the order was created in offline mode
- It will not work correctly if the server has a different time zone than the client

The fix should be done differently: the payment date should be stored in the client, and then used when saving the payment in the server
(0057558)
hgbot (developer)
2013-04-02 10:48

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: cc3d3a29d570514f92a0088992a8ecbabbd0de16
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Apr 02 10:46:24 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/cc3d3a29d570514f92a0088992a8ecbabbd0de16 [^]

related to issue 23423. revert previous change due to incomplete solution

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0057713)
hgbot (developer)
2013-04-03 18:21

Repository: erp/pmods/org.openbravo.retail.posterminal-core
Changeset: cc3d3a29d570514f92a0088992a8ecbabbd0de16
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Apr 02 10:46:24 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal-core/rev/cc3d3a29d570514f92a0088992a8ecbabbd0de16 [^]

related to issue 23423. revert previous change due to incomplete solution

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0059400)
guilleaer (developer)
2013-06-12 15:32

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 468d68793ef75b4048d0119021bf2b614e5158e6
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Jun 12 15:25:56 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/468d68793ef75b4048d0119021bf2b614e5158e6 [^] [^]

fixed issue 23467 & 23423: Payment dates are shown correctly

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0059401)
guilleaer (developer)
2013-06-12 15:32

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 09c12966c6275f23737260c69659307f47186c61
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Jun 12 15:23:34 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/09c12966c6275f23737260c69659307f47186c61 [^] [^]

fixed issue 23467 & 23423: Payment dates are shown correctly

---
M src/org/openbravo/mobile/core/process/JSONPropertyToEntity.java
A src/org/openbravo/mobile/core/utils/OBMOBCUtils.java
---
(0059414)
guilleaer (developer)
2013-06-13 13:19

Check also this commit

https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/5d321b340fe3 [^]

- Issue History
Date Modified Username Field Change
2013-03-27 17:28 sureshbabu New Issue
2013-03-27 17:28 sureshbabu Assigned To => guilleaer
2013-03-27 17:31 guilleaer Status new => scheduled
2013-03-27 17:31 guilleaer fix_in_branch => pi
2013-03-27 17:31 guilleaer Note Added: 0057510
2013-03-27 17:31 guilleaer Status scheduled => resolved
2013-03-27 17:31 guilleaer Fixed in Version => RMP21
2013-03-27 17:31 guilleaer Resolution open => fixed
2013-04-02 10:45 marvintm Note Added: 0057557
2013-04-02 10:45 marvintm Status resolved => new
2013-04-02 10:45 marvintm Resolution fixed => open
2013-04-02 10:45 marvintm Fixed in Version RMP21 =>
2013-04-02 10:48 hgbot Checkin
2013-04-02 10:48 hgbot Note Added: 0057558
2013-04-03 18:21 hgbot Checkin
2013-04-03 18:21 hgbot Note Added: 0057713
2013-04-08 09:10 guilleaer Relationship added related to 0023467
2013-06-12 15:32 guilleaer Status new => scheduled
2013-06-12 15:32 guilleaer Note Added: 0059400
2013-06-12 15:32 guilleaer Status scheduled => resolved
2013-06-12 15:32 guilleaer Fixed in Version => RMP24
2013-06-12 15:32 guilleaer Resolution open => fixed
2013-06-12 15:32 guilleaer Note Added: 0059401
2013-06-13 13:19 guilleaer Note Added: 0059414
2013-06-19 11:52 marvintm Review Assigned To => marvintm
2013-06-19 11:52 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker