Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023379
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminorhave not tried2013-03-22 10:152013-06-06 11:59
ReporterjonalegriaesarteView Statuspublic 
Assigned Tomarvintm 
PrioritynormalResolutionfixedFixed in VersionRMP23
StatusclosedFix in branchFixed in SCM revision7f12b00bdb1d
ProjectionnoneETAnoneTarget VersionRMP23
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRMP20SCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023379: Quotations when Generate Invoice is flagged is not working fine

DescriptionWe have unchecked the "Group Orders in one invoice" flag and checked the
"Generate Invoice" flag to generate an Invoice for each of the orders created
at WebPOS.
With this set up the behaviour we expect is:
1. When creating a regular receipt it will be automatically flagged as "Invoice this
receipt" and the system will generate an invoice at the moment of closing the order.
2. When generating a Quotation no specific behaviour is expected.
3. When creating a Sales Order from the Quotation it should be flagged as "Invoice
this receipt" and the system will generate an invoice at the moment of closing the order.
Steps To ReproduceWe have been doing some tests and this is what we have seen:
1. When creating a regular receipt it is automatically flagged as "Invoice this
receipt" and the system generates an invoice at the moment of closing the order. CORRECT.
2. When generating a Quotation it is flagged as "Invoice". This can be misleading for
the user as it makes no sense
that a Quotation is invoiced. ERROR?
3a. If after setting the Quotation as Under Evaluation you convert it in a Sales
Order it is flagged as "Invoice this receipt". CORRECT.
3b. If after setting the Quotation as Under Evaluation you close it and later on you
select it (using the Quotations selector) and convert it in a Sales Order it is not
flagged as "Invoice this receipt". ERROR.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0058658)
hgbot (developer)
2013-05-15 11:28

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 7f12b00bdb1d398d62c5be6250fce4e386831b25
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 15 11:27:27 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7f12b00bdb1d398d62c5be6250fce4e386831b25 [^]

Fixed issue 23379. Two changes have been made:
- When a quotation is created, the 'generateinvoice' flag is removed
- When an order is generated from a quotation, the 'generateinvoice' flag is set to the value defined in the terminal information

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0058863)
hgbot (developer)
2013-05-23 07:52

Repository: erp/pmods/org.openbravo.retail.posterminal.ch
Changeset: 7f12b00bdb1d398d62c5be6250fce4e386831b25
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 15 11:27:27 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/7f12b00bdb1d398d62c5be6250fce4e386831b25 [^]

Fixed issue 23379. Two changes have been made:
- When a quotation is created, the 'generateinvoice' flag is removed
- When an order is generated from a quotation, the 'generateinvoice' flag is set to the value defined in the terminal information

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0058996)
guilleaer (developer)
2013-05-28 15:54

verified
(0059025)
hgbot (developer)
2013-05-29 12:19

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: 7f12b00bdb1d398d62c5be6250fce4e386831b25
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 15 11:27:27 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/7f12b00bdb1d398d62c5be6250fce4e386831b25 [^]

Fixed issue 23379. Two changes have been made:
- When a quotation is created, the 'generateinvoice' flag is removed
- When an order is generated from a quotation, the 'generateinvoice' flag is set to the value defined in the terminal information

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0059241)
guilleaer (developer)
2013-06-06 11:59

closed again because it has changed "automatically" to resolved

- Issue History
Date Modified Username Field Change
2013-03-22 10:15 jonalegriaesarte New Issue
2013-03-22 10:15 jonalegriaesarte Assigned To => marvintm
2013-05-13 17:16 jonalegriaesarte Target Version => RMP23
2013-05-15 11:28 hgbot Checkin
2013-05-15 11:28 hgbot Note Added: 0058658
2013-05-15 11:28 hgbot Status new => resolved
2013-05-15 11:28 hgbot Resolution open => fixed
2013-05-15 11:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7f12b00bdb1d398d62c5be6250fce4e386831b25 [^]
2013-05-23 07:52 hgbot Checkin
2013-05-23 07:52 hgbot Note Added: 0058863
2013-05-23 07:52 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/7f12b00bdb1d398d62c5be6250fce4e386831b25 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/7f12b00bdb1d398d62c5be6250fce4e386831b25 [^]
2013-05-28 15:54 guilleaer Review Assigned To => guilleaer
2013-05-28 15:54 guilleaer Note Added: 0058996
2013-05-28 15:54 guilleaer Status resolved => closed
2013-05-28 15:54 guilleaer Fixed in Version => RMP23
2013-05-29 12:19 hgbot Checkin
2013-05-29 12:19 hgbot Note Added: 0059025
2013-05-29 12:19 hgbot Status closed => resolved
2013-05-29 12:19 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.ch/rev/7f12b00bdb1d398d62c5be6250fce4e386831b25 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/7f12b00bdb1d398d62c5be6250fce4e386831b25 [^]
2013-06-06 11:59 guilleaer Note Added: 0059241
2013-06-06 11:59 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker